aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2015-02-17 09:26:17 +0800
committertruckman <truckman@FreeBSD.org>2015-02-17 09:26:17 +0800
commit8fccf4d637975fa27263bca4e20ae90a4373afea (patch)
tree3f707cbbc940665055c8eb7049070220d16c848a /editors
parent9b25f91c364180947e506f8a0df965f90bb519ef (diff)
downloadfreebsd-ports-gnome-8fccf4d637975fa27263bca4e20ae90a4373afea.tar.gz
freebsd-ports-gnome-8fccf4d637975fa27263bca4e20ae90a4373afea.tar.zst
freebsd-ports-gnome-8fccf4d637975fa27263bca4e20ae90a4373afea.zip
Switch back to USE_GCC=yes.
Work around this bug <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65009> in g++49 -Os optimzation by using -O0 optimization if we are compiling with g++49. Differential Revision: https://reviews.freebsd.org/D1607 Reviewed by: pfg Approved by: mat (mentor)
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-devel/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 7cfe7d199ab4..8a8d5c5017bd 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -101,7 +101,7 @@ USE_XORG= x11 ice xaw xau xext xrender xrandr \
xi xt xcursor xdamage xcomposite xfixes
USE_GL= gl glu
USE_GSTREAMER= yes
-USE_GCC= 4.8
+USE_GCC= yes
USES+= bison desktop-file-utils gmake perl5 pkgconfig python tar:xz
USE_PERL5= build
WITHOUT_CPU_CFLAGS= true
@@ -262,6 +262,11 @@ post-patch:
.if defined (USE_GCC)
${REINPLACE_CMD} -e "s+%%RPATH%%+-Wl,-rpath=${_GCC_RUNTIME}+" ${WRKSRC}/solenv/inc/unxfbsd.mk
${REINPLACE_CMD} -e "s+%%RPATH%%+-Wl,-rpath=${_GCC_RUNTIME}+" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk
+ # g++49 -Os sometimes leaves inline class methods undefined
+ if [ ${CXX} = g++49 ]; then \
+ ${REINPLACE_CMD} -e "s/ := -Os/ := -O0/" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk; \
+ ${REINPLACE_CMD} -e "s/=-Os /=-O0 /" ${WRKSRC}/solenv/inc/unxfbsdi.mk; \
+ fi
.else
${REINPLACE_CMD} -e "s+%%RPATH%%++" ${WRKSRC}/solenv/inc/unxfbsd.mk
${REINPLACE_CMD} -e "s+%%RPATH%%++" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk