aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-08-30 23:26:48 +0800
committernaddy <naddy@FreeBSD.org>2009-08-30 23:26:48 +0800
commit71f595bc7ee4e1e747f26ecfd8c38ecab8da783b (patch)
tree360ad833340b7cb3ba0e5747edfe49b1493e5d40 /editors
parent07acaa7bfb94e786d17ba4825b7d489df9c0be0b (diff)
downloadfreebsd-ports-gnome-71f595bc7ee4e1e747f26ecfd8c38ecab8da783b.tar.gz
freebsd-ports-gnome-71f595bc7ee4e1e747f26ecfd8c38ecab8da783b.tar.zst
freebsd-ports-gnome-71f595bc7ee4e1e747f26ecfd8c38ecab8da783b.zip
Fix segfault on 8.0.
PR: 138320 Submitted by: Andrew Brampton <brampton@gmail.com>
Diffstat (limited to 'editors')
-rw-r--r--editors/nano/Makefile1
-rw-r--r--editors/nano/files/patch-src_rcfile.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 3b7480f93db9..970870e56e2c 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nano
PORTVERSION= 2.0.9
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://www.nano-editor.org/dist/v2.0/ \
http://www.ewtoo.org/~astyanax/nano/dist/v2.0/
diff --git a/editors/nano/files/patch-src_rcfile.c b/editors/nano/files/patch-src_rcfile.c
new file mode 100644
index 000000000000..6dbf573c286c
--- /dev/null
+++ b/editors/nano/files/patch-src_rcfile.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/rcfile.c.orig
++++ src/rcfile.c
+@@ -612,7 +612,7 @@
+ {
+ char *buf = NULL;
+ ssize_t len;
+- size_t n;
++ size_t n = 0;
+
+ while ((len = getline(&buf, &n, rcstream)) > 0) {
+ char *ptr, *keyword, *option;