aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
committernetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
commit8d63fa8ce3e1cb7a464d405732fcf971c5848297 (patch)
treebef012ab5e448ce5c144b7bb40139ba1dfd902a6 /editors
parent5f5845bb3ad1db90d601456aaaea7343c4dabfc6 (diff)
downloadfreebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.gz
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.zst
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Diffstat (limited to 'editors')
-rw-r--r--editors/edith/Makefile6
-rw-r--r--editors/staroffice5/Makefile6
-rw-r--r--editors/staroffice52/Makefile8
-rw-r--r--editors/staroffice60/Makefile7
-rw-r--r--editors/staroffice70/Makefile7
5 files changed, 19 insertions, 15 deletions
diff --git a/editors/edith/Makefile b/editors/edith/Makefile
index 79cdac4b7076..540ce2461ed0 100644
--- a/editors/edith/Makefile
+++ b/editors/edith/Makefile
@@ -16,10 +16,9 @@ DISTFILES= edith1.55.common.tar.gz \
MAINTAINER= ports@FreeBSD.org
COMMENT= A X11 GUI editor for binary and plain text files
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
-USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
RESTRICTED= "Redistribution not allowed"
NO_BUILD= yes
@@ -29,7 +28,6 @@ MANCOMPRESSED= no
WRKSRC= ${WRKDIR}/edith
EDITHDIR= ${PREFIX}/lib/edith
-STRIP=
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/linux/edith ${PREFIX}/bin
diff --git a/editors/staroffice5/Makefile b/editors/staroffice5/Makefile
index 987adec11bad..dc94cc74415c 100644
--- a/editors/staroffice5/Makefile
+++ b/editors/staroffice5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 5.1a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors linux
MASTER_SITES= http://afug.hypermart.net/files/ \
ftp://ftp.stat.duke.edu/pub/Users/sto/StarOffice51a/
@@ -19,13 +19,14 @@ MAINTAINER= mb@imp.ch
COMMENT= Integrated wordprocessor/dbase/spreadheet/drawing/chart/browser
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
NO_LATEST_LINK= yes
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be downloaded direct from Sun via www interface'
USE_REINPLACE= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
IS_INTERACTIVE= yes
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
EXTRACT_CMD= ${CAT}
@@ -71,6 +72,7 @@ do-install:
@/compat/linux/sbin/ldconfig -f ${TMPDIR}/ld.so.conf.tmp
@${CAT} ${PKGMESSAGE}
@-TEMP=${TMPDIR} ${WRKDIR}/so51inst/office51/setup /net
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
@${INSTALL_DATA} ${WRKDIR}/applicat.rdb ${PREFIX}/Office51/bin
@${INSTALL_DATA} ${_DISTDIR}/libofa517li.so ${PREFIX}/Office51/lib
diff --git a/editors/staroffice52/Makefile b/editors/staroffice52/Makefile
index 40bc9cc72532..ae12d1d6f4ca 100644
--- a/editors/staroffice52/Makefile
+++ b/editors/staroffice52/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors linux
MASTER_SITES= ftp://ftp.csua.berkeley.edu/pub/.1/ports/distfiles/staroffice52/ \
ftp://sunsite.cnlab-switch.ch/mirror/staroffice/english/ \
@@ -32,8 +32,7 @@ EXTRACT_ONLY= 109939-03.tar.Z
MAINTAINER= mbr@FreeBSD.org
COMMENT= Integrated wordprocessor/dbase/spreadheet/drawing/chart/browser
-FETCH_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base-8
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+FETCH_DEPENDS= ${LINUX_BASE_PORT}
NO_LATEST_LINK= yes
ONLY_FOR_ARCHS= i386
@@ -42,6 +41,8 @@ CD_MOUNTPT= '/cdrom'
IS_INTERACTIVE= yes
NO_BUILD= yes
USE_REINPLACE= yes
+USE_LINUX= yes
+USE_X_PREFIY= yes
DIST_SUBDIR= staroffice52
WRKSRC= ${WRKDIR}/office52
TMPDIR= ${WRKDIR}/tmp
@@ -213,6 +214,7 @@ do-install:
@for file in ${SUNSOLVE}/* ; do \
${CP} -Rv $$file ${PREFIX}/office52/ ; \
done
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>"
.endif
post-install:
diff --git a/editors/staroffice60/Makefile b/editors/staroffice60/Makefile
index 6cbb8b0b1821..e890b2a7b57b 100644
--- a/editors/staroffice60/Makefile
+++ b/editors/staroffice60/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 6.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors linux
MASTER_SITES= ftp://ftp.sunsite.auc.dk/disk6/sun-patches/:patch \
ftp://ftp.math.ohio-state.edu/private/sun/.../:patch \
@@ -26,12 +26,12 @@ EXTRACT_ONLY= 112887-04.tar
MAINTAINER= mbr@FreeBSD.org
COMMENT= Wordprocessor/dbase/spreadheet/drawing/chart
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
NO_LATEST_LINK= yes
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be bought and downloaded direct from Sun via www interface'
+USE_LINUX= yes
+USE_X_PREFIX= yes
IS_INTERACTIVE= yes
NO_BUILD= yes
SOVERSION= ${PORTNAME}${PORTVERSION}
@@ -229,6 +229,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/staroffice6 ${PREFIX}/bin/staroffice-spadmin
@${LN} -fs ${PREFIX}/bin/staroffice6 ${PREFIX}/bin/staroffice-sweb
@${LN} -fs ${PREFIX}/bin/staroffice6 ${PREFIX}/bin/staroffice-swriter
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
@${ECHO} StarOffice6.0 has been installed successfully. In order to use
@${ECHO} it, execute ${PREFIX}/bin/staroffice6.
@${ECHO}
diff --git a/editors/staroffice70/Makefile b/editors/staroffice70/Makefile
index 048ba74c9e5f..ffff7c009307 100644
--- a/editors/staroffice70/Makefile
+++ b/editors/staroffice70/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 7.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors linux
MASTER_SITES= ftp://patches.sun.com/patchroot/all_unsigned/:patch \
ftp://ftp.sun.co.uk/pub/patches/:patch \
@@ -30,11 +30,11 @@ EXTRACT_ONLY= 116518-06.tar
MAINTAINER= mbr@FreeBSD.org
COMMENT= Wordprocessor/dbase/spreadheet/drawing/chart
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be bought and downloaded direct from Sun via www interface'
+USE_LINUX= yes
+USE_X_PREFIX= yes
IS_INTERACTIVE= yes
NO_BUILD= yes
SOVERSION= ${PORTNAME}${PORTVERSION}
@@ -243,6 +243,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/staroffice7 ${PREFIX}/bin/staroffice-spadmin
@${LN} -fs ${PREFIX}/bin/staroffice7 ${PREFIX}/bin/staroffice-sweb
@${LN} -fs ${PREFIX}/bin/staroffice7 ${PREFIX}/bin/staroffice-swriter
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
@${ECHO} StarOffice7.0 has been installed successfully. In order to use
@${ECHO} it, execute ${PREFIX}/bin/staroffice7.
@${ECHO}