aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-11-08 07:28:20 +0800
committerasami <asami@FreeBSD.org>2000-11-08 07:28:20 +0800
commitc6a520f6cada8f214b5fae4b3a64dd3766bcc7a6 (patch)
treea231c9f0a623731d42f6401a6582004e4332cf70 /editors
parent8a96405e11f66420af7a5706ae8aaee6764b18c6 (diff)
downloadfreebsd-ports-gnome-c6a520f6cada8f214b5fae4b3a64dd3766bcc7a6.tar.gz
freebsd-ports-gnome-c6a520f6cada8f214b5fae4b3a64dd3766bcc7a6.tar.zst
freebsd-ports-gnome-c6a520f6cada8f214b5fae4b3a64dd3766bcc7a6.zip
Change motif to a normal dependency. REQUIRES_MOTIF is now called
USE_MOTIF and generates a LIB_DEPENDS to x11-toolkits/open-motif. As before, it implies USE_XPM (and therefore USE_XLIB). Motif-dummy is removed from PKG_IGNORE_DEPENDS, whose sole resident is now XFree86-3. Most of the simple ".if defined(HAVE_MOTIF)"s are removed to always have USE_MOTIF. ftp/moxftp will define USE_MOTIF unless WANT_ATHENA_VERSION (new variable) is defined. I merged the X cases in cad/mars, so USE_MOTIF is used iff WITHOUT_X11 is not defined. I will remove x11-toolkits/Motif-dummy (which has been repo copied to open-motif) in a few days.
Diffstat (limited to 'editors')
-rw-r--r--editors/asedit/Makefile2
-rw-r--r--editors/nedit/Makefile2
-rw-r--r--editors/thoteditor/Makefile3
-rw-r--r--editors/vim/Makefile2
-rw-r--r--editors/vim5/Makefile2
-rw-r--r--editors/vim6/Makefile2
6 files changed, 6 insertions, 7 deletions
diff --git a/editors/asedit/Makefile b/editors/asedit/Makefile
index b5634b43e302..8f0bdb3ffee7 100644
--- a/editors/asedit/Makefile
+++ b/editors/asedit/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= shanee@augusta.de
-REQUIRES_MOTIF= yes
+USE_MOTIF= yes
USE_IMAKE= yes
XMKMF= xmkmf
diff --git a/editors/nedit/Makefile b/editors/nedit/Makefile
index 96ea6a3a636c..3dd80d4e94c9 100644
--- a/editors/nedit/Makefile
+++ b/editors/nedit/Makefile
@@ -14,7 +14,7 @@ DISTFILES= nedit-5.1.1-src.tar.gz nedit-5.1.app-defaults
MAINTAINER= deischen@freebsd.org
-REQUIRES_MOTIF= yes
+USE_MOTIF= yes
USE_X_PREFIX= yes
USE_XPM= yes
EXTRACT_ONLY= nedit-5.1.1-src.tar.gz
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index 516619961dc6..a5e23704340c 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -20,9 +20,8 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= chuckr@FreeBSD.org
THOT_SUBDIR= Target
-REQUIRES_MOTIF= yes
+USE_MOTIF= yes
WRKSRC= $(WRKDIR)/Thot/$(THOT_SUBDIR)
-REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
USE_GMAKE= yes
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index a991ae69807a..65b2c5afb8ca 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -57,7 +57,7 @@ MAKE_ARGS+= X_LIBS=-lxpg4 CONF_OPT_MAX="--enable-max-features"
USE_GTK= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE} --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"
.elif defined(HAVE_MOTIF)
-REQUIRES_MOTIF= yes
+USE_MOTIF= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\" --enable-multibyte --enable-fontset --enable-multibyte --enable-xim" MOTIFHOME=${X11BASE}
.else
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index 989f9d920562..bdfb3d442da9 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -56,7 +56,7 @@ MAKE_ARGS+= X_LIBS=-lxpg4 CONF_OPT_MAX="--enable-max-features"
USE_GTK= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE} --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"
.elif defined(HAVE_MOTIF)
-REQUIRES_MOTIF= yes
+USE_MOTIF= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\" --enable-multibyte --enable-fontset --enable-multibyte --enable-xim" MOTIFHOME=${X11BASE}
.else
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"
diff --git a/editors/vim6/Makefile b/editors/vim6/Makefile
index a991ae69807a..65b2c5afb8ca 100644
--- a/editors/vim6/Makefile
+++ b/editors/vim6/Makefile
@@ -57,7 +57,7 @@ MAKE_ARGS+= X_LIBS=-lxpg4 CONF_OPT_MAX="--enable-max-features"
USE_GTK= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE} --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"
.elif defined(HAVE_MOTIF)
-REQUIRES_MOTIF= yes
+USE_MOTIF= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\" --enable-multibyte --enable-fontset --enable-multibyte --enable-xim" MOTIFHOME=${X11BASE}
.else
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena --enable-multibyte --enable-fontset --enable-multibyte --enable-xim"