aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-01-31 20:41:50 +0800
committermarino <marino@FreeBSD.org>2016-01-31 20:41:50 +0800
commit3241575112300bec17e756b8db3e604c09791c15 (patch)
tree24210f66d10e68c80e6b59b6ba244af55698905b /editors
parentda9c930c4721151359e8fb4b0a1ae0ea97569220 (diff)
downloadfreebsd-ports-gnome-3241575112300bec17e756b8db3e604c09791c15.tar.gz
freebsd-ports-gnome-3241575112300bec17e756b8db3e604c09791c15.tar.zst
freebsd-ports-gnome-3241575112300bec17e756b8db3e604c09791c15.zip
editors/bitedit: document ncurses rqmt (USES+=ncurses), respect LDFLAGS
approved by: infrastructure blanket
Diffstat (limited to 'editors')
-rw-r--r--editors/bitedit/Makefile1
-rw-r--r--editors/bitedit/files/patch-Makefile8
2 files changed, 5 insertions, 4 deletions
diff --git a/editors/bitedit/Makefile b/editors/bitedit/Makefile
index edbe7f1ddd70..b7806eafb1d2 100644
--- a/editors/bitedit/Makefile
+++ b/editors/bitedit/Makefile
@@ -11,6 +11,7 @@ COMMENT= Bitedit is a simple ncurses program for editing a file
LICENSE= GPLv2
+USES= ncurses
MAKE_ARGS= CFLAGS="${CFLAGS} -DVERSION=\\\"${PORTVERSION}\\\""
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
diff --git a/editors/bitedit/files/patch-Makefile b/editors/bitedit/files/patch-Makefile
index c10ba06b5086..f63c398aabd6 100644
--- a/editors/bitedit/files/patch-Makefile
+++ b/editors/bitedit/files/patch-Makefile
@@ -1,13 +1,13 @@
---- ./Makefile.orig 2003-05-27 14:23:25.000000000 +0200
-+++ ./Makefile 2014-02-19 13:50:29.293943342 +0100
-@@ -9,8 +9,8 @@
+--- Makefile.orig 2003-05-27 12:23:25 UTC
++++ Makefile
+@@ -9,8 +9,8 @@ VERSION=0.9.4
DISTFILE=bitedit-$(VERSION).tar.gz
DEFINES=-DVERSION=\"$(VERSION)\"
-CFLAGS=-g -Wall $(DEFINES)
-LD=$(CC) -g -Wall
+CFLAGS+=-Wall $(DEFINES)
-+LD=$(CC) -Wall
++LD=$(CC) -Wall $(LDFLAGS)
all: $(TARGETS)