aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-11-06 00:14:47 +0800
committergahr <gahr@FreeBSD.org>2013-11-06 00:14:47 +0800
commit378e033ccc3596fa8ba39ed629d476891a6ec937 (patch)
tree50cd93bf13fb9e3b3073d9f1e5623554d607adb3 /editors
parent33d49d4ae8e80cd68268e84353cb2413c7d240ed (diff)
downloadfreebsd-ports-gnome-378e033ccc3596fa8ba39ed629d476891a6ec937.tar.gz
freebsd-ports-gnome-378e033ccc3596fa8ba39ed629d476891a6ec937.tar.zst
freebsd-ports-gnome-378e033ccc3596fa8ba39ed629d476891a6ec937.zip
- Convert to USES+=tk
- STAGE-clean
Diffstat (limited to 'editors')
-rw-r--r--editors/vigor/Makefile11
-rw-r--r--editors/vigor/files/patch-configure11
2 files changed, 15 insertions, 7 deletions
diff --git a/editors/vigor/Makefile b/editors/vigor/Makefile
index 8048a0ec40f8..88aaf9a7f946 100644
--- a/editors/vigor/Makefile
+++ b/editors/vigor/Makefile
@@ -15,20 +15,17 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE
WRKSRC= ${WRKDIR}/${DISTNAME}/build
-USE_TCL= yes
-USE_TCL_BUILD= yes
-USE_TK= yes
-USE_TK_BUILD= yes
+USES+= tk
USE_XORG= x11
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--exec-prefix=${STAGEDIR}${PREFIX}
CPPFLAGS+= -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e 's|tcl80|tcl${TCL_VER:S/.//}|; \
- s|tk80|tk${TK_VER:S/.//}|; \
+ ${REINPLACE_CMD} -e 's|tcl80|tcl${TCL_SHLIB_VER}|; \
+ s|tk80|tk${TK_SHLIB_VER}|; \
s|^grantpt|XXXgrantpt|;' \
${WRKSRC}/configure
diff --git a/editors/vigor/files/patch-configure b/editors/vigor/files/patch-configure
new file mode 100644
index 000000000000..df455040d277
--- /dev/null
+++ b/editors/vigor/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-11-05 17:12:10.000000000 +0100
++++ configure 2013-11-05 17:12:16.000000000 +0100
+@@ -48,7 +48,7 @@
+ bindir='${exec_prefix}/bin'
+ sbindir='${exec_prefix}/sbin'
+ libexecdir='${exec_prefix}/libexec'
+-datadir='${prefix}/share'
++datadir='${exec_prefix}/share'
+ sysconfdir='${prefix}/etc'
+ sharedstatedir='${prefix}/com'
+ localstatedir='${prefix}/var'