aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2008-11-09 06:54:17 +0800
committerolgeni <olgeni@FreeBSD.org>2008-11-09 06:54:17 +0800
commit6460190be3e9f7962e36791cd163ee226ae56264 (patch)
tree625b35afd718c57cc3926538d2de70a9af3df17c /editors
parentf1a63d67df905d529c43d4bd3de30a5aa72f8682 (diff)
downloadfreebsd-ports-gnome-6460190be3e9f7962e36791cd163ee226ae56264.tar.gz
freebsd-ports-gnome-6460190be3e9f7962e36791cd163ee226ae56264.tar.zst
freebsd-ports-gnome-6460190be3e9f7962e36791cd163ee226ae56264.zip
Use PYTHON_CMD with the -m flag to run compileall (avoid referencing PYTHON_SITELIBDIR).
Diffstat (limited to 'editors')
-rw-r--r--editors/rox-edit/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/editors/rox-edit/Makefile b/editors/rox-edit/Makefile
index 3518bb5c85f2..690764437170 100644
--- a/editors/rox-edit/Makefile
+++ b/editors/rox-edit/Makefile
@@ -27,8 +27,8 @@ post-extract:
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -rf
do-build:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -m compileall ${WRKSRC}
+ @${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
@${MKDIR} ${PREFIX}/apps