aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2017-02-10 10:02:54 +0800
committerjkim <jkim@FreeBSD.org>2017-02-10 10:02:54 +0800
commit72d107f4f7716900d6519167cf8ac0bac32f1ae7 (patch)
tree09117e07caeee84b542d53f26970665f4cb1af42 /editors
parent49e84a8afe3d0aad68e0ff442a0b87c699646c5a (diff)
downloadfreebsd-ports-gnome-72d107f4f7716900d6519167cf8ac0bac32f1ae7.tar.gz
freebsd-ports-gnome-72d107f4f7716900d6519167cf8ac0bac32f1ae7.tar.zst
freebsd-ports-gnome-72d107f4f7716900d6519167cf8ac0bac32f1ae7.zip
Refine r433663. If "use-header-bar" property of the dialog is set to TRUE,
it uses a GtkHeaderBar for action buttons instead of the action area and gtk_dialog_get_header_bar() should not return NULL. If it is set to FALSE, gtk_dialog_get_header_bar() always returns NULL. In other words, we should not remove buttons from both header bar and action area in any case. This patch also removes pointless assertions from the previous patch. PR: 203563
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx22
2 files changed, 7 insertions, 17 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 4cb1e140e772..56b89c1e7cae 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -2,7 +2,7 @@
.include "${.CURDIR}/Makefile.common"
-PORTREVISION= 4
+PORTREVISION= 5
MASTER_SITES= http://download.documentfoundation.org/libreoffice/src/${PORTVERSION}/ \
http://dev-www.libreoffice.org/src/:src \
http://dev-www.libreoffice.org/extern/:ext
diff --git a/editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx b/editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx
index 8e6352b264bc..dc2ea8a099df 100644
--- a/editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx
+++ b/editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx
@@ -1,26 +1,16 @@
--- vcl/unx/gtk/fpicker/SalGtkFilePicker.cxx.orig 2017-01-12 00:54:33 UTC
+++ vcl/unx/gtk/fpicker/SalGtkFilePicker.cxx
-@@ -418,8 +418,11 @@ shrinkFilterName( const OUString &rFilte
- static void
- dialog_remove_buttons(GtkWidget *pActionArea)
- {
-- GList *pChildren =
-- gtk_container_get_children( GTK_CONTAINER( pActionArea ) );
-+ GtkContainer *pContainer = GTK_CONTAINER( pActionArea );
-+
-+ g_return_if_fail( pContainer != nullptr );
-+
-+ GList *pChildren = gtk_container_get_children( pContainer );
-
- for( GList *p = pChildren; p; p = p->next )
- {
-@@ -436,10 +439,10 @@ dialog_remove_buttons( GtkDialog *pDialo
+@@ -436,10 +436,13 @@ dialog_remove_buttons( GtkDialog *pDialo
{
g_return_if_fail( GTK_IS_DIALOG( pDialog ) );
-#if GTK_CHECK_VERSION(3,0,0)
#if GTK_CHECK_VERSION(3,12,0)
- dialog_remove_buttons(gtk_dialog_get_header_bar(pDialog));
+- dialog_remove_buttons(gtk_dialog_get_header_bar(pDialog));
++ GtkWidget *pHeaderBar = gtk_dialog_get_header_bar( pDialog );
++ if( pHeaderBar != nullptr )
++ dialog_remove_buttons( pHeaderBar );
++ else
#endif
+#if GTK_CHECK_VERSION(2,14,0)
dialog_remove_buttons(gtk_dialog_get_action_area(pDialog));