aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2016-06-14 12:42:13 +0800
committerjkim <jkim@FreeBSD.org>2016-06-14 12:42:13 +0800
commit7ab852fef1499b613e2fde736ad320eb41cb945c (patch)
treeb98bfba82faebcb94482018ed2503b7858395da5 /editors
parent065c196011704226caf0ac74fcf934d75b05e8cb (diff)
downloadfreebsd-ports-gnome-7ab852fef1499b613e2fde736ad320eb41cb945c.tar.gz
freebsd-ports-gnome-7ab852fef1499b613e2fde736ad320eb41cb945c.tar.zst
freebsd-ports-gnome-7ab852fef1499b613e2fde736ad320eb41cb945c.zip
Fix build on head.
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/libreoffice/files/patch-configure.ac11
-rw-r--r--editors/libreoffice4/Makefile2
-rw-r--r--editors/libreoffice4/files/patch-configure.ac15
4 files changed, 23 insertions, 7 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 9aed4b7bd895..b5f543a1e59b 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -253,8 +253,6 @@ CONFIGURE_ENV= DMAKE=${LOCALBASE}/bin/dmake \
GPERF=${LOCALBASE}/bin/gperf \
OPENCOLLADA_CFLAGS="${COLLADA_CFLAGS}" \
OPENCOLLADA_LIBS="${COLLADA_LIBS}" \
- OPENSSL_CFLAGS="-I/usr/include" \
- OPENSSL_LIBS="-lcrypto -lssl" \
PYTHON_CFLAGS="`${PYTHON_VERSION}-config --cflags`" \
PYTHON_LIBS="`${PYTHON_VERSION}-config --libs`"
diff --git a/editors/libreoffice/files/patch-configure.ac b/editors/libreoffice/files/patch-configure.ac
new file mode 100644
index 000000000000..7891d280c2ad
--- /dev/null
+++ b/editors/libreoffice/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2016-05-04 21:28:24 UTC
++++ configure.ac
+@@ -9304,7 +9304,7 @@ if test "$enable_openssl" = "yes"; then
+
+ with_system_openssl=no
+ libo_CHECK_SYSTEM_MODULE([openssl],[OPENSSL],[openssl])
+- elif test "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o "$_os" = "DragonFly" \
++ elif test "$_os" = "FreeBSD" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o "$_os" = "DragonFly" \
+ && test "$with_system_openssl" != "no"; then
+ with_system_openssl=yes
+ SYSTEM_OPENSSL=TRUE
diff --git a/editors/libreoffice4/Makefile b/editors/libreoffice4/Makefile
index 916af3a9d2cc..8a61e8d9d6d2 100644
--- a/editors/libreoffice4/Makefile
+++ b/editors/libreoffice4/Makefile
@@ -113,8 +113,6 @@ CONFIGURE_ENV= DMAKE=${LOCALBASE}/bin/dmake \
GPERF=${LOCALBASE}/bin/gperf \
OPENCOLLADA_CFLAGS="${COLLADA_CFLAGS}" \
OPENCOLLADA_LIBS="${COLLADA_LIBS}" \
- OPENSSL_CFLAGS="-I/usr/include" \
- OPENSSL_LIBS="-lcrypto -lssl" \
PYTHON_CFLAGS="`${PYTHON_VERSION}-config --cflags`" \
PYTHON_LIBS="`${PYTHON_VERSION}-config --libs`"
diff --git a/editors/libreoffice4/files/patch-configure.ac b/editors/libreoffice4/files/patch-configure.ac
index 7e2d565076e7..d10b2fb99dec 100644
--- a/editors/libreoffice4/files/patch-configure.ac
+++ b/editors/libreoffice4/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2015-01-28 07:00:34.000000000 -0500
-+++ configure.ac 2015-01-28 18:11:00.936172000 -0500
-@@ -7789,7 +7789,7 @@
+--- configure.ac.orig 2015-04-20 19:36:29 UTC
++++ configure.ac
+@@ -7798,7 +7798,7 @@ dnl Check for system libcmis
dnl ===================================================================
# libcmis requires curl and we can't build curl for iOS
if test $_os != iOS; then
@@ -9,3 +9,12 @@
ENABLE_CMIS=TRUE
else
ENABLE_CMIS=
+@@ -9428,7 +9428,7 @@ if test "$enable_openssl" = "yes"; then
+
+ with_system_openssl=no
+ libo_CHECK_SYSTEM_MODULE([openssl],[OPENSSL],[openssl])
+- elif test "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o "$_os" = "DragonFly" \
++ elif test "$_os" = "FreeBSD" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o "$_os" = "DragonFly" \
+ && test "$with_system_openssl" != "no"; then
+ with_system_openssl=yes
+ SYSTEM_OPENSSL=TRUE