aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-07-06 07:12:23 +0800
committershaun <shaun@FreeBSD.org>2006-07-06 07:12:23 +0800
commitb775f1442a2ca6695c184794a7668aa81776bd8e (patch)
treed1cc51d5cc2053c816811f5475386db39845117e /editors
parentc430751c1b5b9dccbf10abde2c7d668b26ceedd6 (diff)
downloadfreebsd-ports-gnome-b775f1442a2ca6695c184794a7668aa81776bd8e.tar.gz
freebsd-ports-gnome-b775f1442a2ca6695c184794a7668aa81776bd8e.tar.zst
freebsd-ports-gnome-b775f1442a2ca6695c184794a7668aa81776bd8e.zip
Requires a Perl compiled without threads to build.
PR: ports/99100 Submitted by: Tim Welch <ports@thepentagon.org> Approved by: ahze (mentor)
Diffstat (limited to 'editors')
-rw-r--r--editors/nvi-perl/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/nvi-perl/Makefile b/editors/nvi-perl/Makefile
index 697baafb846b..b77388553e2a 100644
--- a/editors/nvi-perl/Makefile
+++ b/editors/nvi-perl/Makefile
@@ -29,7 +29,17 @@ CFLAGS+= -DPERL_POLLUTE
MAN1= pnvi.1
MLINKS= pnvi.1 pnex.1 pnvi.1 pnview.1
+.include <bsd.port.pre.mk>
+
+post-depends:
+.if exists(${PERL})
+PERL_THREADED!= ${PERL} -V | ${GREP} -- -Dusethreads=y || ${TRUE}
+. if ${PERL_THREADED} != ""
+IGNORE= must be built with a NON-threaded Perl
+. endif
+.endif
+
post-patch:
${LN} -s /usr/include/sys/queue.h ${WRKSRC}/../include/sys/queue_dist.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>