aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /editors
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'editors')
-rw-r--r--editors/e93/Makefile6
-rw-r--r--editors/ved/Makefile8
-rw-r--r--editors/vigor/Makefile12
-rw-r--r--editors/xenon/Makefile12
4 files changed, 19 insertions, 19 deletions
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index 1611b98c2623..4c0ac94d2022 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -19,15 +19,15 @@ COMMENT= A nifty editor based on Tcl/Tk
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
tk82.1:${PORTSDIR}/x11-toolkits/tk82
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_X_PREFIX= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_X_PREFIX= yes
-
do-install:
${MKDIR} ${PREFIX}/share/doc/e93 ${PREFIX}/lib/e93lib/images \
${PREFIX}/lib/e93lib/highlightschemes \
diff --git a/editors/ved/Makefile b/editors/ved/Makefile
index eb40293e83f4..f33a0073fb42 100644
--- a/editors/ved/Makefile
+++ b/editors/ved/Makefile
@@ -13,16 +13,16 @@ MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/ved/
MAINTAINER= greid@ukug.uk.freebsd.org
COMMENT= A small and fast screen-oriented editor.
+USE_GMAKE= yes
+
+MAN1= ved.1
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-USE_GMAKE= yes
-
-MAN1= ved.1
-
post-patch:
.for F in ved.h ved.1
${SED} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/ved/$F \
diff --git a/editors/vigor/Makefile b/editors/vigor/Makefile
index 3ec6d429369d..dbd3e48649e2 100644
--- a/editors/vigor/Makefile
+++ b/editors/vigor/Makefile
@@ -17,12 +17,6 @@ COMMENT= A vi clone inspired by the userfriendly comic strip
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
tcl82.1:${PORTSDIR}/lang/tcl82
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--program-transform-name="s,0,1,"
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
@@ -30,6 +24,12 @@ CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${DISTNAME}/build
CFLAGS+= -I${LOCALBASE}/include/tcl8.2 -I${LOCALBASE}/include/tk8.2
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
# Uglyness. So is "-ltcl -ltk -ltcl", so I don't feel bad.
post-patch:
@${CP} ${WRKSRC}/configure ${WRKSRC}/configure.orig
diff --git a/editors/xenon/Makefile b/editors/xenon/Makefile
index 63eca50a182d..3292a94651e4 100644
--- a/editors/xenon/Makefile
+++ b/editors/xenon/Makefile
@@ -14,12 +14,6 @@ MASTER_SITES= http://sydney.proximity.com.au/~ben/xenon/dist/ \
MAINTAINER= jedgar@FreeBSD.org
COMMENT= Simple X-based text editor
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_GMAKE= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
@@ -31,6 +25,12 @@ MAN1= xe.1
FIX_FILES= Xe.h XeApp.h XeFontTable.C XeFontTable.h XeKeyTable.C \
XeKeyTable.h XeObjectTable.h
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-configure:
.for file in ${FIX_FILES}
@${REINPLACE_CMD} -e 's|#include <ext/|#include <|' \