aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-06-12 23:14:18 +0800
committerkwm <kwm@FreeBSD.org>2015-06-12 23:14:18 +0800
commit05a6f8b5d732917971fa630a494b5d26542f4e67 (patch)
tree629e5401a7376dcaf5f46ab8fba04a8b03aab549 /editors
parentd3b608f56927e02b90422c8c28911673dc30e6ab (diff)
downloadfreebsd-ports-gnome-05a6f8b5d732917971fa630a494b5d26542f4e67.tar.gz
freebsd-ports-gnome-05a6f8b5d732917971fa630a494b5d26542f4e67.tar.zst
freebsd-ports-gnome-05a6f8b5d732917971fa630a494b5d26542f4e67.zip
* Split off the python bindings from the main libpeas port.
* This allows use to supply both python bindings. Update libpeas using ports for this change. * Assign maintainership to gnome@ Obtained from: GNOME devel repo
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit-plugins/Makefile5
-rw-r--r--editors/gedit/Makefile4
2 files changed, 6 insertions, 3 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 8b5bae29fd69..9d7eb01f5951 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gedit-plugins
PORTVERSION= 3.14.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -41,7 +41,8 @@ PYTHON_DESC= Build plugins that depend on python
USES+= python
BUILD_DEPENDS+= py3?-dbus>=0:${PORTSDIR}/devel/py3-dbus
LIB_DEPENDS+= libgucharmap_2_90.so:${PORTSDIR}/deskutils/gucharmap
-RUN_DEPENDS+= py3?-dbus>=0:${PORTSDIR}/devel/py3-dbus
+RUN_DEPENDS+= py3?-dbus>=0:${PORTSDIR}/devel/py3-dbus \
+ ${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py3-libpeas
USE_GNOME+= vte3
CONFIGURE_ARGS+=--enable-python
GLIB_SCHEMAS+= org.gnome.gedit.plugins.terminal.gschema.xml
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 5e35de9515da..ea1c44c3e79f 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gedit
PORTVERSION= 3.14.3
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -19,7 +20,8 @@ LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
libpeas-gtk-1.0.so:${PORTSDIR}/devel/libpeas \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup
RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
- gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas \
+ ${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py3-libpeas
USES= desktop-file-utils gettext gmake libtool \
pathfix pkgconfig python:3 tar:xz