aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-11-13 17:31:25 +0800
committermaho <maho@FreeBSD.org>2006-11-13 17:31:25 +0800
commit063380318af5c6ae5d652df1f18a86cd4a36b61c (patch)
tree7e93f5b98560ad7a28871043839175165d17abca /editors
parenta593e779adde5fe8eb196b4f4e93e5ff5d06c360 (diff)
downloadfreebsd-ports-gnome-063380318af5c6ae5d652df1f18a86cd4a36b61c.tar.gz
freebsd-ports-gnome-063380318af5c6ae5d652df1f18a86cd4a36b61c.tar.zst
freebsd-ports-gnome-063380318af5c6ae5d652df1f18a86cd4a36b61c.zip
Update to OOE680_m2, add evolution2 support [1] and Fix typo [2].
PR: 105400 [2] Suggested by: Vizo Allman <vizoster@gmail.com> [1] Submitted by: Alexey Shuvaev [2]
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice.org-2-RC/Makefile31
-rw-r--r--editors/openoffice.org-2-RC/distinfo6
-rw-r--r--editors/openoffice.org-3-RC/Makefile31
-rw-r--r--editors/openoffice.org-3-RC/distinfo6
4 files changed, 40 insertions, 34 deletions
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 6a344450ba04..eb8af9b3f1ed 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME?= openoffice.org
-PORTVERSION?= ${OOOVERSION}
+PORTNAME?= openoffice.org-RC
+PORTVERSION?= 2.1.${SNAPDATE}
CATEGORIES+= editors java
-MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOVERSION}/&,} \
+MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/developer/680_m${MILESTONE}/&,} \
http://openoffice.lunarshells.com/sources/ \
http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
@@ -26,9 +26,8 @@ DISTFILES+= ${ANT_DISTFILE}:antbin
EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
-COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
+COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser(release branch)
-OOOVERSION= 2.0.4
NO_LATEST_LINK= yes
USE_GNOME= gtk20
MOZILLA_VERSION= 1.7.5
@@ -44,6 +43,7 @@ USE_KDELIBS_VER= 3
USE_XLIB= yes
USE_GMAKE= yes
USE_PERL5= yes
+USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
.if !defined(WITH_GNUGCJ)
@@ -56,7 +56,7 @@ JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= amd64 i386
.if ${ARCH} == amd64
GCC_TARGET= x86_64-portbld-freebsd${OSREL}
@@ -71,17 +71,19 @@ IGNORE= install lang/perl5.8 then try again
.endif
CODELINE= 680
-RELEASE_NR= 2.0
-OOOTAG?= OOD680_m5
-OOOSRC?= OOo_2.0.4_src.tar.gz
-INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
-EXECBASE?= openoffice.org-${OOOVERSION}
+RELEASE_NR= 2.1
+MILESTONE?= 2
+OOOTAG?= OOE680_m${MILESTONE}
+OOOSRC?= OOo_${OOOTAG}_source${EXTRACT_SUFX}
+SNAPDATE= 20061107
+INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
+EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
.if ${ARCH} == amd64
-PACKAGE_BASENAME= OOo_${OOOVERSION}_${OPSYS}${SIMPLEOSVER}X86_64
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
.else
-PACKAGE_BASENAME= OOo_${OOOVERSION}_${OPSYS}${SIMPLEOSVER}Intel
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
.endif
LOCALIZED_LANG?= en-US
@@ -236,7 +238,7 @@ post-install:
@${CP} ${FILESDIR}/openoffice.org-wrapper ${WRKDIR}/
@${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#g' \
-e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
- -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
+ -e 's#%%OOOTAG%%#${OOOTAG}#g' \
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
${WRKDIR}/openoffice.org-wrapper
@${INSTALL_SCRIPT} ${WRKDIR}/openoffice.org-wrapper \
@@ -282,6 +284,7 @@ post-install:
@${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#g' \
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
+ -e 's#%%OOOTAG%%#${OOOTAG}#g' \
-e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
diff --git a/editors/openoffice.org-2-RC/distinfo b/editors/openoffice.org-2-RC/distinfo
index b928e8ace134..ba7a423d1b3e 100644
--- a/editors/openoffice.org-2-RC/distinfo
+++ b/editors/openoffice.org-2-RC/distinfo
@@ -1,6 +1,6 @@
-MD5 (openoffice.org2.0/OOo_2.0.4_src.tar.gz) = df4bb26645e974a2358bc17f8381a197
-SHA256 (openoffice.org2.0/OOo_2.0.4_src.tar.gz) = 98551d4574586c5a9e26635be758cf05a0315ee9eb44ad7c5ac7c7b983933ea6
-SIZE (openoffice.org2.0/OOo_2.0.4_src.tar.gz) = 333861883
+MD5 (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = 20b81ec782549c2d21bfeb8b7ec2026f
+SHA256 (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = e2b6b520f014e0773dd794d863bcfa04dbf11ed46659c7a28b5f55d32ea02a44
+SIZE (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = 270751002
MD5 (openoffice.org2.0/unowinreg.dll) = e3a0b76dcd876f3d721ee7183729153d
SHA256 (openoffice.org2.0/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice.org2.0/unowinreg.dll) = 6144
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 6a344450ba04..eb8af9b3f1ed 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME?= openoffice.org
-PORTVERSION?= ${OOOVERSION}
+PORTNAME?= openoffice.org-RC
+PORTVERSION?= 2.1.${SNAPDATE}
CATEGORIES+= editors java
-MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/stable/${OOOVERSION}/&,} \
+MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/developer/680_m${MILESTONE}/&,} \
http://openoffice.lunarshells.com/sources/ \
http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
@@ -26,9 +26,8 @@ DISTFILES+= ${ANT_DISTFILE}:antbin
EXTRACT_ONLY= ${OOOSRC}
MAINTAINER= openoffice@FreeBSD.org
-COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
+COMMENT?= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser(release branch)
-OOOVERSION= 2.0.4
NO_LATEST_LINK= yes
USE_GNOME= gtk20
MOZILLA_VERSION= 1.7.5
@@ -44,6 +43,7 @@ USE_KDELIBS_VER= 3
USE_XLIB= yes
USE_GMAKE= yes
USE_PERL5= yes
+USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
.if !defined(WITH_GNUGCJ)
@@ -56,7 +56,7 @@ JAVA_VENDOR= freebsd bsdjava
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= amd64 i386
.if ${ARCH} == amd64
GCC_TARGET= x86_64-portbld-freebsd${OSREL}
@@ -71,17 +71,19 @@ IGNORE= install lang/perl5.8 then try again
.endif
CODELINE= 680
-RELEASE_NR= 2.0
-OOOTAG?= OOD680_m5
-OOOSRC?= OOo_2.0.4_src.tar.gz
-INSTALLATION_BASEDIR?= openoffice.org-${OOOVERSION}
-EXECBASE?= openoffice.org-${OOOVERSION}
+RELEASE_NR= 2.1
+MILESTONE?= 2
+OOOTAG?= OOE680_m${MILESTONE}
+OOOSRC?= OOo_${OOOTAG}_source${EXTRACT_SUFX}
+SNAPDATE= 20061107
+INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
+EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
.if ${ARCH} == amd64
-PACKAGE_BASENAME= OOo_${OOOVERSION}_${OPSYS}${SIMPLEOSVER}X86_64
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
.else
-PACKAGE_BASENAME= OOo_${OOOVERSION}_${OPSYS}${SIMPLEOSVER}Intel
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
.endif
LOCALIZED_LANG?= en-US
@@ -236,7 +238,7 @@ post-install:
@${CP} ${FILESDIR}/openoffice.org-wrapper ${WRKDIR}/
@${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#g' \
-e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
- -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
+ -e 's#%%OOOTAG%%#${OOOTAG}#g' \
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
${WRKDIR}/openoffice.org-wrapper
@${INSTALL_SCRIPT} ${WRKDIR}/openoffice.org-wrapper \
@@ -282,6 +284,7 @@ post-install:
@${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#g' \
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
+ -e 's#%%OOOTAG%%#${OOOTAG}#g' \
-e 's#%%RELEASE_NR%%#${RELEASE_NR}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
diff --git a/editors/openoffice.org-3-RC/distinfo b/editors/openoffice.org-3-RC/distinfo
index b928e8ace134..ba7a423d1b3e 100644
--- a/editors/openoffice.org-3-RC/distinfo
+++ b/editors/openoffice.org-3-RC/distinfo
@@ -1,6 +1,6 @@
-MD5 (openoffice.org2.0/OOo_2.0.4_src.tar.gz) = df4bb26645e974a2358bc17f8381a197
-SHA256 (openoffice.org2.0/OOo_2.0.4_src.tar.gz) = 98551d4574586c5a9e26635be758cf05a0315ee9eb44ad7c5ac7c7b983933ea6
-SIZE (openoffice.org2.0/OOo_2.0.4_src.tar.gz) = 333861883
+MD5 (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = 20b81ec782549c2d21bfeb8b7ec2026f
+SHA256 (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = e2b6b520f014e0773dd794d863bcfa04dbf11ed46659c7a28b5f55d32ea02a44
+SIZE (openoffice.org2.0/OOo_OOE680_m2_source.tar.bz2) = 270751002
MD5 (openoffice.org2.0/unowinreg.dll) = e3a0b76dcd876f3d721ee7183729153d
SHA256 (openoffice.org2.0/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice.org2.0/unowinreg.dll) = 6144