aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-08-18 09:01:45 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-08-18 09:01:45 +0800
commit0e67efc3f2698fea9cebcf3a4a1b30ee5ecf9624 (patch)
tree25cd6a5fb6c07f102e9d68bc9b05d7c0bdcc52cf /editors
parent8608fc8856913a52b4c07426094a5c6a551a3657 (diff)
downloadfreebsd-ports-gnome-0e67efc3f2698fea9cebcf3a4a1b30ee5ecf9624.tar.gz
freebsd-ports-gnome-0e67efc3f2698fea9cebcf3a4a1b30ee5ecf9624.tar.zst
freebsd-ports-gnome-0e67efc3f2698fea9cebcf3a4a1b30ee5ecf9624.zip
Import of fine.
fine is "The Finally INteligent Editor" that does syntax highlighting, has the ability to be programmed to insert text with key bindings and more. It uses the QT toolkit.
Diffstat (limited to 'editors')
-rw-r--r--editors/fine/Makefile28
-rw-r--r--editors/fine/distinfo1
-rw-r--r--editors/fine/files/patch-aa42
-rw-r--r--editors/fine/files/patch-ab55
-rw-r--r--editors/fine/pkg-comment1
-rw-r--r--editors/fine/pkg-descr6
-rw-r--r--editors/fine/pkg-plist7
7 files changed, 140 insertions, 0 deletions
diff --git a/editors/fine/Makefile b/editors/fine/Makefile
new file mode 100644
index 000000000000..0ee27353bb2c
--- /dev/null
+++ b/editors/fine/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: FINE
+# Version required: 2.1
+# Date created: 17 August 1999
+# Whom: Chris Piazza <cpiazza@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= fine
+PKGNAME= fine-2.1
+CATEGORIES= editors
+MASTER_SITES= ftp://razor.fer.uni-lj.si/pub/software/bojank/fine/
+
+MAINTAINER= cpiazza@FreeBSD.org
+
+USE_GMAKE= yes
+USE_QT= yes
+WRKSRC= ${WRKDIR}/fine
+
+do-install:
+ @${MKDIR} ${PREIFX}/share/fine
+ ${INSTALL_DATA} ${WRKSRC}/.editor ${PREFIX}/share/fine/editor
+.for template in C++.template LaTeX.template h.template html.template
+ ${INSTALL_DATA} ${WRKSRC}/${template} ${PREFIX}/share/fine/
+.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/fine ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/editors/fine/distinfo b/editors/fine/distinfo
new file mode 100644
index 000000000000..ef11380ae1b4
--- /dev/null
+++ b/editors/fine/distinfo
@@ -0,0 +1 @@
+MD5 (fine.tar.gz) = 0a9e6db4c7f266ca470264e3475b4181
diff --git a/editors/fine/files/patch-aa b/editors/fine/files/patch-aa
new file mode 100644
index 000000000000..e68f82dc23f6
--- /dev/null
+++ b/editors/fine/files/patch-aa
@@ -0,0 +1,42 @@
+--- Makefile.orig Tue Mar 16 09:14:22 1999
++++ Makefile Tue Aug 17 16:15:41 1999
+@@ -1,14 +1,15 @@
+-INCLUDE = -I$(QTDIR)/include -I. -I$(HOME)/include -I./icons
+-DESTLIB = $(HOME)/lib # where to put library
+-LIB = -L/usr/X11R6/lib -L$(QTDIR)/lib -L$(DESTLIB)
++QTDIR = ${X11BASE}
++INCLUDE = -I$(QTDIR)/include -I ${QTDIR}/include/X11/qt -I. -I$(HOME)/include -I./icons
++DESTLIB = ${PREFIX}/lib
++LIB = -L${LOCALBASE}/lib -L$(QTDIR)/lib -L$(DESTLIB) -L.
+
+ MOC = $(QTDIR)/bin/moc
+-CC = g++
+-C = gcc
++#CC = ${CX
++#CXX = ${CXX}
+ AR = ar
+ M = moc_
+
+-OPTIONS = -g -ansi -fguiding-decls
++OPTIONS = ${CFLAGS} -ansi -fguiding-decls -DFINEDIR=\""${PREFIX}/share/fine\""
+
+ OBJ = qsmartedit.o qcolormultilinedit.o undoredo.o qeditor.o qfontselect.o qcolordialog.o qcolorlistboxitem.o qkeyworddialog.o qhotkeydialog.o
+ METAOBJ = qsmartedit.mo qcolormultilinedit.mo qeditor.mo qfontselect.mo qcolordialog.mo qkeyworddialog.mo qhotkeydialog.mo
+@@ -27,14 +28,13 @@
+
+ $(TARGET): $(OBJ) $(METAOBJ)
+ $(AR) r $(TARGET) $(OBJ) $(METAOBJ)
+- mv $(TARGET) $(DESTLIB)
+
+ %.o: %.C
+- $(CC) -c $(OPTIONS) $(INCLUDE) $<
++ $(CXX) -c $(OPTIONS) $(INCLUDE) $<
+
+ %.mo: %.h
+ $(MOC) $< -o $(subst .h,.C,m$<)
+- $(CC) -c $(OPTIONS) $(INCLUDE) $(subst .h,.C,m$<) -o $(subst .h,.mo,$<)
++ $(CXX) -c $(OPTIONS) $(INCLUDE) $(subst .h,.C,m$<) -o $(subst .h,.mo,$<)
+
+ fine: fine.o fine.mo
+- $(CC) -g -ofine fine.o fine.mo $(OPTIONS) $(LIB) -lFine -lqt -lX11 -lXext
++ $(CXX) -g -ofine fine.o fine.mo $(OPTIONS) $(LIB) -lFine -lqt -lX11 -lXext
diff --git a/editors/fine/files/patch-ab b/editors/fine/files/patch-ab
new file mode 100644
index 000000000000..3b9291161975
--- /dev/null
+++ b/editors/fine/files/patch-ab
@@ -0,0 +1,55 @@
+--- fine.C.orig Fri May 7 03:08:12 1999
++++ fine.C Tue Aug 17 17:46:57 1999
+@@ -172,7 +172,7 @@
+
+ if (sc == NULL)
+ { sc = new QBinaryTree<Configuration>(shortcut);
+- sprintf(s,"%s/.fine/.editor",getenv("HOME"));
++ sprintf(s,"%s/editor",FINEDIR);
+ f = fopen(s,"rt");
+ if (f != NULL)
+ { while (!feof(f))
+@@ -181,7 +181,7 @@
+ }
+ fclose(f);
+ } else QMessageBox::warning(ed,"Couldn't find main configuration file",
+- "Couldn't find .editor file in your .fine directory!\nTry to type: make install in the FINE distribution directory.");
++ "Couldn't find editor file in your .fine directory!\nTry to type: make install in the FINE distribution directory.");
+ }
+
+ sysmenu = new QMenuBar(this,"Editor System Main Menu");
+@@ -370,7 +370,7 @@
+ if (ptrsc != NULL)
+ { sh = ptrsc->Element();
+ s = new char[strlen(getenv("HOME"))+strlen(sh.filename)+200];
+- sprintf(s,"%s/.fine/%s",getenv("HOME"),sh.filename);
++ sprintf(s,"%s/%s",FINEDIR,sh.filename);
+ w->editor()->readConfig(s);
+ delete [] s;
+ }
+@@ -410,7 +410,7 @@
+ printf("\nTemplate file:%s, Compiler:%s, Previewer:%s",defsc.filename,
+ (defsc.compiler != NULL? defsc.compiler:"(null)"),
+ (defsc.previewer != NULL? defsc.previewer:"(null)"));
+- sprintf(s,"%s/.fine/%s",getenv("HOME"),defsc.filename);
++ sprintf(s,"%s/%s",FINEDIR,defsc.filename);
+ ed->readConfig(s);
+ ed->repaint();
+ fflush(stdout);
+@@ -461,14 +461,14 @@
+ { if (ptrsc != NULL) Delete(sc,ptrsc->Element());
+ sc->Insert(*scw);
+ ptrsc = sc->Locate(*scw);
+- sprintf(fns,"%s/.fine/.editor",getenv("HOME"));
++ sprintf(fns,"%s/editor",FINEDIR);
+ f = fopen(fns,"wt");
+ fprintf(f,"# This is file used by FINE editor\n");
+ fprintf(f,"# It contains information about all template files used by FINE\n");
+ saveConfigTree(f,sc->Left());
+ saveConfigTree(f,sc->Right());
+ fclose(f);
+- sprintf(fns,"%s/.fine/%s",getenv("HOME"),scw->filename);
++ sprintf(fns,"%s/%s",FINEDIR,scw->filename);
+ f = fopen(fns,"wt");
+ fprintf(f,"# This is %s template file\n",scw->name);
+ fprintf(f,"\n# screen settings\n");
diff --git a/editors/fine/pkg-comment b/editors/fine/pkg-comment
new file mode 100644
index 000000000000..72d33c81e190
--- /dev/null
+++ b/editors/fine/pkg-comment
@@ -0,0 +1 @@
+An editor that uses the QT toolkit and can do syntax highlighting
diff --git a/editors/fine/pkg-descr b/editors/fine/pkg-descr
new file mode 100644
index 000000000000..94ef6622c851
--- /dev/null
+++ b/editors/fine/pkg-descr
@@ -0,0 +1,6 @@
+The Finally INteligent Editor. A user friendly editor with
+a nie GUI (uses the Qt toolkit) that can parse syntax
+and colour keywords and other things. It can also be programmed
+to insert text with keybindings.
+
+WWW: http://razor.fer.uni-lj.si/~bojank/fine.html
diff --git a/editors/fine/pkg-plist b/editors/fine/pkg-plist
new file mode 100644
index 000000000000..8f35b650df0d
--- /dev/null
+++ b/editors/fine/pkg-plist
@@ -0,0 +1,7 @@
+bin/fine
+share/fine/C++.template
+share/fine/LaTeX.template
+share/fine/editor
+share/fine/h.template
+share/fine/html.template
+@dirrm share/fine