aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-07-15 02:01:50 +0800
committerkevlo <kevlo@FreeBSD.org>2001-07-15 02:01:50 +0800
commit0e9e720b2917e72938bbc451fbe805f70c82a9fe (patch)
tree59f0827719dc9ebf32bfcfed4339a4d47d15326b /editors
parent95190bf194cef8619521959b3bbb2a29fc904b9c (diff)
downloadfreebsd-ports-gnome-0e9e720b2917e72938bbc451fbe805f70c82a9fe.tar.gz
freebsd-ports-gnome-0e9e720b2917e72938bbc451fbe805f70c82a9fe.tar.zst
freebsd-ports-gnome-0e9e720b2917e72938bbc451fbe805f70c82a9fe.zip
Initial import of kxmleditor-0.4
KXML editor is a program that displays contents of XML file.
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/kxmleditor/Makefile24
-rw-r--r--editors/kxmleditor/distinfo1
-rw-r--r--editors/kxmleditor/pkg-comment1
-rw-r--r--editors/kxmleditor/pkg-descr5
-rw-r--r--editors/kxmleditor/pkg-plist85
6 files changed, 117 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 799b621c39ca..819ce7e8ba2d 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -67,6 +67,7 @@
SUBDIR += joe-devel
SUBDIR += jove
SUBDIR += koffice
+ SUBDIR += kxmleditor
SUBDIR += le
SUBDIR += led
SUBDIR += leim20
diff --git a/editors/kxmleditor/Makefile b/editors/kxmleditor/Makefile
new file mode 100644
index 000000000000..3ad8bcc77e85
--- /dev/null
+++ b/editors/kxmleditor/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: kxmleditor
+# Date created: 15 July 2001
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kxmleditor
+PORTVERSION= 0.4
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= kevlo@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+USE_KDELIBS_VER=2
+
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="moc2" KDEDIR="${LOCALBASE}"
+CONFIGURE_ARGS+= --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib
+
+.include <bsd.port.mk>
diff --git a/editors/kxmleditor/distinfo b/editors/kxmleditor/distinfo
new file mode 100644
index 000000000000..94fe3b0f4451
--- /dev/null
+++ b/editors/kxmleditor/distinfo
@@ -0,0 +1 @@
+MD5 (kxmleditor-0.4.tar.gz) = d32b93c4d376745186f140b49012ba97
diff --git a/editors/kxmleditor/pkg-comment b/editors/kxmleditor/pkg-comment
new file mode 100644
index 000000000000..1da8e675f4b0
--- /dev/null
+++ b/editors/kxmleditor/pkg-comment
@@ -0,0 +1 @@
+XML editor for KDE2
diff --git a/editors/kxmleditor/pkg-descr b/editors/kxmleditor/pkg-descr
new file mode 100644
index 000000000000..b9f1aa0172ff
--- /dev/null
+++ b/editors/kxmleditor/pkg-descr
@@ -0,0 +1,5 @@
+KXML Editor is program that display contents of XML file. Left side contain
+tree with XML document structure, right side contain list of attributes for
+for selected XML element and its contents.
+
+WWW: http://kxmleditor.sourceforge.net/
diff --git a/editors/kxmleditor/pkg-plist b/editors/kxmleditor/pkg-plist
new file mode 100644
index 000000000000..0650548542e1
--- /dev/null
+++ b/editors/kxmleditor/pkg-plist
@@ -0,0 +1,85 @@
+bin/kxmleditor
+share/applnk/Applications/kxmleditor.desktop
+share/apps/kxmleditor/icons/hicolor/16x16/actions/bookmark_next.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/bookmark_prev.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/collapse_node.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/expand_node.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_delete_attribute.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_delete_contents.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_delete_element.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_delete_procins.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_edit_attribute.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_edit_contents.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_edit_element.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_edit_procins.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_insert_attribute.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_insert_contents.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_insert_element.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_insert_procins.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_move_item_down.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_move_item_up.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/bookmark_next.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/bookmark_prev.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/collapse_node.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/expand_node.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_delete_attribute.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_delete_contents.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_delete_element.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_delete_procins.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_edit_attribute.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_edit_contents.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_edit_element.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_edit_procins.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_insert_attribute.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_insert_contents.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_insert_element.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_insert_procins.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_move_item_down.png
+share/apps/kxmleditor/icons/hicolor/22x22/actions/xml_move_item_up.png
+share/apps/kxmleditor/icons/hicolor/32x32/actions/bookmark_next.png
+share/apps/kxmleditor/icons/hicolor/32x32/actions/bookmark_prev.png
+share/apps/kxmleditor/icons/hicolor/32x32/actions/xml_move_item_down.png
+share/apps/kxmleditor/icons/hicolor/32x32/actions/xml_move_item_up.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/bookmark_next.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/bookmark_prev.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/collapse_node.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/expand_node.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_delete_attribute.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_delete_contents.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_delete_element.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_delete_procins.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_edit_attribute.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_edit_contents.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_edit_element.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_edit_procins.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_insert_attribute.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_insert_contents.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_insert_element.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_insert_procins.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_move_item_down.png
+share/apps/kxmleditor/icons/locolor/16x16/actions/xml_move_item_up.png
+share/apps/kxmleditor/kxmleditorui.rc
+share/apps/kxmleditor/pics/xml_attribute.png
+share/apps/kxmleditor/pics/xml_cdata.png
+share/apps/kxmleditor/pics/xml_comment.png
+share/apps/kxmleditor/pics/xml_contents.png
+share/apps/kxmleditor/pics/xml_element.png
+share/apps/kxmleditor/pics/xml_text.png
+share/doc/HTML/en/kxmleditor/common
+share/doc/HTML/en/kxmleditor/index.docbook
+share/doc/HTML/en/kxmleditor/screenshot.png
+share/doc/HTML/en/kxmleditor/xml.png
+@dirrm share/doc/HTML/en/kxmleditor
+@dirrm share/apps/kxmleditor/pics
+@dirrm share/apps/kxmleditor/icons/locolor/16x16/actions
+@dirrm share/apps/kxmleditor/icons/locolor/16x16
+@dirrm share/apps/kxmleditor/icons/locolor
+@dirrm share/apps/kxmleditor/icons/hicolor/32x32/actions
+@dirrm share/apps/kxmleditor/icons/hicolor/32x32
+@dirrm share/apps/kxmleditor/icons/hicolor/22x22/actions
+@dirrm share/apps/kxmleditor/icons/hicolor/22x22
+@dirrm share/apps/kxmleditor/icons/hicolor/16x16/actions
+@dirrm share/apps/kxmleditor/icons/hicolor/16x16
+@dirrm share/apps/kxmleditor/icons/hicolor
+@dirrm share/apps/kxmleditor/icons
+@dirrm share/apps/kxmleditor