aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-06-25 19:37:03 +0800
committermaho <maho@FreeBSD.org>2009-06-25 19:37:03 +0800
commit495cb1402450030bf9490fd41a9e809d7a2f1232 (patch)
treed1ed0b25de80c2f5beb6422ad9c4869737231699 /editors
parent7126b481e10aed20781663165842b6dd7e2e1ae4 (diff)
downloadfreebsd-ports-gnome-495cb1402450030bf9490fd41a9e809d7a2f1232.tar.gz
freebsd-ports-gnome-495cb1402450030bf9490fd41a9e809d7a2f1232.tar.zst
freebsd-ports-gnome-495cb1402450030bf9490fd41a9e809d7a2f1232.zip
Add some extensions to OOo default install.
From: build log ftp://ftp.linux.cz/pub/localization/OpenOffice.org/devel/DEV300/DEV300_m50/Build-1/build/log-GNU_Linux.bz2 Funded by: OpenOffice.org community.
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice.org-3-RC/Makefile18
-rw-r--r--editors/openoffice.org-3-RC/files/Makefile.knobs2
2 files changed, 16 insertions, 4 deletions
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 81f0b67ea6f7..09dab11f48c6 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -146,7 +146,19 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--enable-crashdump=yes \
--with-system-zlib \
--with-system-stdlibs \
- --with-epm=internal
+ --with-epm=internal \
+ --enable-minimizer \
+ --enable-presenter-console \
+ --enable-pdfimport \
+ --enable-wiki-publisher \
+ --enable-report-builder
+
+OOOEXTENSIONS+= minimizer/sun-presentation-minimizer.oxt
+OOOEXTENSIONS+= minimizer/sun-presentation-minimizer.oxt
+OOOEXTENSIONS+= presenter/presenter-screen.oxt
+OOOEXTENSIONS+= pdfimport/pdfimport.oxt
+OOOEXTENSIONS+= swext/wiki-publisher.oxt
+OOOEXTENSIONS+= sun-report-builder.oxt
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
@@ -180,7 +192,7 @@ pre-everything::
.endif
#issue XXXXXX not raised yet...
-CRLFFILES=curl/curl*patch neon/neon*patch
+CRLFFILES=curl/curl*patch neon/neon*patch jfreereport/patches/*.patch
post-extract:
for i in ${CRLFFILES}; do \
@@ -238,6 +250,8 @@ do-install:
@${MKDIR} ${PREFIX}/${INSTALLATION_BASEDIR}
@cd ${WRKDIR}/tmp/opt/ ; ${TAR} cf - -C . . | ${TAR} xf - -C ${PREFIX}/${INSTALLATION_BASEDIR}
.endif
+ @${MKDIR} ${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
+ @cd ${WRKSRC}/solver/310/unxfbsdi.pro/bin/ ; ${INSTALL_DATA} ${OOOEXTENSIONS} ${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
post-install:
@${ECHO_MSG} "===> Add wrapper scripts";
diff --git a/editors/openoffice.org-3-RC/files/Makefile.knobs b/editors/openoffice.org-3-RC/files/Makefile.knobs
index e1053db6682d..5d96251759ef 100644
--- a/editors/openoffice.org-3-RC/files/Makefile.knobs
+++ b/editors/openoffice.org-3-RC/files/Makefile.knobs
@@ -4,8 +4,6 @@
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home="${LOCALBASE}/share/java/apache-ant"
-CONFIGURE_ARGS+= --with-vba-package-format="builtin"
-
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
.endif