aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2003-02-01 18:43:36 +0800
committermbr <mbr@FreeBSD.org>2003-02-01 18:43:36 +0800
commit6eefe867428d0bc14cabbbbc1edfae42da6bb38b (patch)
tree63ebc6eda4becfce98b11a64f89a7809831af440 /editors
parent32d25195cb963f535bebe5c4203a98f09a5b0ddb (diff)
downloadfreebsd-ports-gnome-6eefe867428d0bc14cabbbbc1edfae42da6bb38b.tar.gz
freebsd-ports-gnome-6eefe867428d0bc14cabbbbc1edfae42da6bb38b.tar.zst
freebsd-ports-gnome-6eefe867428d0bc14cabbbbc1edfae42da6bb38b.zip
Fix the build dependendency for the JDK. We
don't need the USE_LINUX since the linux-sun-jdk port already has it defined.
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.0/Makefile5
-rw-r--r--editors/openoffice.org-1.0/Makefile5
-rw-r--r--editors/openoffice/Makefile5
3 files changed, 9 insertions, 6 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 338af5caad8e..8084bc9ff31e 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -114,13 +114,14 @@ MAINTAINER= openoffice@FreeBSD.org
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/jakarta-ant
-BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
.if !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
.endif
.if !defined(WITH_BSD_JDK)
-USE_LINUX= yes
+BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/linux-sun-jdk13
+.else
+BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
.endif
USE_PERL5= yes
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 338af5caad8e..8084bc9ff31e 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -114,13 +114,14 @@ MAINTAINER= openoffice@FreeBSD.org
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/jakarta-ant
-BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
.if !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
.endif
.if !defined(WITH_BSD_JDK)
-USE_LINUX= yes
+BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/linux-sun-jdk13
+.else
+BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
.endif
USE_PERL5= yes
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 338af5caad8e..8084bc9ff31e 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -114,13 +114,14 @@ MAINTAINER= openoffice@FreeBSD.org
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/jakarta-ant
-BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
.if !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
.endif
.if !defined(WITH_BSD_JDK)
-USE_LINUX= yes
+BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/linux-sun-jdk13
+.else
+BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
.endif
USE_PERL5= yes