aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
committerbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
commit7b5950ceb07fbf7baff9cf5f999cb870df39056d (patch)
tree293dcbc9c7e5b5460095f0f0b868e1ead9528ded /editors
parentce8f3833463574b1140cd020d12c0b68cfcb0d83 (diff)
downloadfreebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.gz
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.zst
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.zip
Introduce ICONV_CONFIGURE_ARG variable defined at Uses/iconv.mk.
It's value is "--with-libiconv-prefix=/usr/local" for systems before 100043 with ports libiconv and to use at systems post 100043 with base iconv it's value is "" (NULL). Co-authors: bapt, madpilot and bsam (me)
Diffstat (limited to 'editors')
-rw-r--r--editors/ssed/Makefile4
-rw-r--r--editors/vile/Makefile2
-rw-r--r--editors/xvile/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/editors/ssed/Makefile b/editors/ssed/Makefile
index 825cee580c68..2b8890cbe4ac 100644
--- a/editors/ssed/Makefile
+++ b/editors/ssed/Makefile
@@ -19,8 +19,8 @@ MAN1= ssed.1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+USES+= gettext iconv
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/editors/vile/Makefile b/editors/vile/Makefile
index 200e537eaa4e..c8dc3b9ccbc5 100644
--- a/editors/vile/Makefile
+++ b/editors/vile/Makefile
@@ -39,7 +39,7 @@ PLIST_SUB+= SO_EXT=""
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
-CONFIGURE_ARGS+= --with-iconv --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= --with-iconv ${ICONV_CONFIGURE_ARG}
PLIST_SUB+= ICONV=""
.else
CONFIGURE_ARGS+= --without-iconv --without-locale
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index c224753188a3..cd3d8201db24 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -53,7 +53,7 @@ PLIST_SUB+= SO_EXT=""
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
-CONFIGURE_ARGS+= --with-iconv --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= --with-iconv ${ICONV_CONFIGURE_ARG}
PLIST_SUB+= ICONV=""
.else
BROKEN= Does not build if ICONV support is disabled