aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-02 22:53:32 +0800
committermiwi <miwi@FreeBSD.org>2013-03-02 22:53:32 +0800
commit7cb409bee10901aee77221284e2a1778627de108 (patch)
treeac76001a0545989e5ce456dce9cac5f8a6fdf0c7 /editors
parent9ea1b5184fb1df5c0375f8efd4fbcbba31d52479 (diff)
downloadfreebsd-ports-gnome-7cb409bee10901aee77221284e2a1778627de108.tar.gz
freebsd-ports-gnome-7cb409bee10901aee77221284e2a1778627de108.tar.zst
freebsd-ports-gnome-7cb409bee10901aee77221284e2a1778627de108.zip
- Update MASTER_SITES and WWW: line
- Add LICENSE - Add MAKE_JOBS_UNSAFE PR: 176546 Submitted by: Ports Fury
Diffstat (limited to 'editors')
-rw-r--r--editors/aee/Makefile53
-rw-r--r--editors/aee/pkg-descr2
2 files changed, 33 insertions, 22 deletions
diff --git a/editors/aee/Makefile b/editors/aee/Makefile
index a80671259155..483f22ed22e0 100644
--- a/editors/aee/Makefile
+++ b/editors/aee/Makefile
@@ -3,45 +3,56 @@
PORTNAME= aee
PORTVERSION= 2.2.15b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
-MASTER_SITES= http://mahon.cwx.net/sources/
+MASTER_SITES= http://www.users.uswest.net/~hmahon/sources/
MAINTAINER= ports@FreeBSD.org
COMMENT= Easy editor with both curses and X11 interfaces
+LICENSE= ART10
+
OPTIONS_DEFINE= XAE
XAE_DESC= Build X11 version 'xae'
+MAKE_JOBS_UNSAFE= yes
+
+MAN1= aee.1
+PLIST_FILES= bin/aee bin/rae %%DATADIR%%/help.ae
+PLIST_DIRS= %%DATADIR%%
+
.include <bsd.port.options.mk>
-.if !${PORT_OPTIONS:MXAE}
-ALL_TARGET= main
-PLIST_SUB= XAE="@comment "
-.else
+.if ${PORT_OPTIONS:MXAE}
USE_XORG= x11
ALL_TARGET= both
-PLIST_SUB= XAE=""
+PLIST_FILES+= bin/xae bin/rxae
+DESKTOP_ENTRIES="Xae" "" "" "xae" "" false
+.else
+ALL_TARGET= main
.endif
-PLIST_FILES= bin/aee bin/rae lib/help.ae %%XAE%%bin/xae %%XAE%%bin/rxae
-
-MAN1= aee.1
-
post-patch:
- @${REINPLACE_CMD} -e 's|cc|${CC}|g' ${WRKSRC}/create.mk.aee
- @${REINPLACE_CMD} -e 's|cc|${CC}|g' ${WRKSRC}/create.mk.xae
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
- ${WRKSRC}/create.mk.xae
+.for i in create.mk.aee create.mk.xae
+ @${REINPLACE_CMD} -e \
+ 's|cc|${CC}|g ; \
+ s|"-s"|""|g ; \
+ s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/${i}
+.endfor
+.for i in aee.1 localize.c
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local/lib|${DATADIR}|g' ${WRKSRC}/${i}
+.endfor
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/aee ${PREFIX}/bin
- ${LN} ${PREFIX}/bin/aee ${PREFIX}/bin/rae
- ${INSTALL_MAN} ${WRKSRC}/aee.1 ${PREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/help.ae ${PREFIX}/lib
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} aee ${PREFIX}/bin)
+ (cd ${PREFIX}/bin && ${LN} aee rae)
+ (cd ${WRKSRC} && ${INSTALL_MAN} aee.1 ${MANPREFIX}/man/man1)
+ @${MKDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} help.ae ${DATADIR})
.if ${PORT_OPTIONS:MXAE}
- ${INSTALL_PROGRAM} ${WRKSRC}/xae ${PREFIX}/bin
- ${LN} ${PREFIX}/bin/xae ${PREFIX}/bin/rxae
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} xae ${PREFIX}/bin)
+ (cd ${PREFIX}/bin && ${LN} xae rxae)
.endif
.include <bsd.port.mk>
diff --git a/editors/aee/pkg-descr b/editors/aee/pkg-descr
index 88d65ec3db78..344b4ed37e26 100644
--- a/editors/aee/pkg-descr
+++ b/editors/aee/pkg-descr
@@ -8,4 +8,4 @@ multiple edit buffers.
aee is a superset of the "Easy Editor" (ee) that is part of the
FreeBSD base system.
-WWW: http://mahon.cwx.net/
+WWW: http://www.users.uswest.net/~hmahon/