aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2010-08-16 01:01:29 +0800
committermezz <mezz@FreeBSD.org>2010-08-16 01:01:29 +0800
commit84429cef58c1946ef253e7675c5391e83299dea6 (patch)
tree3cf5c3ddc32fcbc77ced77761c2cb1e65ce67976 /editors
parent4a062a0ce2b6676b73a947ba7b9d2b179dc0d08f (diff)
downloadfreebsd-ports-gnome-84429cef58c1946ef253e7675c5391e83299dea6.tar.gz
freebsd-ports-gnome-84429cef58c1946ef253e7675c5391e83299dea6.tar.zst
freebsd-ports-gnome-84429cef58c1946ef253e7675c5391e83299dea6.zip
Remove check for static gravity. Bump the PORTREVISION. It fixes the annoy
message when run vim in GTK+2 like this: ** (gvim:32022): CRITICAL **: gtk_form_set_static_gravity: assertion `static_gravity_supported' failed Obtained from: http://ftp.vim.org/pub/vim/patches/7.2/7.2.257
Diffstat (limited to 'editors')
-rw-r--r--editors/vim6/Makefile2
-rw-r--r--editors/vim6/files/patch-7.2.25751
2 files changed, 52 insertions, 1 deletions
diff --git a/editors/vim6/Makefile b/editors/vim6/Makefile
index 268c6518e421..2360f35f1ab7 100644
--- a/editors/vim6/Makefile
+++ b/editors/vim6/Makefile
@@ -9,7 +9,7 @@
PORTNAME?= vim6
PATCHLEVEL= 9
PORTVERSION= 6.4.${PATCHLEVEL}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= editors
MASTER_SITES= ${MASTER_SITE_VIM}
DISTNAME= vim-${PORTVERSION:C/\.[0-9a-z]*$//}
diff --git a/editors/vim6/files/patch-7.2.257 b/editors/vim6/files/patch-7.2.257
new file mode 100644
index 000000000000..e17de297fb23
--- /dev/null
+++ b/editors/vim6/files/patch-7.2.257
@@ -0,0 +1,51 @@
+To: vim-dev@vim.org
+Subject: Patch 7.2.257
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 7.2.257
+Problem: With GTK 2.17 lots of assertion error messages.
+Solution: Remove check for static gravity. (Sebastian Droege)
+Files: src/gui_gtk_f.c
+
+
+*** ../vim-7.2.256/src/gui_gtk_f.c 2009-05-17 23:25:16.000000000 +0200
+--- gui_gtk_f.c 2009-09-11 15:15:41.000000000 +0200
+***************
+*** 860,870 ****
+ gtk_form_set_static_gravity(GdkWindow *window, gboolean use_static)
+ {
+ #ifdef HAVE_GTK2
+! gboolean static_gravity_supported;
+!
+! static_gravity_supported = gdk_window_set_static_gravities(window,
+! use_static);
+! g_return_if_fail(static_gravity_supported);
+ #else
+ XSetWindowAttributes xattributes;
+
+--- 860,868 ----
+ gtk_form_set_static_gravity(GdkWindow *window, gboolean use_static)
+ {
+ #ifdef HAVE_GTK2
+! /* We don't check if static gravity is actually supported, because it
+! * results in an annoying assertion error message. */
+! gdk_window_set_static_gravities(window, use_static);
+ #else
+ XSetWindowAttributes xattributes;
+
+--
+hundred-and-one symptoms of being an internet addict:
+231. You sprinkle Carpet Fresh on the rugs and put your vacuum cleaner
+ in the front doorway permanently so it always looks like you are
+ actually attempting to do something about that mess that has amassed
+ since you discovered the Internet.
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net \\\
+/// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\ download, build and distribute -- http://www.A-A-P.org ///
+ \\\ help me help AIDS victims -- http://ICCF-Holland.org ///