aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-02-28 06:30:09 +0800
committerwill <will@FreeBSD.org>2001-02-28 06:30:09 +0800
commit8a9d7a704f118e35133fe4de3788f9562cbf2f2e (patch)
tree678850a3758c9d1fd19ef2974aa468118c026bf5 /editors
parentafc00832c2b24c12b528e8c010f7ea31f1d7f075 (diff)
downloadfreebsd-ports-gnome-8a9d7a704f118e35133fe4de3788f9562cbf2f2e.tar.gz
freebsd-ports-gnome-8a9d7a704f118e35133fe4de3788f9562cbf2f2e.tar.zst
freebsd-ports-gnome-8a9d7a704f118e35133fe4de3788f9562cbf2f2e.zip
Add patches to fix build with KDE 2.1. Bump PORTREVISION to denote new
package based on KDE 2.1. Change MAINTAINER back to myself. This should fix kde2 metaport once again. Submitted by: many many people...
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/calligra/files/patch-kpbackground.h.new10
-rw-r--r--editors/calligra/files/patch-kppixmapobject.h10
-rw-r--r--editors/calligra/files/patch-kspread.h10
-rw-r--r--editors/calligra/files/patch-kspread_cluster.h11
-rw-r--r--editors/calligra/files/patch-kword_frame.cc11
-rw-r--r--editors/calligra/files/patch-kword_page.cc10
-rw-r--r--editors/koffice-kde3/Makefile3
-rw-r--r--editors/koffice-kde3/files/patch-kpbackground.h.new10
-rw-r--r--editors/koffice-kde3/files/patch-kppixmapobject.h10
-rw-r--r--editors/koffice-kde3/files/patch-kspread.h10
-rw-r--r--editors/koffice-kde3/files/patch-kspread_cluster.h11
-rw-r--r--editors/koffice-kde3/files/patch-kword_frame.cc11
-rw-r--r--editors/koffice-kde3/files/patch-kword_page.cc10
-rw-r--r--editors/koffice-kde4/Makefile3
-rw-r--r--editors/koffice-kde4/files/patch-kpbackground.h.new10
-rw-r--r--editors/koffice-kde4/files/patch-kppixmapobject.h10
-rw-r--r--editors/koffice-kde4/files/patch-kspread.h10
-rw-r--r--editors/koffice-kde4/files/patch-kspread_cluster.h11
-rw-r--r--editors/koffice-kde4/files/patch-kword_frame.cc11
-rw-r--r--editors/koffice-kde4/files/patch-kword_page.cc10
-rw-r--r--editors/koffice/Makefile3
-rw-r--r--editors/koffice/files/patch-kpbackground.h.new10
-rw-r--r--editors/koffice/files/patch-kppixmapobject.h10
-rw-r--r--editors/koffice/files/patch-kspread.h10
-rw-r--r--editors/koffice/files/patch-kspread_cluster.h11
-rw-r--r--editors/koffice/files/patch-kword_frame.cc11
-rw-r--r--editors/koffice/files/patch-kword_page.cc10
28 files changed, 256 insertions, 4 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 7c4d886debbc..a69564914598 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -7,11 +7,12 @@
PORTNAME= koffice
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
-MAINTAINER= kevlo@FreeBSD.org
+MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2 \
iconv.2:${PORTSDIR}/converters/iconv
diff --git a/editors/calligra/files/patch-kpbackground.h.new b/editors/calligra/files/patch-kpbackground.h.new
new file mode 100644
index 000000000000..271f1b05d2d2
--- /dev/null
+++ b/editors/calligra/files/patch-kpbackground.h.new
@@ -0,0 +1,10 @@
+--- kpresenter/kpbackground.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kpbackground.h.new Tue Feb 27 16:52:49 2001
+@@ -20,6 +20,7 @@
+ #ifndef kpbackground_h
+ #define kpbackground_h
+
++#include <stdlib.h>
+ #include <qcolor.h>
+ #include <qstring.h>
+ #include <qrect.h>
diff --git a/editors/calligra/files/patch-kppixmapobject.h b/editors/calligra/files/patch-kppixmapobject.h
new file mode 100644
index 000000000000..ac30fba20bab
--- /dev/null
+++ b/editors/calligra/files/patch-kppixmapobject.h
@@ -0,0 +1,10 @@
+--- kpresenter/kppixmapobject.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kppixmapobject.h.new Tue Feb 27 16:45:55 2001
+@@ -20,6 +20,7 @@
+ #ifndef kppixmapobject_h
+ #define kppixmapobject_h
+
++#include <stdlib.h>
+ #include <qdatetime.h>
+
+ #include "kpobject.h"
diff --git a/editors/calligra/files/patch-kspread.h b/editors/calligra/files/patch-kspread.h
new file mode 100644
index 000000000000..afdba0bb7a8a
--- /dev/null
+++ b/editors/calligra/files/patch-kspread.h
@@ -0,0 +1,10 @@
+--- kspread/kspread_util.h Sun Jun 25 04:09:50 2000
++++ kspread/kspread_util.h.new Tue Feb 27 17:00:17 2001
+@@ -20,6 +20,7 @@
+ #ifndef __kspread_util_h__
+ #define __kspread_util_h__
+
++#include <stdlib.h>
+ #include <qstring.h>
+ #include <qrect.h>
+
diff --git a/editors/calligra/files/patch-kspread_cluster.h b/editors/calligra/files/patch-kspread_cluster.h
new file mode 100644
index 000000000000..6df3e047c6b8
--- /dev/null
+++ b/editors/calligra/files/patch-kspread_cluster.h
@@ -0,0 +1,11 @@
+--- kspread/kspread_cluster.h Thu Jul 13 14:35:01 2000
++++ kspread/kspread_cluster.h.new Tue Feb 27 17:09:23 2001
+@@ -1,6 +1,8 @@
+ #ifndef kspread_cluster_h
+ #define kspread_cluster_h
+
++#include <stdlib.h>
++
+ class KSpreadCell;
+ class ColumnLayout;
+ class RowLayout;
diff --git a/editors/calligra/files/patch-kword_frame.cc b/editors/calligra/files/patch-kword_frame.cc
new file mode 100644
index 000000000000..d26624673465
--- /dev/null
+++ b/editors/calligra/files/patch-kword_frame.cc
@@ -0,0 +1,11 @@
+--- kword/kword_frame.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_frame.cc.new Tue Feb 27 17:17:40 2001
+@@ -30,7 +30,7 @@
+
+ #include <kdebug.h>
+ #include <koPageLayoutDia.h>
+-
++#include <stdlib.h>
+ #include <fstream>
+ #include <unistd.h>
+ #include <limits.h>
diff --git a/editors/calligra/files/patch-kword_page.cc b/editors/calligra/files/patch-kword_page.cc
new file mode 100644
index 000000000000..80056bd94af4
--- /dev/null
+++ b/editors/calligra/files/patch-kword_page.cc
@@ -0,0 +1,10 @@
+--- kword/kword_page.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_page.cc.new Tue Feb 27 17:14:33 2001
+@@ -17,6 +17,7 @@
+ Boston, MA 02111-1307, USA.
+ */
+
++#include <stdlib.h>
+ #include <kfiledialog.h>
+ #include <kapp.h>
+ #include <kmimemagic.h>
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 7c4d886debbc..a69564914598 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -7,11 +7,12 @@
PORTNAME= koffice
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
-MAINTAINER= kevlo@FreeBSD.org
+MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2 \
iconv.2:${PORTSDIR}/converters/iconv
diff --git a/editors/koffice-kde3/files/patch-kpbackground.h.new b/editors/koffice-kde3/files/patch-kpbackground.h.new
new file mode 100644
index 000000000000..271f1b05d2d2
--- /dev/null
+++ b/editors/koffice-kde3/files/patch-kpbackground.h.new
@@ -0,0 +1,10 @@
+--- kpresenter/kpbackground.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kpbackground.h.new Tue Feb 27 16:52:49 2001
+@@ -20,6 +20,7 @@
+ #ifndef kpbackground_h
+ #define kpbackground_h
+
++#include <stdlib.h>
+ #include <qcolor.h>
+ #include <qstring.h>
+ #include <qrect.h>
diff --git a/editors/koffice-kde3/files/patch-kppixmapobject.h b/editors/koffice-kde3/files/patch-kppixmapobject.h
new file mode 100644
index 000000000000..ac30fba20bab
--- /dev/null
+++ b/editors/koffice-kde3/files/patch-kppixmapobject.h
@@ -0,0 +1,10 @@
+--- kpresenter/kppixmapobject.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kppixmapobject.h.new Tue Feb 27 16:45:55 2001
+@@ -20,6 +20,7 @@
+ #ifndef kppixmapobject_h
+ #define kppixmapobject_h
+
++#include <stdlib.h>
+ #include <qdatetime.h>
+
+ #include "kpobject.h"
diff --git a/editors/koffice-kde3/files/patch-kspread.h b/editors/koffice-kde3/files/patch-kspread.h
new file mode 100644
index 000000000000..afdba0bb7a8a
--- /dev/null
+++ b/editors/koffice-kde3/files/patch-kspread.h
@@ -0,0 +1,10 @@
+--- kspread/kspread_util.h Sun Jun 25 04:09:50 2000
++++ kspread/kspread_util.h.new Tue Feb 27 17:00:17 2001
+@@ -20,6 +20,7 @@
+ #ifndef __kspread_util_h__
+ #define __kspread_util_h__
+
++#include <stdlib.h>
+ #include <qstring.h>
+ #include <qrect.h>
+
diff --git a/editors/koffice-kde3/files/patch-kspread_cluster.h b/editors/koffice-kde3/files/patch-kspread_cluster.h
new file mode 100644
index 000000000000..6df3e047c6b8
--- /dev/null
+++ b/editors/koffice-kde3/files/patch-kspread_cluster.h
@@ -0,0 +1,11 @@
+--- kspread/kspread_cluster.h Thu Jul 13 14:35:01 2000
++++ kspread/kspread_cluster.h.new Tue Feb 27 17:09:23 2001
+@@ -1,6 +1,8 @@
+ #ifndef kspread_cluster_h
+ #define kspread_cluster_h
+
++#include <stdlib.h>
++
+ class KSpreadCell;
+ class ColumnLayout;
+ class RowLayout;
diff --git a/editors/koffice-kde3/files/patch-kword_frame.cc b/editors/koffice-kde3/files/patch-kword_frame.cc
new file mode 100644
index 000000000000..d26624673465
--- /dev/null
+++ b/editors/koffice-kde3/files/patch-kword_frame.cc
@@ -0,0 +1,11 @@
+--- kword/kword_frame.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_frame.cc.new Tue Feb 27 17:17:40 2001
+@@ -30,7 +30,7 @@
+
+ #include <kdebug.h>
+ #include <koPageLayoutDia.h>
+-
++#include <stdlib.h>
+ #include <fstream>
+ #include <unistd.h>
+ #include <limits.h>
diff --git a/editors/koffice-kde3/files/patch-kword_page.cc b/editors/koffice-kde3/files/patch-kword_page.cc
new file mode 100644
index 000000000000..80056bd94af4
--- /dev/null
+++ b/editors/koffice-kde3/files/patch-kword_page.cc
@@ -0,0 +1,10 @@
+--- kword/kword_page.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_page.cc.new Tue Feb 27 17:14:33 2001
+@@ -17,6 +17,7 @@
+ Boston, MA 02111-1307, USA.
+ */
+
++#include <stdlib.h>
+ #include <kfiledialog.h>
+ #include <kapp.h>
+ #include <kmimemagic.h>
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 7c4d886debbc..a69564914598 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -7,11 +7,12 @@
PORTNAME= koffice
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
-MAINTAINER= kevlo@FreeBSD.org
+MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2 \
iconv.2:${PORTSDIR}/converters/iconv
diff --git a/editors/koffice-kde4/files/patch-kpbackground.h.new b/editors/koffice-kde4/files/patch-kpbackground.h.new
new file mode 100644
index 000000000000..271f1b05d2d2
--- /dev/null
+++ b/editors/koffice-kde4/files/patch-kpbackground.h.new
@@ -0,0 +1,10 @@
+--- kpresenter/kpbackground.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kpbackground.h.new Tue Feb 27 16:52:49 2001
+@@ -20,6 +20,7 @@
+ #ifndef kpbackground_h
+ #define kpbackground_h
+
++#include <stdlib.h>
+ #include <qcolor.h>
+ #include <qstring.h>
+ #include <qrect.h>
diff --git a/editors/koffice-kde4/files/patch-kppixmapobject.h b/editors/koffice-kde4/files/patch-kppixmapobject.h
new file mode 100644
index 000000000000..ac30fba20bab
--- /dev/null
+++ b/editors/koffice-kde4/files/patch-kppixmapobject.h
@@ -0,0 +1,10 @@
+--- kpresenter/kppixmapobject.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kppixmapobject.h.new Tue Feb 27 16:45:55 2001
+@@ -20,6 +20,7 @@
+ #ifndef kppixmapobject_h
+ #define kppixmapobject_h
+
++#include <stdlib.h>
+ #include <qdatetime.h>
+
+ #include "kpobject.h"
diff --git a/editors/koffice-kde4/files/patch-kspread.h b/editors/koffice-kde4/files/patch-kspread.h
new file mode 100644
index 000000000000..afdba0bb7a8a
--- /dev/null
+++ b/editors/koffice-kde4/files/patch-kspread.h
@@ -0,0 +1,10 @@
+--- kspread/kspread_util.h Sun Jun 25 04:09:50 2000
++++ kspread/kspread_util.h.new Tue Feb 27 17:00:17 2001
+@@ -20,6 +20,7 @@
+ #ifndef __kspread_util_h__
+ #define __kspread_util_h__
+
++#include <stdlib.h>
+ #include <qstring.h>
+ #include <qrect.h>
+
diff --git a/editors/koffice-kde4/files/patch-kspread_cluster.h b/editors/koffice-kde4/files/patch-kspread_cluster.h
new file mode 100644
index 000000000000..6df3e047c6b8
--- /dev/null
+++ b/editors/koffice-kde4/files/patch-kspread_cluster.h
@@ -0,0 +1,11 @@
+--- kspread/kspread_cluster.h Thu Jul 13 14:35:01 2000
++++ kspread/kspread_cluster.h.new Tue Feb 27 17:09:23 2001
+@@ -1,6 +1,8 @@
+ #ifndef kspread_cluster_h
+ #define kspread_cluster_h
+
++#include <stdlib.h>
++
+ class KSpreadCell;
+ class ColumnLayout;
+ class RowLayout;
diff --git a/editors/koffice-kde4/files/patch-kword_frame.cc b/editors/koffice-kde4/files/patch-kword_frame.cc
new file mode 100644
index 000000000000..d26624673465
--- /dev/null
+++ b/editors/koffice-kde4/files/patch-kword_frame.cc
@@ -0,0 +1,11 @@
+--- kword/kword_frame.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_frame.cc.new Tue Feb 27 17:17:40 2001
+@@ -30,7 +30,7 @@
+
+ #include <kdebug.h>
+ #include <koPageLayoutDia.h>
+-
++#include <stdlib.h>
+ #include <fstream>
+ #include <unistd.h>
+ #include <limits.h>
diff --git a/editors/koffice-kde4/files/patch-kword_page.cc b/editors/koffice-kde4/files/patch-kword_page.cc
new file mode 100644
index 000000000000..80056bd94af4
--- /dev/null
+++ b/editors/koffice-kde4/files/patch-kword_page.cc
@@ -0,0 +1,10 @@
+--- kword/kword_page.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_page.cc.new Tue Feb 27 17:14:33 2001
+@@ -17,6 +17,7 @@
+ Boston, MA 02111-1307, USA.
+ */
+
++#include <stdlib.h>
+ #include <kfiledialog.h>
+ #include <kapp.h>
+ #include <kmimemagic.h>
diff --git a/editors/koffice/Makefile b/editors/koffice/Makefile
index 7c4d886debbc..a69564914598 100644
--- a/editors/koffice/Makefile
+++ b/editors/koffice/Makefile
@@ -7,11 +7,12 @@
PORTNAME= koffice
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
-MAINTAINER= kevlo@FreeBSD.org
+MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2 \
iconv.2:${PORTSDIR}/converters/iconv
diff --git a/editors/koffice/files/patch-kpbackground.h.new b/editors/koffice/files/patch-kpbackground.h.new
new file mode 100644
index 000000000000..271f1b05d2d2
--- /dev/null
+++ b/editors/koffice/files/patch-kpbackground.h.new
@@ -0,0 +1,10 @@
+--- kpresenter/kpbackground.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kpbackground.h.new Tue Feb 27 16:52:49 2001
+@@ -20,6 +20,7 @@
+ #ifndef kpbackground_h
+ #define kpbackground_h
+
++#include <stdlib.h>
+ #include <qcolor.h>
+ #include <qstring.h>
+ #include <qrect.h>
diff --git a/editors/koffice/files/patch-kppixmapobject.h b/editors/koffice/files/patch-kppixmapobject.h
new file mode 100644
index 000000000000..ac30fba20bab
--- /dev/null
+++ b/editors/koffice/files/patch-kppixmapobject.h
@@ -0,0 +1,10 @@
+--- kpresenter/kppixmapobject.h Sat Aug 26 04:53:37 2000
++++ kpresenter/kppixmapobject.h.new Tue Feb 27 16:45:55 2001
+@@ -20,6 +20,7 @@
+ #ifndef kppixmapobject_h
+ #define kppixmapobject_h
+
++#include <stdlib.h>
+ #include <qdatetime.h>
+
+ #include "kpobject.h"
diff --git a/editors/koffice/files/patch-kspread.h b/editors/koffice/files/patch-kspread.h
new file mode 100644
index 000000000000..afdba0bb7a8a
--- /dev/null
+++ b/editors/koffice/files/patch-kspread.h
@@ -0,0 +1,10 @@
+--- kspread/kspread_util.h Sun Jun 25 04:09:50 2000
++++ kspread/kspread_util.h.new Tue Feb 27 17:00:17 2001
+@@ -20,6 +20,7 @@
+ #ifndef __kspread_util_h__
+ #define __kspread_util_h__
+
++#include <stdlib.h>
+ #include <qstring.h>
+ #include <qrect.h>
+
diff --git a/editors/koffice/files/patch-kspread_cluster.h b/editors/koffice/files/patch-kspread_cluster.h
new file mode 100644
index 000000000000..6df3e047c6b8
--- /dev/null
+++ b/editors/koffice/files/patch-kspread_cluster.h
@@ -0,0 +1,11 @@
+--- kspread/kspread_cluster.h Thu Jul 13 14:35:01 2000
++++ kspread/kspread_cluster.h.new Tue Feb 27 17:09:23 2001
+@@ -1,6 +1,8 @@
+ #ifndef kspread_cluster_h
+ #define kspread_cluster_h
+
++#include <stdlib.h>
++
+ class KSpreadCell;
+ class ColumnLayout;
+ class RowLayout;
diff --git a/editors/koffice/files/patch-kword_frame.cc b/editors/koffice/files/patch-kword_frame.cc
new file mode 100644
index 000000000000..d26624673465
--- /dev/null
+++ b/editors/koffice/files/patch-kword_frame.cc
@@ -0,0 +1,11 @@
+--- kword/kword_frame.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_frame.cc.new Tue Feb 27 17:17:40 2001
+@@ -30,7 +30,7 @@
+
+ #include <kdebug.h>
+ #include <koPageLayoutDia.h>
+-
++#include <stdlib.h>
+ #include <fstream>
+ #include <unistd.h>
+ #include <limits.h>
diff --git a/editors/koffice/files/patch-kword_page.cc b/editors/koffice/files/patch-kword_page.cc
new file mode 100644
index 000000000000..80056bd94af4
--- /dev/null
+++ b/editors/koffice/files/patch-kword_page.cc
@@ -0,0 +1,10 @@
+--- kword/kword_page.cc Sun Oct 15 15:48:52 2000
++++ kword/kword_page.cc.new Tue Feb 27 17:14:33 2001
+@@ -17,6 +17,7 @@
+ Boston, MA 02111-1307, USA.
+ */
+
++#include <stdlib.h>
+ #include <kfiledialog.h>
+ #include <kapp.h>
+ #include <kmimemagic.h>