aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-22 20:55:18 +0800
committermakc <makc@FreeBSD.org>2013-11-22 20:55:18 +0800
commit9a1c12c35ce45ac3ef0446aeeb9d78a85d351753 (patch)
treee5d8fb03dadf7c4332a432be715b65ed71eed93f /editors
parent6a8fa025703756528837f1ccf220676f5c3848f0 (diff)
downloadfreebsd-ports-gnome-9a1c12c35ce45ac3ef0446aeeb9d78a85d351753.tar.gz
freebsd-ports-gnome-9a1c12c35ce45ac3ef0446aeeb9d78a85d351753.tar.zst
freebsd-ports-gnome-9a1c12c35ce45ac3ef0446aeeb9d78a85d351753.zip
- Convert to USES=qmake
- Use options helpers - Convert LIB_DEPENDS to new style Approved by: portmgr (blanket approval)
Diffstat (limited to 'editors')
-rw-r--r--editors/tea/Makefile32
-rw-r--r--editors/texmakerx/Makefile31
2 files changed, 18 insertions, 45 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 31b54d02f635..bed5727a968d 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -16,8 +16,9 @@ OPTIONS_RADIO= SPELL
OPTIONS_RADIO_SPELL= ASPELL HUNSPELL
OPTIONS_DEFAULT= ASPELL
+USES= qmake
USE_BZIP2= yes
-USE_QT4= gui moc_build qmake_build rcc_build
+USE_QT4= gui moc_build rcc_build
PLIST_FILES= bin/tea share/pixmaps/tea_icon_v2.png
PORTDOCS= *
@@ -25,21 +26,13 @@ PORTDOCS= *
DESKTOP_ENTRIES="TEA" "" "${PREFIX}/share/pixmaps/tea_icon_v2.png" \
"${PORTNAME}" "" ""
-.include <bsd.port.options.mk>
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+ASPELL_QMAKE_ON= USE_ASPELL=true
+ASPELL_QMAKE_OFF= USE_ASPELL=false
-.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
-QMAKEFLAGS+= USE_ASPELL=true
-.else
-QMAKEFLAGS+= USE_ASPELL=false
-.endif
-
-.if ${PORT_OPTIONS:MHUNSPELL}
-LIB_DEPENDS+= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
-QMAKEFLAGS+= USE_HUNSPELL=true
-.else
-QMAKEFLAGS+= USE_HUNSPELL=false
-.endif
+HUNSPELL_LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
+HUNSPELL_QMAKE_ON= USE_HUNSPELL=true
+HUNSPELL_QMAKE_OFF= USE_HUNSPELL=false
post-patch:
@${REINPLACE_CMD} -e \
@@ -47,14 +40,9 @@ post-patch:
@${REINPLACE_CMD} -e \
's|/usr/include|${LOCALBASE}/include|' ${WRKSRC}/src.pro
-do-configure:
- @cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
-
do-install:
- (cd ${WRKSRC}/bin \
- && ${INSTALL_PROGRAM} tea ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/icons \
- && ${INSTALL_DATA} tea_icon_v2.png ${STAGEDIR}${PREFIX}/share/pixmaps)
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/tea ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/icons/tea_icon_v2.png ${STAGEDIR}${PREFIX}/share/pixmaps
(cd ${WRKSRC}/manuals \
&& ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
diff --git a/editors/texmakerx/Makefile b/editors/texmakerx/Makefile
index 329f5823bd7d..1d9413a2b0a6 100644
--- a/editors/texmakerx/Makefile
+++ b/editors/texmakerx/Makefile
@@ -9,37 +9,26 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/TexMakerX%20${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION:S:.0::}
MAINTAINER= lx@FreeBSD.org
-COMMENT= A LaTeX IDE derived from Texmaker
+COMMENT= LaTeX IDE derived from Texmaker
-LIB_DEPENDS= poppler:${PORTSDIR}/graphics/poppler \
- poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler \
+ libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
-USE_GHOSTSCRIPT=yes
-USE_QT4= gui network xml moc_build qmake_build rcc_build \
+USES= dos2unix qmake
+USE_GHOSTSCRIPT_RUN= yes
+USE_QT4= gui network xml moc_build rcc_build \
uic_build qtestlib script
USE_TEX= latex dvipsk
-USE_DOS2UNIX= yes
-HAS_CONFIGURE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= XDVI GV
GV_DESC= View ps files with gv
+GV_RUN_DEPENDS= xdvi:${PORTSDIR}/print/xdvik
XDVI_DESC= View dvi files with xdvi
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXDVI}
-RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
-.endif
-
-.if ${PORT_OPTIONS:MGV}
-RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
-.endif
+XDVI_RUN_DEPENDS= gv:${PORTSDIR}/print/gv
post-patch:
@${REINPLACE_CMD} -e 's,^\(utilities.path =\).*,\1 ${DATADIR},' \
@@ -47,8 +36,4 @@ post-patch:
-e 's,/usr/lib,${LOCALBASE}/lib,g' \
${WRKSRC}/${PORTNAME}.pro
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} PREFIX=${PREFIX} ${PORTNAME}.pro
-
.include <bsd.port.mk>