aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2010-09-19 08:30:49 +0800
committerobrien <obrien@FreeBSD.org>2010-09-19 08:30:49 +0800
commita610de1ec42cfc1797ea528a5718b75e8f2684e0 (patch)
tree1835fa1d49831f1f16698a5655c4e8b4a022909a /editors
parent8cba4d877d1f190f776510fc7b93fffd3a960ef6 (diff)
downloadfreebsd-ports-gnome-a610de1ec42cfc1797ea528a5718b75e8f2684e0.tar.gz
freebsd-ports-gnome-a610de1ec42cfc1797ea528a5718b75e8f2684e0.tar.zst
freebsd-ports-gnome-a610de1ec42cfc1797ea528a5718b75e8f2684e0.zip
Obey BSD's 'STRIP= ' setting.
PR: 150689 Submitted by: swell.k@gmail.com
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index ef0ea383b502..bec80289f989 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -193,6 +193,9 @@ CTAGS_CMD= ${FIND} . -type f \\|${XARGS} ctags
post-patch:
@(${FIND} ${WRKSRC}/../runtime/ -name menu\*.vim -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's,ctags -R \.,${CTAGS_CMD},g')
+.if !defined(STRIP) || ${STRIP} == ""
+ ${REINPLACE_CMD} '/$$(STRIP)/d' ${WRKSRC}/Makefile
+.endif
pre-configure:
# Fix dependency misspelling so that 'make -j#' will work.