aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-12 18:53:38 +0800
committerbapt <bapt@FreeBSD.org>2013-12-12 18:53:38 +0800
commitafa514e55d965168153a8b1b6e4843fb8bf7785a (patch)
tree6cb6f0da787d4b67708abc802fa739d71222bbdc /editors
parentc8a4e806481ba453004f7526561a209d7f21e6aa (diff)
downloadfreebsd-ports-gnome-afa514e55d965168153a8b1b6e4843fb8bf7785a.tar.gz
freebsd-ports-gnome-afa514e55d965168153a8b1b6e4843fb8bf7785a.tar.zst
freebsd-ports-gnome-afa514e55d965168153a8b1b6e4843fb8bf7785a.zip
Convert LIB_DEPENDS for ports depending on boost
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile40
-rw-r--r--editors/madedit/Makefile2
2 files changed, 21 insertions, 21 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index f1aa04b89b93..39607c91d580 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -11,26 +11,26 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE graphic art and office suite
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- qca:${PORTSDIR}/devel/qca \
- exiv2:${PORTSDIR}/graphics/exiv2 \
- lcms2:${PORTSDIR}/graphics/lcms2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- wpd-0.9:${PORTSDIR}/textproc/libwpd \
- wpg-0.2:${PORTSDIR}/graphics/libwpg \
- poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
- openjpeg:${PORTSDIR}/graphics/openjpeg \
- jpeg:${PORTSDIR}/graphics/jpeg \
- dcmdata:${PORTSDIR}/devel/dcmtk \
- fftw3:${PORTSDIR}/math/fftw3 \
- tiff:${PORTSDIR}/graphics/tiff \
- gsl:${PORTSDIR}/math/gsl \
- wps-0.2:${PORTSDIR}/textproc/libwps \
- visio-0.0:${PORTSDIR}/textproc/libvisio \
- OpenColorIO:${PORTSDIR}/graphics/opencolorio
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libqca.so:${PORTSDIR}/devel/qca \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libwpd-0.9.so:${PORTSDIR}/textproc/libwpd \
+ libwpg-0.2.so:${PORTSDIR}/graphics/libwpg \
+ libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4 \
+ libopenjpeg.so:${PORTSDIR}/graphics/openjpeg \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libdcmdata.so:${PORTSDIR}/devel/dcmtk \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libgsl.so:${PORTSDIR}/math/gsl \
+ libwps-0.2.so:${PORTSDIR}/textproc/libwps \
+ libvisio-0.0.so:${PORTSDIR}/textproc/libvisio \
+ libOpenColorIO.so:${PORTSDIR}/graphics/opencolorio
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
CONFLICTS= koffice-kde4-2.*
diff --git a/editors/madedit/Makefile b/editors/madedit/Makefile
index 6132449144b1..ec5e14fd7f54 100644
--- a/editors/madedit/Makefile
+++ b/editors/madedit/Makefile
@@ -16,7 +16,7 @@ USES= gettext pkgconfig dos2unix
USE_WX= 2.6+
WANT_UNICODE= yes
-LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS+= libboost_regex.so:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}