aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-03-16 19:48:45 +0800
committerdanfe <danfe@FreeBSD.org>2013-03-16 19:48:45 +0800
commitc3679ebd26d4d288f39a74c6cb7108efa263a771 (patch)
tree6ea02d1fa07bb5a90ebdc542b3947b1c13abd1bd /editors
parent22d7eeef175857924d0006a7554f44d3c6a1a4e5 (diff)
downloadfreebsd-ports-gnome-c3679ebd26d4d288f39a74c6cb7108efa263a771.tar.gz
freebsd-ports-gnome-c3679ebd26d4d288f39a74c6cb7108efa263a771.tar.zst
freebsd-ports-gnome-c3679ebd26d4d288f39a74c6cb7108efa263a771.zip
- Trim Makefile header
- Convert to OptionsNG - Drop ABI version in LIB_DEPENDS
Diffstat (limited to 'editors')
-rw-r--r--editors/biew/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 42be21f3bdda..e6c23ee90461 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: BIEW (now called BEYE, Binary EYE)
-# Date created: 04 February 2000
-# Whom: Michael Vasilenko <acid@stu.cn.ua>
-#
+# Created by: Michael Vasilenko <acid@stu.cn.ua>
# $FreeBSD$
-#
PORTNAME= biew
PORTVERSION= 6.1.0
@@ -32,16 +28,19 @@ MAN1= biew.1
PORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
file_ini.ru release.txt unix.txt
-OPTIONS= SLANG "Use S-Lang based display renderer" on
+OPTIONS_DEFINE= SLANG DOCS
+OPTIONS_DEFAULT= SLANG
-.include <bsd.port.pre.mk>
+SLANG_DESC= Use S-Lang based display renderer
+
+.include <bsd.port.options.mk>
.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile
.endif
-.if defined(WITH_SLANG)
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+.if ${PORT_OPTIONS:MSLANG}
+LIB_DEPENDS= slang:${PORTSDIR}/devel/libslang2
CONFIGURE_ARGS+= --enable-slang
.else
CONFIGURE_ARGS+= --enable-curses
@@ -72,9 +71,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/bin_rc/syntax/* ${DATADIR}/syntax
${INSTALL_DATA} ${WRKSRC}/bin_rc/xlt/russian/* ${DATADIR}/xlt
${INSTALL_MAN} ${WRKSRC}/doc/biew.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>