aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2003-09-08 23:36:05 +0800
committermbr <mbr@FreeBSD.org>2003-09-08 23:36:05 +0800
commitc7dc28e461e78cea38f0944328b473a0e08dbf1c (patch)
tree9fe1e5c1b6e1f529e77b134a2459792eb9499600 /editors
parent26072e4566eb3f4982df046139bf621f734c5f99 (diff)
downloadfreebsd-ports-gnome-c7dc28e461e78cea38f0944328b473a0e08dbf1c.tar.gz
freebsd-ports-gnome-c7dc28e461e78cea38f0944328b473a0e08dbf1c.tar.zst
freebsd-ports-gnome-c7dc28e461e78cea38f0944328b473a0e08dbf1c.zip
Add gcc port dependency.
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.1-devel/Makefile1
-rw-r--r--editors/openoffice-1.1/Makefile1
-rw-r--r--editors/openoffice-2.0-devel/Makefile1
-rw-r--r--editors/openoffice-3-devel/Makefile1
-rw-r--r--editors/openoffice-3/Makefile1
-rw-r--r--editors/openoffice-devel/Makefile1
-rw-r--r--editors/openoffice.org-1.1-devel/Makefile1
-rw-r--r--editors/openoffice.org-1.1/Makefile1
-rw-r--r--editors/openoffice.org-2-RC/Makefile1
-rw-r--r--editors/openoffice.org-2-devel/Makefile1
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile1
-rw-r--r--editors/openoffice.org-2.0/Makefile1
-rw-r--r--editors/openoffice.org-2/Makefile1
-rw-r--r--editors/openoffice.org-3-RC/Makefile1
-rw-r--r--editors/openoffice.org-3-devel/Makefile1
-rw-r--r--editors/openoffice.org-3/Makefile1
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile1
17 files changed, 17 insertions, 0 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice-1.1/Makefile b/editors/openoffice-1.1/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice-1.1/Makefile
+++ b/editors/openoffice-1.1/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice-2.0-devel/Makefile b/editors/openoffice-2.0-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice-2.0-devel/Makefile
+++ b/editors/openoffice-2.0-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-1.1-devel/Makefile b/editors/openoffice.org-1.1-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-1.1-devel/Makefile
+++ b/editors/openoffice.org-1.1-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-1.1/Makefile b/editors/openoffice.org-1.1/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-1.1/Makefile
+++ b/editors/openoffice.org-1.1/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-2.0/Makefile b/editors/openoffice.org-2.0/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-2.0/Makefile
+++ b/editors/openoffice.org-2.0/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 464666f4c594..941324b73b2c 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -90,6 +90,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
.if ${OSVERSION} < 500000
# OOo requires gcc 3.3 (not systems's gcc)
+BUILD_DEPENDS+= gcc33:${PORTSDIR}/lang/gcc33
USE_GCC=3.3 # make no sense yet
CC= gcc33
CXX= g++33