aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2012-05-29 11:45:00 +0800
committerdanfe <danfe@FreeBSD.org>2012-05-29 11:45:00 +0800
commitcc39200bf7367151f42bc89a3d0e258330566e3f (patch)
treeba805373b90b6e67f7ab734326c252662845d92e /editors
parent4bef17ac1112c4d76a09881c12523530894fc046 (diff)
downloadfreebsd-ports-gnome-cc39200bf7367151f42bc89a3d0e258330566e3f.tar.gz
freebsd-ports-gnome-cc39200bf7367151f42bc89a3d0e258330566e3f.tar.zst
freebsd-ports-gnome-cc39200bf7367151f42bc89a3d0e258330566e3f.zip
Add heme 0.4.2, small, slick, and fast console hex editor for Unix-like
systems. If you're tired of utterly buggy screen and input handling of editors/biew, but want a pure console hex editor, give this one a try. WWW: http://sourceforge.net/projects/heme/
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/heme/Makefile31
-rw-r--r--editors/heme/distinfo2
-rw-r--r--editors/heme/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 0a56407b28a3..6cd8a4827c98 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -64,6 +64,7 @@
SUBDIR += gobby
SUBDIR += gphpedit
SUBDIR += gwrite
+ SUBDIR += heme
SUBDIR += hexcurse
SUBDIR += hexedit
SUBDIR += hexpert
diff --git a/editors/heme/Makefile b/editors/heme/Makefile
new file mode 100644
index 000000000000..1874e6921999
--- /dev/null
+++ b/editors/heme/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: heme
+# Date created: 29 May 2012
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= heme
+PORTVERSION= 0.4.2
+CATEGORIES= editors
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Portable and fast console hex editor for Unix-like systems
+
+LICENSE= GPLv2
+
+ALL_TARGET= ${PORTNAME}
+MAKE_ARGS= CFLAGS="${CFLAGS} -Wall -DHAVE_MMAP" INSTALL_PREFIX="${PREFIX}"
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+PORTDOCS= README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/editors/heme/distinfo b/editors/heme/distinfo
new file mode 100644
index 000000000000..453f3aa4f2a4
--- /dev/null
+++ b/editors/heme/distinfo
@@ -0,0 +1,2 @@
+SHA256 (heme-0.4.2.tar.gz) = 3ba5c7883cb4b79f22d5b9b6f401c70655c41518531441347e5fd15c8bb45973
+SIZE (heme-0.4.2.tar.gz) = 21815
diff --git a/editors/heme/pkg-descr b/editors/heme/pkg-descr
new file mode 100644
index 000000000000..eee4112535b6
--- /dev/null
+++ b/editors/heme/pkg-descr
@@ -0,0 +1,11 @@
+Heme is intended to be fast and portable console hex editor for Unix-like
+systems. It has undo support (number of undo operations is only limited by
+available memory), ability to fill a range of addresses with the specified
+byte, ability to search for a single byte or character string. Offsets can
+be given in hexadecimal, octal, or decimal forms. There are two editing
+modes: hex (binary) and ASCII (text).
+
+Heme uses standard curses library for screen and input handling, and offers
+colors support (they can be set in the configuration file).
+
+WWW: http://sourceforge.net/projects/heme/