aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-23 18:19:45 +0800
committerbapt <bapt@FreeBSD.org>2013-04-23 18:19:45 +0800
commitcc9da7cf72f748a1ae9fcd3ab5aed032ad3ab188 (patch)
treed1c32a7b5fa2a2eaa7b78f599c959792a18b9fa4 /editors
parent11c0610b9e646125696b12a43e2585bfb141e9ef (diff)
downloadfreebsd-ports-gnome-cc9da7cf72f748a1ae9fcd3ab5aed032ad3ab188.tar.gz
freebsd-ports-gnome-cc9da7cf72f748a1ae9fcd3ab5aed032ad3ab188.tar.zst
freebsd-ports-gnome-cc9da7cf72f748a1ae9fcd3ab5aed032ad3ab188.zip
Convert e* to USES=pkgconfig
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/deforaos-editor/Makefile2
-rw-r--r--editors/fxite/Makefile2
-rw-r--r--editors/libreoffice/Makefile3
-rw-r--r--editors/texworks/Makefile2
5 files changed, 5 insertions, 7 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index fdb98695830c..c4314e103577 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -42,13 +42,12 @@ USE_ICONV= yes
USE_KDE4= kactivities kdehier kdelibs kdeprefix libkdcraw nepomuk-core \
okular pimlibs attica automoc4 sharedmime soprano
USE_PERL5= yes
-USE_PKGCONFIG= yes
USE_QT4= dbus designer_build gui opengl phonon porting_build qt3support \
qtestlib_build script sql svg webkit xml xmlpatterns \
moc_build qmake_build rcc_build uic_build uic3_build
USE_SQLITE= 3
USE_BZIP2= yes
-USES= cmake:outsource
+USES= cmake:outsource pkgconfig
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DIHAVEPATCHEDQT:BOOL=TRUE # To be removed with Qt 4.8.2.
MAKE_JOBS_SAFE= yes
diff --git a/editors/deforaos-editor/Makefile b/editors/deforaos-editor/Makefile
index 8f8f666e5dbe..b94cdce72e9b 100644
--- a/editors/deforaos-editor/Makefile
+++ b/editors/deforaos-editor/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
Desktop:${PORTSDIR}/x11/deforaos-libdesktop
MAKE_ARGS= PREFIX=${PREFIX}
+USES= pkgconfig
USE_GNOME= gtk20 desktopfileutils
-USE_PKGCONFIG= build
USE_GETTEXT= yes
.include <bsd.port.mk>
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
index 20fc08d4d413..6caf5ba831a9 100644
--- a/editors/fxite/Makefile
+++ b/editors/fxite/Makefile
@@ -21,8 +21,8 @@ GH_ACCOUNT= yetanothergeek
GH_TAGNAME= FXITE-0_91
GH_COMMIT= c2ecac3
+USES= pkgconfig
USE_LUA= yes
-USE_PKGCONFIG= build
USE_AUTOTOOLS= aclocal autoconf automake
ACLOCAL_ARGS= --force -I m4
AUTOMAKE_ARGS= --gnu --add-missing --copy
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 0022ef7bc3fa..34fcc540edde 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -66,12 +66,11 @@ USE_GL= gl glu
USE_GMAKE= yes
USE_OPENLDAP= yes
USE_PERL5_BUILD= yes
-USE_PKGCONFIG= build
USE_PYTHON= yes
USE_QT4= # empty but required
USE_XORG= xaw xrandr
USE_XZ= yes
-USES= bison
+USES= bison pkgconfig
WANT_GNOME= yes
DISTFILES+= ${PORTNAME}-${LOVERSION}${EXTRACT_SUFX}
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index ea2ce281714a..7d70385e075f 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= hunspell:${PORTSDIR}/textproc/hunspell
LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_QT4= qmake_build gui corelib rcc_build moc_build uic_build \
dbus xml scripttools designer_build
QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} \