aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-03-14 13:27:18 +0800
committermezz <mezz@FreeBSD.org>2012-03-14 13:27:18 +0800
commite239e9c59909bde802e6d78def29e093145aa10a (patch)
tree5c927df616a2eff514548d1f70ce3f9e7c52fbe0 /editors
parentcefd08a2d78c0eef52c7684437631b25f2b3a5d6 (diff)
downloadfreebsd-ports-gnome-e239e9c59909bde802e6d78def29e093145aa10a.tar.gz
freebsd-ports-gnome-e239e9c59909bde802e6d78def29e093145aa10a.tar.zst
freebsd-ports-gnome-e239e9c59909bde802e6d78def29e093145aa10a.zip
Fix the build with GCC 4.6.
PR: ports/161784 Submitted by: Christian Mangin <cmangin@arobas.net> Feature safe: yes
Diffstat (limited to 'editors')
-rw-r--r--editors/abiword/files/patch-src_Makefile.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/editors/abiword/files/patch-src_Makefile.in b/editors/abiword/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..863e989dbddb
--- /dev/null
+++ b/editors/abiword/files/patch-src_Makefile.in
@@ -0,0 +1,29 @@
+--- src/Makefile.in.orig 2011-10-18 13:46:19.263699367 -0400
++++ src/Makefile.in 2011-10-18 13:48:41.402205325 -0400
+@@ -500,7 +500,7 @@
+ $(WP_CPPFLAGS) \
+ -DABIWORD_DATADIR="\"$(ABIWORD_DATADIR)\""
+
+-libabiword_2_8_la_LDFLAGS = $(DEPS_LIBS) --no-undefined -avoid-version \
++libabiword_2_8_la_LDFLAGS = $(DEPS_LIBS) -Wl,--no-undefined -avoid-version \
+ -export-dynamic $(am__append_6)
+ libabiword_2_8_la_LIBADD = $(opt_libs) plugins/libplugins.la \
+ text/fmt/xp/libxp.la text/ptbl/xp/libxp.la \
+@@ -535,7 +535,7 @@
+
+ @TOOLKIT_COCOA_TRUE@AbiWord_LDFLAGS = \
+ @TOOLKIT_COCOA_TRUE@ $(DEPS_LIBS) \
+-@TOOLKIT_COCOA_TRUE@ --no-undefined \
++@TOOLKIT_COCOA_TRUE@ -Wl,--no-undefined \
+ @TOOLKIT_COCOA_TRUE@ -avoid-version \
+ @TOOLKIT_COCOA_TRUE@ -export-dynamic \
+ @TOOLKIT_COCOA_TRUE@ -headerpad_max_install_names
+@@ -551,7 +551,7 @@
+
+ @TOOLKIT_COCOA_FALSE@abiword_LDFLAGS = \
+ @TOOLKIT_COCOA_FALSE@ $(platform_ldflags) \
+-@TOOLKIT_COCOA_FALSE@ --no-undefined \
++@TOOLKIT_COCOA_FALSE@ -Wl,--no-undefined \
+ @TOOLKIT_COCOA_FALSE@ -avoid-version \
+ @TOOLKIT_COCOA_FALSE@ -export-dynamic
+