aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2019-03-20 00:26:25 +0800
committeradamw <adamw@FreeBSD.org>2019-03-20 00:26:25 +0800
commit98b2c2429b2f75efd0a1cf97f354cded687dd2f9 (patch)
treedf27b45840065ab8752e440686a02d5c5560b25a /editors
parenta5fcdaea20f26d584971fba4707e50a1fc722963 (diff)
downloadfreebsd-ports-gnome-98b2c2429b2f75efd0a1cf97f354cded687dd2f9.tar.gz
freebsd-ports-gnome-98b2c2429b2f75efd0a1cf97f354cded687dd2f9.tar.zst
freebsd-ports-gnome-98b2c2429b2f75efd0a1cf97f354cded687dd2f9.zip
Add PYNVIM option
PYNVIM installs the py-pynvim port. This enables support for nvim plugins written in python. It is NOT required for editing or debugging python scripts---that support is already included in neovim.
Diffstat (limited to 'editors')
-rw-r--r--editors/neovim/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 98c8f4a1e523..c71eded1cac7 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -34,10 +34,13 @@ CMAKE_ARGS= -DLUA_PRG:FILEPATH="${LUA_CMD}" \
-DCMAKE_INSTALL_MANDIR:PATH="${MANPREFIX}/man" \
-DDEPS_PREFIX:PATH="${LOCALBASE}"
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= NLS PYNVIM
OPTIONS_SUB= yes
NLS_CMAKE_BOOL= ENABLE_LIBINTL
NLS_USES= gettext
+PYNVIM_DESC= Enable support for plugins written in python
+PYNVIM_USES= python:run
+PYNVIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pynvim>=0.3.0:editors/py-pynvim
post-patch:
@${REINPLACE_CMD} -e \