aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-04-08 19:42:21 +0800
committermaho <maho@FreeBSD.org>2004-04-08 19:42:21 +0800
commitcb771058e8b679a8ab2728536f638cd9ab109839 (patch)
tree3e75045e3825c0ffc7c2772b847bbb65b161ede3 /editors
parent1bf73d77f0c7cc13450d256a03fdc4a96e564d44 (diff)
downloadfreebsd-ports-gnome-cb771058e8b679a8ab2728536f638cd9ab109839.tar.gz
freebsd-ports-gnome-cb771058e8b679a8ab2728536f638cd9ab109839.tar.zst
freebsd-ports-gnome-cb771058e8b679a8ab2728536f638cd9ab109839.zip
Make solver section.
Suggested by: Takamichi Akiyama <tora@openoffice.org>
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.1/Makefile7
-rw-r--r--editors/openoffice.org-1.1/Makefile7
2 files changed, 12 insertions, 2 deletions
diff --git a/editors/openoffice-1.1/Makefile b/editors/openoffice-1.1/Makefile
index 4114126a5bb6..30ffebfcf9d8 100644
--- a/editors/openoffice-1.1/Makefile
+++ b/editors/openoffice-1.1/Makefile
@@ -305,7 +305,7 @@ pre-fetch:
@${ECHO}
@${FALSE}
.endif
- @${ECHO} "If you want SDK, please type make sdk"
+ @${ECHO} "If you want SDK and/or solver, please type make sdk and/or make solver"
post-extract:
@for file in ${EXTRACT_REST}; do \
@@ -559,6 +559,11 @@ sdk:
.endif
${MV} ${WRKSRC}/../solver/${BUILD_NR}/unxfbsd.pro/bin/OpenOffice.org${FRELEASE_NR}_SDK.tar.gz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_sdk.tar.gz
+
+solver:
+ @${ECHO_MSG} "===> Make Solver of OpenOffice.org"
+ @cd ${WRKSRC}/.. ; ${TAR} cfz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_solver.tar.gz solver
+
update:
@${MAKE} fetch
@${MAKE} extract
diff --git a/editors/openoffice.org-1.1/Makefile b/editors/openoffice.org-1.1/Makefile
index 4114126a5bb6..30ffebfcf9d8 100644
--- a/editors/openoffice.org-1.1/Makefile
+++ b/editors/openoffice.org-1.1/Makefile
@@ -305,7 +305,7 @@ pre-fetch:
@${ECHO}
@${FALSE}
.endif
- @${ECHO} "If you want SDK, please type make sdk"
+ @${ECHO} "If you want SDK and/or solver, please type make sdk and/or make solver"
post-extract:
@for file in ${EXTRACT_REST}; do \
@@ -559,6 +559,11 @@ sdk:
.endif
${MV} ${WRKSRC}/../solver/${BUILD_NR}/unxfbsd.pro/bin/OpenOffice.org${FRELEASE_NR}_SDK.tar.gz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_sdk.tar.gz
+
+solver:
+ @${ECHO_MSG} "===> Make Solver of OpenOffice.org"
+ @cd ${WRKSRC}/.. ; ${TAR} cfz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_solver.tar.gz solver
+
update:
@${MAKE} fetch
@${MAKE} extract