aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-04 20:48:08 +0800
committermaho <maho@FreeBSD.org>2007-01-04 20:48:08 +0800
commit68451bfd4e1b4bf64379f86e960156a2d0d5d3cd (patch)
treed41b733b98efbf8dc2cea80ec549ca945e3a9d22 /editors
parent20156da808a31a006bb0fcfd8df2af6c9f81a275 (diff)
downloadfreebsd-ports-gnome-68451bfd4e1b4bf64379f86e960156a2d0d5d3cd.tar.gz
freebsd-ports-gnome-68451bfd4e1b4bf64379f86e960156a2d0d5d3cd.tar.zst
freebsd-ports-gnome-68451bfd4e1b4bf64379f86e960156a2d0d5d3cd.zip
Use ${DESKTOPDIR} instead of using ${PREFIX}/share/applications.
It is already defined in ports/Mk/bsd.port.mk. Submitted by: jkim
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile6
-rw-r--r--editors/openoffice-3/Makefile6
-rw-r--r--editors/openoffice-3/files/Makefile.localized3
-rw-r--r--editors/openoffice.org-2-RC/Makefile6
-rw-r--r--editors/openoffice.org-2-devel/Makefile6
-rw-r--r--editors/openoffice.org-2/Makefile6
-rw-r--r--editors/openoffice.org-2/files/Makefile.localized3
-rw-r--r--editors/openoffice.org-3-RC/Makefile6
-rw-r--r--editors/openoffice.org-3-devel/Makefile6
-rw-r--r--editors/openoffice.org-3/Makefile6
-rw-r--r--editors/openoffice.org-3/files/Makefile.localized3
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile6
12 files changed, 36 insertions, 27 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 7a4fdd77b163..6ecbdd5743c1 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -263,10 +263,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 7a65ebcbc729..91c3f47bd9db 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -263,10 +263,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice-3/files/Makefile.localized b/editors/openoffice-3/files/Makefile.localized
index 410647cd4dff..584a01df7b8b 100644
--- a/editors/openoffice-3/files/Makefile.localized
+++ b/editors/openoffice-3/files/Makefile.localized
@@ -341,4 +341,7 @@ BUILD_DEPENDS+= ${PREFIX}/share/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "all"
+ALL_LOCALIZED_LANGS=yes
+.endif
.endif
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 082bd04e0924..7d287326b467 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -265,10 +265,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 7a4fdd77b163..6ecbdd5743c1 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -263,10 +263,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 7a65ebcbc729..91c3f47bd9db 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -263,10 +263,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice.org-2/files/Makefile.localized b/editors/openoffice.org-2/files/Makefile.localized
index 410647cd4dff..584a01df7b8b 100644
--- a/editors/openoffice.org-2/files/Makefile.localized
+++ b/editors/openoffice.org-2/files/Makefile.localized
@@ -341,4 +341,7 @@ BUILD_DEPENDS+= ${PREFIX}/share/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "all"
+ALL_LOCALIZED_LANGS=yes
+.endif
.endif
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 082bd04e0924..7d287326b467 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -265,10 +265,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 7a4fdd77b163..6ecbdd5743c1 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -263,10 +263,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 7a65ebcbc729..91c3f47bd9db 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -263,10 +263,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
diff --git a/editors/openoffice.org-3/files/Makefile.localized b/editors/openoffice.org-3/files/Makefile.localized
index 410647cd4dff..584a01df7b8b 100644
--- a/editors/openoffice.org-3/files/Makefile.localized
+++ b/editors/openoffice.org-3/files/Makefile.localized
@@ -341,4 +341,7 @@ BUILD_DEPENDS+= ${PREFIX}/share/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/
LANG_PKGNAME= ${LOCALIZED_LANG}
.endif
################################################################
+.if ${LOCALIZED_LANG} == "all"
+ALL_LOCALIZED_LANGS=yes
+.endif
.endif
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 7a4fdd77b163..6ecbdd5743c1 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -263,10 +263,10 @@ post-install:
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/$${app}.desktop ; \
done
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
- @${RM} -f ${PREFIX}/share/applications/${EXECBASE}
- @${MKDIR} ${PREFIX}/share/applications
+ @${RM} -f ${DESKTOPDIR}/${EXECBASE}
+ @${MKDIR} ${DESKTOPDIR}
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applications/${EXECBASE}
+ ${DESKTOPDIR}/${EXECBASE}
@${ECHO_CMD} "share/applications/${EXECBASE}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \