aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2017-09-29 06:53:04 +0800
committeradamw <adamw@FreeBSD.org>2017-09-29 06:53:04 +0800
commitddf85f27ac40709c7f4f32bc4ede421ee784e563 (patch)
tree8ba9c470c446e04f28fd27c4bd6f2bb35e58ced5 /editors
parenta388250c594e6035da2e791ce4ed054643b263bf (diff)
downloadfreebsd-ports-gnome-ddf85f27ac40709c7f4f32bc4ede421ee784e563.tar.gz
freebsd-ports-gnome-ddf85f27ac40709c7f4f32bc4ede421ee784e563.tar.zst
freebsd-ports-gnome-ddf85f27ac40709c7f4f32bc4ede421ee784e563.zip
Reorganize patching and targets
There are so many targets here that it's really hard to follow. Move the OPTIONS-related stuff away from the basic targets, and separate out a couple patches into more sensible targets so that it's clearer what things are doing.
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile40
1 files changed, 21 insertions, 19 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 94b6512c8510..c74805bcde3e 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -157,34 +157,19 @@ post-extract:
${INSTALL_DATA} ${FILESDIR}/vietnamese_viscii.vim ${WRKSRC}/runtime/keymap
post-patch:
- @${FIND} ${WRKSRC}/ -name 'Makefile' | ${XARGS} ${REINPLACE_CMD} -e 's| $$<| $$>|'
- @${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|g' ${WRKSRC}/src/auto/configure
@${ECHO_CMD} '#define SYS_VIMRC_FILE "'${ETCDIR}'/vimrc"' >> ${WRKSRC}/src/feature.h
@${ECHO_CMD} '#define SYS_GVIMRC_FILE "'${ETCDIR}'/gvimrc"' >> ${WRKSRC}/src/feature.h
-.if empty(PORT_OPTIONS:MPYTHON)
- @${REINPLACE_CMD} -e 1d ${WRKSRC}/runtime/tools/demoserver.py
-.endif
-
-post-patch-EXUBERANT_CTAGS-off:
- @${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|ctags -R \.|${FIND} . -type f \\\| ${XARGS} ctags|g'
-
-post-patch-EXUBERANT_CTAGS-on:
- @${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|ctags -R \.|exctags -R .|g'
+ @${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|g; s|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/src/auto/configure
pre-configure:
@${CP} ${WRKSRC}/src/config.mk.dist ${WRKSRC}/src/auto/config.mk
@${DO_MAKE_BUILD} -C ${WRKSRC}/src distclean
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
- -e 's|\$$gtk_config_prefix/bin/gtk-config|\$${GTK_CONFIG}|g' \
- -e 's|\$$gtk_config_exec_prefix/bin/gtk-config|\$${GTK_CONFIG}|g' \
- -e 's|set dummy lua;|set dummy ${LUA_CMD};|g' ${WRKSRC}/src/auto/configure
-
-pre-configure-XTERM_SAVE-on:
- @${REINPLACE_CMD} -e '/FEAT_XTERM_SAVE/ s|.*|#define FEAT_XTERM_SAVE|' ${WRKSRC}/src/feature.h
post-configure:
@${DO_MAKE_BUILD} -C ${WRKSRC}/src scratch config
- @${REINPLACE_CMD} -e 's|#define HAVE_SYSINFO 1|/* #undef HAVE_SYSINFO */|' ${WRKSRC}/src/auto/config.h
+# Needed when devel/libsysinfo is installed:
+ @${REINPLACE_CMD} -e '/#define HAVE_SYSINFO 1/ d' ${WRKSRC}/src/auto/config.h
post-install:
@${RM} ${STAGEDIR}${PREFIX}/bin/ex
@@ -193,6 +178,23 @@ post-install:
${LN} -sf vim ${STAGEDIR}${PREFIX}/bin/$F
.endfor
+# OPTIONS
+post-patch-EXUBERANT_CTAGS-off:
+ @${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's!ctags -R \.!${FIND} . -type f \\| ${XARGS} ctags!g'
+
+post-patch-EXUBERANT_CTAGS-on:
+ @${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|ctags -R \.|exctags -R .|g'
+
+post-patch-LUA-on:
+ @${REINPLACE_CMD} -e 's|set dummy lua;|set dummy ${LUA_CMD};|g' ${WRKSRC}/src/auto/configure
+
+post-patch-PYTHON-off:
+# Work around qa-check shebang error
+ @${REINPLACE_CMD} -e 1d ${WRKSRC}/runtime/tools/demoserver.py
+
+post-patch-XTERM_SAVE-on:
+ @${REINPLACE_CMD} -e '/FEAT_XTERM_SAVE/ s|.*|#define FEAT_XTERM_SAVE|' ${WRKSRC}/src/feature.h
+
post-install-DEFAULT_VIMRC-on:
@${MKDIR} ${STAGEDIR}${ETCDIR}
${SED} -e '/set nocompatible/d' ${FILESDIR}/vimrc > ${STAGEDIR}${ETCDIR}/gvimrc.sample