aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/aqemu
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-03-19 22:26:04 +0800
committerrakuco <rakuco@FreeBSD.org>2016-03-19 22:26:04 +0800
commit530b03fe287a1e15cad46b14964fff2713c29b9e (patch)
treed2f004402efeb5ce4791fd3f310ad64e3fc15e86 /emulators/aqemu
parent9cad028dfff9762a22b867d04761fbd6ccdac7c9 (diff)
downloadfreebsd-ports-gnome-530b03fe287a1e15cad46b14964fff2713c29b9e.tar.gz
freebsd-ports-gnome-530b03fe287a1e15cad46b14964fff2713c29b9e.tar.zst
freebsd-ports-gnome-530b03fe287a1e15cad46b14964fff2713c29b9e.zip
Add patch to stop building the libvncclient target.
The libvncclient target was removed because it was not used anywhere (aqemu links against the systems libvncclient.so, only the definitions and includes are needed from this block) and did not declare its dependency on the moc and ui files, possibly causing problems in parallel builds (way more often with CMake 3.5.0). PR: 208033
Diffstat (limited to 'emulators/aqemu')
-rw-r--r--emulators/aqemu/files/patch-CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/emulators/aqemu/files/patch-CMakeLists.txt b/emulators/aqemu/files/patch-CMakeLists.txt
index dca00ea263f6..5ac7206c8a52 100644
--- a/emulators/aqemu/files/patch-CMakeLists.txt
+++ b/emulators/aqemu/files/patch-CMakeLists.txt
@@ -1,6 +1,18 @@
---- ./CMakeLists.txt.orig 2010-12-21 19:45:24.000000000 +0300
-+++ ./CMakeLists.txt 2011-04-17 13:03:32.608958928 +0400
-@@ -318,6 +318,6 @@
+The libvncclient target was removed because it was not used anywhere (aqemu
+links against the systems libvncclient.so, only the definitions and includes
+are needed from this block) and did not declare its dependency on the moc and
+ui files, possibly causing problems in parallel builds.
+--- CMakeLists.txt.orig 2011-01-14 19:38:53 UTC
++++ CMakeLists.txt
+@@ -164,7 +164,6 @@ IF( NOT WITHOUT_EMBEDDED_DISPLAY )
+ Embedded_Display/vncclientthread.cpp Embedded_Display/vncview.cpp )
+
+ ADD_DEFINITIONS( -DVNC_DISPLAY -DQTONLY )
+- ADD_LIBRARY( libvncclient SHARED ${aqemu_headers} ${aqemu_sources} )
+
+ INCLUDE_DIRECTORIES( ${VNCCLIENT_INCLUDE_DIRS} ${LIBVNCCLIENT_INCLUDE_DIR} )
+ ENDIF( NOT WITHOUT_EMBEDDED_DISPLAY )
+@@ -318,6 +317,6 @@ IF( INSTALL_MAN )
MESSAGE( STATUS "MAN_PAGE_COMPRESSOR flag not set. Available values: gzip, bzip2, lzma" )
MESSAGE( STATUS "Will be installed not compressed MAN pages" )