aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/bsnes
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-10-02 19:14:50 +0800
committermakc <makc@FreeBSD.org>2010-10-02 19:14:50 +0800
commit25caa1ff8e5a88e9f1606b56f91705389aaf7742 (patch)
tree16f8c3d774ad893048e91e05aef377c0d96d5454 /emulators/bsnes
parent3a48f1e2136ac53a25f1a91794f4372f01e9658a (diff)
downloadfreebsd-ports-gnome-25caa1ff8e5a88e9f1606b56f91705389aaf7742.tar.gz
freebsd-ports-gnome-25caa1ff8e5a88e9f1606b56f91705389aaf7742.tar.zst
freebsd-ports-gnome-25caa1ff8e5a88e9f1606b56f91705389aaf7742.zip
Update to 0.70
PR: ports/150979 Submitted by: Emmanuel Vadot (maintainer)
Diffstat (limited to 'emulators/bsnes')
-rw-r--r--emulators/bsnes/Makefile16
-rw-r--r--emulators/bsnes/distinfo6
-rw-r--r--emulators/bsnes/files/patch-Makefile11
-rw-r--r--emulators/bsnes/files/patch-function.hpp15
-rw-r--r--emulators/bsnes/files/patch-qt-Makefile (renamed from emulators/bsnes/files/patch-src-ui_qt-Makefile)4
-rw-r--r--emulators/bsnes/files/patch-snesfilter-Makefile13
-rw-r--r--emulators/bsnes/files/patch-snesreader-Makefile13
-rw-r--r--emulators/bsnes/files/patch-src-Makefile22
-rw-r--r--emulators/bsnes/files/patch-supergameboy-Makefile12
9 files changed, 24 insertions, 88 deletions
diff --git a/emulators/bsnes/Makefile b/emulators/bsnes/Makefile
index be5796edf84e..1fc5ce499334 100644
--- a/emulators/bsnes/Makefile
+++ b/emulators/bsnes/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= bsnes
-PORTVERSION= 0.68
+PORTVERSION= 0.70
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/.//}
@@ -22,7 +22,7 @@ USE_GCC= 4.4+
ONLY_FOR_ARCHS= i386 amd64
WRKSRC= ${WRKDIR}/
-MAKE_ENV+= moc=moc-qt4
+MAKE_ENV+= moc=moc-qt4 c="${CC} -std=gnu99" cpp="${CXX} -std=gnu++0x"
USE_LDCONFIG= yes
OPTIONS= VIDEO_GLX "Build GLX Video Driver" on \
@@ -97,9 +97,9 @@ IGNORE= you have to choose at least an input driver first
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|VIDEO|${VIDEO_DRIVER}|' ${WRKSRC}/bsnes/qt/Makefile
- ${REINPLACE_CMD} -e 's|AUDIO|${AUDIO_DRIVER}|' ${WRKSRC}/bsnes/qt/Makefile
- ${REINPLACE_CMD} -e 's|INPUT|${INPUT_DRIVER}|' ${WRKSRC}/bsnes/qt/Makefile
+ ${REINPLACE_CMD} -e 's|VIDEO|${VIDEO_DRIVER}|' ${WRKSRC}/bsnes/ui-qt/Makefile
+ ${REINPLACE_CMD} -e 's|AUDIO|${AUDIO_DRIVER}|' ${WRKSRC}/bsnes/ui-qt/Makefile
+ ${REINPLACE_CMD} -e 's|INPUT|${INPUT_DRIVER}|' ${WRKSRC}/bsnes/ui-qt/Makefile
do-build:
(cd ${WRKSRC}/bsnes && ${GMAKE} ${MAKE_ENV})
@@ -108,11 +108,11 @@ do-build:
(cd ${WRKSRC}/supergameboy && ${GMAKE} ${MAKE_ENV})
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bsnes/out/bsnes-compatibility ${PREFIX}/bin/bsnes
+ ${INSTALL_PROGRAM} ${WRKSRC}/bsnes/out/bsnes ${PREFIX}/bin/
${MKDIR} ${PREFIX}/share/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/bsnes/qt/data/bsnes.png ${PREFIX}/share/pixmaps/bsnes.png
+ ${INSTALL_DATA} ${WRKSRC}/bsnes/ui-qt/data/bsnes.png ${PREFIX}/share/pixmaps/
${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/bsnes/qt//data/bsnes.desktop ${PREFIX}/share/applications/bsnes.desktop
+ ${INSTALL_DATA} ${WRKSRC}/bsnes/ui-qt/data/bsnes.desktop ${PREFIX}/share/applications/
${INSTALL_DATA} ${WRKSRC}/snesreader/libsnesreader.so ${PREFIX}/lib/
${INSTALL_DATA} ${WRKSRC}/snesfilter/libsnesfilter.so ${PREFIX}/lib/
${INSTALL_DATA} ${WRKSRC}/supergameboy/libsupergameboy.so ${PREFIX}/lib/
diff --git a/emulators/bsnes/distinfo b/emulators/bsnes/distinfo
index f87d44b388c5..f1b94fc53165 100644
--- a/emulators/bsnes/distinfo
+++ b/emulators/bsnes/distinfo
@@ -1,3 +1,3 @@
-MD5 (bsnes_v068.tar.bz2) = 9ff2f6dc64f54f0da538cefade64b3a7
-SHA256 (bsnes_v068.tar.bz2) = a92cd604674e3beed9a1a3153e9fdf9cbbdc29aff62482e4d2a29c47bd8cffe2
-SIZE (bsnes_v068.tar.bz2) = 945351
+MD5 (bsnes_v070.tar.bz2) = d7977e140abc9f07fe55c3ae420bc281
+SHA256 (bsnes_v070.tar.bz2) = 843fe06200488863510dd4c2923eaef6744977f8d1926cdb0806bb6d470c4b79
+SIZE (bsnes_v070.tar.bz2) = 1020720
diff --git a/emulators/bsnes/files/patch-Makefile b/emulators/bsnes/files/patch-Makefile
new file mode 100644
index 000000000000..cecf6efe221a
--- /dev/null
+++ b/emulators/bsnes/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- bsnes/Makefile.orig 2010-09-27 03:24:08.000000000 +0200
++++ bsnes/Makefile 2010-09-27 03:24:26.000000000 +0200
+@@ -19,7 +19,7 @@
+
+ # platform
+ ifeq ($(platform),x)
+- link += -s -ldl -lX11 -lXext
++ link += -s -lX11 -lXext
+ else ifeq ($(platform),osx)
+ else ifeq ($(platform),win)
+ link += -mwindows
diff --git a/emulators/bsnes/files/patch-function.hpp b/emulators/bsnes/files/patch-function.hpp
deleted file mode 100644
index 9bdff9b7c5aa..000000000000
--- a/emulators/bsnes/files/patch-function.hpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- bsnes/nall/function.hpp.orig 2010-09-02 13:10:15.000000000 +0200
-+++ bsnes/nall/function.hpp 2010-09-02 13:10:34.000000000 +0200
-@@ -1,7 +1,11 @@
- #ifndef NALL_FUNCTION_HPP
- #define NALL_FUNCTION_HPP
-
--#include <malloc.h>
-+#ifdef __FreeBSD__
-+# include <stdlib.h>
-+#else
-+# include <malloc.h>
-+#endif
- #include <functional>
- #include <type_traits>
-
diff --git a/emulators/bsnes/files/patch-src-ui_qt-Makefile b/emulators/bsnes/files/patch-qt-Makefile
index 2b4e08f83493..c829b3da5758 100644
--- a/emulators/bsnes/files/patch-src-ui_qt-Makefile
+++ b/emulators/bsnes/files/patch-qt-Makefile
@@ -1,5 +1,5 @@
---- bsnes/qt/Makefile.orig 2010-09-02 13:05:33.000000000 +0200
-+++ bsnes/qt/Makefile 2010-09-02 13:05:50.000000000 +0200
+--- bsnes/ui-qt/Makefile.orig 2010-09-27 03:25:04.000000000 +0200
++++ bsnes/ui-qt/Makefile 2010-09-27 03:25:16.000000000 +0200
@@ -13,9 +13,9 @@
# platform
diff --git a/emulators/bsnes/files/patch-snesfilter-Makefile b/emulators/bsnes/files/patch-snesfilter-Makefile
deleted file mode 100644
index 118507fcb677..000000000000
--- a/emulators/bsnes/files/patch-snesfilter-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- snesfilter/Makefile.orig 2010-09-02 13:28:07.000000000 +0200
-+++ snesfilter/Makefile 2010-09-02 13:28:17.000000000 +0200
-@@ -3,8 +3,8 @@
- qtlibs := QtCore QtGui
- include nall/qt/Makefile
-
--c := $(compiler) -std=gnu99
--cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
-+c := $(CC) -std=gnu99
-+cpp := $(CXX) -std=gnu++0x
- flags := -O3 -I. -Iobj -fomit-frame-pointer $(qtinc)
- link :=
-
diff --git a/emulators/bsnes/files/patch-snesreader-Makefile b/emulators/bsnes/files/patch-snesreader-Makefile
deleted file mode 100644
index b0ddbe812bdc..000000000000
--- a/emulators/bsnes/files/patch-snesreader-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- snesreader/Makefile.orig 2010-09-02 13:26:29.000000000 +0200
-+++ snesreader/Makefile 2010-09-02 13:26:42.000000000 +0200
-@@ -3,8 +3,8 @@
- qtlibs := QtCore QtGui
- include nall/qt/Makefile
-
--c := $(compiler) -std=gnu99
--cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
-+c := $(CC) -std=gnu99
-+cpp := $(CXX) -std=gnu++0x
- flags := -O3 -I. -Iobj -fomit-frame-pointer
- link :=
-
diff --git a/emulators/bsnes/files/patch-src-Makefile b/emulators/bsnes/files/patch-src-Makefile
deleted file mode 100644
index 8eefb4bbe58f..000000000000
--- a/emulators/bsnes/files/patch-src-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- bsnes/Makefile.orig 2010-09-02 13:02:47.000000000 +0200
-+++ bsnes/Makefile 2010-09-02 13:04:10.000000000 +0200
-@@ -4,8 +4,8 @@
- ui := qt
-
- # compiler
--c := $(compiler) -std=gnu99
--cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
-+c := $(CC)
-+cpp := $(CXX) -std=gnu++0x
- flags := -O3 -fomit-frame-pointer -I. -I$(snes)
- link :=
- objects :=
-@@ -19,7 +19,7 @@
-
- # platform
- ifeq ($(platform),x)
-- link += -s -ldl -lX11 -lXext
-+ link += -s -lX11 -lXext
- else ifeq ($(platform),osx)
- else ifeq ($(platform),win)
- link += -mwindows
diff --git a/emulators/bsnes/files/patch-supergameboy-Makefile b/emulators/bsnes/files/patch-supergameboy-Makefile
deleted file mode 100644
index e1ea9342d0d3..000000000000
--- a/emulators/bsnes/files/patch-supergameboy-Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- supergameboy/Makefile.orig 2010-09-02 13:28:45.000000000 +0200
-+++ supergameboy/Makefile 2010-09-02 13:28:55.000000000 +0200
-@@ -1,7 +1,7 @@
- include nall/Makefile
-
--c := $(compiler) -std=gnu99
--cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
-+c := $(CC) -std=gnu99
-+cpp := $(CXX) -std=gnu++0x
- flags := -O3 -fomit-frame-pointer -I. -Icommon -Ilibgambatte/include -Ilibgambatte/src
- link :=
-