aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/bsvc
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-12-12 01:13:00 +0800
committeroliver <oliver@FreeBSD.org>2003-12-12 01:13:00 +0800
commitbd982ca9ff18f4bdc80e9d249b17ffd6e4927ecb (patch)
tree587cc17ee7380251c8af809743762567e9f40bdc /emulators/bsvc
parent87a5d6741008d668300c91e5d6064ea7bfd30f94 (diff)
downloadfreebsd-ports-gnome-bd982ca9ff18f4bdc80e9d249b17ffd6e4927ecb.tar.gz
freebsd-ports-gnome-bd982ca9ff18f4bdc80e9d249b17ffd6e4927ecb.tar.zst
freebsd-ports-gnome-bd982ca9ff18f4bdc80e9d249b17ffd6e4927ecb.zip
fix build on 5
Diffstat (limited to 'emulators/bsvc')
-rw-r--r--emulators/bsvc/Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/emulators/bsvc/Makefile b/emulators/bsvc/Makefile
index 6dd30412cd24..e58a76752a4e 100644
--- a/emulators/bsvc/Makefile
+++ b/emulators/bsvc/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= emulators tk82
MASTER_SITES= ftp://ftp.redlinelabs.com/pub/bsvc/ \
${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= system/emulators
-DISTFILES= ${DISTNAME}-src.tar.gz
+DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= An extensible hardware simulation framework with MC68K support
@@ -26,16 +26,23 @@ MAKE_ENV= PROJECT_BASE=${PREFIX} WRKSRC=${WRKSRC}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
pre-patch:
- ${CP} ${WRKSRC}/Makefile.Linux ${WRKSRC}/Makefile
+ @${CP} ${WRKSRC}/Makefile.Linux ${WRKSRC}/Makefile
+
post-patch:
- ${FIND} ${WRKSRC} -name "*.[ch]xx" -exec \
- ${REINPLACE_CMD} -e 's/iostream\.h/iostream/; s/fstream\.h/fstream/' \{\} \;
- ${FIND} ${WRKSRC} -name Makefile -exec \
- ${REINPLACE_CMD} -e 's/make/$(MAKE)/' \{\} \;
+
+.for cfile in codegen.c listing.c object.c main.c
+ @${REINPLACE_CMD} -e 's|exit()|exit(1)|g' ${WRKSRC}/Assemblers/68kasm/${cfile}
+.endfor
+ @${REINPLACE_CMD} -e 's|^#endif.*$$|#endif|g' \
+ ${WRKSRC}/Assemblers/68kasm/instlookup.c
+
+ @${FIND} ${WRKSRC} -name "*.[ch]xx" -exec \
+ ${REINPLACE_CMD} -e \
+ 's/iostream\.h/iostream/; \
+ s/strstream\.h/strstream/; \
+ s/fstream\.h/fstream/' \{\} \;
+ @${FIND} ${WRKSRC} -name Makefile -exec \
+ ${REINPLACE_CMD} -e 's/make/$(MAKE)/' \{\} \;
.include <bsd.port.post.mk>