aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/dboxfe
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-12-15 21:51:31 +0800
committermakc <makc@FreeBSD.org>2012-12-15 21:51:31 +0800
commit7d86b8592dc07363273464ff565ff14cf08e803c (patch)
tree58d1511c6de9e249ad6fbfaa97c76ccbb7e609d5 /emulators/dboxfe
parent625b852957cfc6b2fa25781174e44f3306a19aa8 (diff)
downloadfreebsd-ports-gnome-7d86b8592dc07363273464ff565ff14cf08e803c.tar.gz
freebsd-ports-gnome-7d86b8592dc07363273464ff565ff14cf08e803c.tar.zst
freebsd-ports-gnome-7d86b8592dc07363273464ff565ff14cf08e803c.zip
- Strip Makefile header
- Install Desktop entries and icon - Pass QMAKEFLAGS to qmake (as a result post-configure fixes are needless now) - Mark MAKE_JOBS_SAFE - Update COMMENT, description, WWW - Reformat description with `fmt -s'
Diffstat (limited to 'emulators/dboxfe')
-rw-r--r--emulators/dboxfe/Makefile37
-rw-r--r--emulators/dboxfe/pkg-descr8
2 files changed, 20 insertions, 25 deletions
diff --git a/emulators/dboxfe/Makefile b/emulators/dboxfe/Makefile
index 6d9abf405ac8..b0b70c4f16bb 100644
--- a/emulators/dboxfe/Makefile
+++ b/emulators/dboxfe/Makefile
@@ -1,44 +1,39 @@
-# New ports collection makefile for: dboxfe
-# Date created: 2007-12-08
-# Whom: Max Brazhnikov <makc@issp.ac.ru>
-#
# $FreeBSD$
-#
PORTNAME= dboxfe
PORTVERSION= 0.1.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR=${PORTNAME}
MAINTAINER= makc@FreeBSD.org
-COMMENT= A Qt4 front-end to DOSBox
+COMMENT= Qt4 based configuration manager for DOSBox
RUN_DEPENDS= dosbox:${PORTSDIR}/emulators/dosbox
USE_BZIP2= yes
USE_QT4= gui network xml uic_build moc_build qmake_build rcc_build
HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/dboxfe bin/dboxfetray
+PLIST_FILES= bin/dboxfe \
+ bin/dboxfetray \
+ share/pixmaps/dboxfe.png
-.include <bsd.port.pre.mk>
+DESKTOP_ENTRIES= "DBoxFE" "DOSBox configuration manager" \
+ "${PREFIX}/share/pixmaps/dboxfe.png" \
+ "dboxfe" "Utility;Qt;" false \
+ "DBoxFEtray" "DBoxFE systray icon" \
+ "${PREFIX}/share/pixmaps/dboxfe.png" \
+ "dboxfetray" "Utility;Qt;TrayIcon;" false
PRO_DIRS= . dboxfetray
do-configure:
.for dir in ${PRO_DIRS}
- @(cd ${WRKSRC}/${dir} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE})
-.endfor
-
-post-configure:
-.for dir in ${PRO_DIRS}
- @${REINPLACE_CMD} -e \
- 's|^CC .*|CC=${CC}|; \
- s|^CXX .*|CXX=${CXX}|; \
- s|^LINK .*|LINK=${CXX}|' \
- ${WRKSRC}/${dir}/Makefile
+ @(cd ${WRKSRC}/${dir} && \
+ ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS})
.endfor
do-build:
@@ -49,5 +44,7 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/dboxfe ${PREFIX}/bin/dboxfe
${INSTALL_PROGRAM} ${WRKSRC}/bin/dboxfetray ${PREFIX}/bin/dboxfetray
+ ${INSTALL_DATA} ${WRKSRC}/dboxfetray/res/dboxfetray.png \
+ ${PREFIX}/share/pixmaps/dboxfe.png
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/dboxfe/pkg-descr b/emulators/dboxfe/pkg-descr
index 514892f82044..56714e0aef22 100644
--- a/emulators/dboxfe/pkg-descr
+++ b/emulators/dboxfe/pkg-descr
@@ -1,6 +1,4 @@
-DBoxFE is a Qt4 frontend for DOSBox. With DBoxFE you can create and
-manage your configuration files very easily, which are needed by
-DOSBox. In addition it's also possible to create gameprofiles to
-generate different configuration files
+DBoxFE is a Qt4 frontend for DOSBox. With DBoxFE you can easily
+create and manage configuration profiles for DOSBox.
-WWW: http://chmaster.freeforge.net/dboxfe-project.htm
+WWW: http://chm-projects.de/?q=dboxfe