aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/dolphin-emu-devel
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-04-19 21:35:15 +0800
committermartymac <martymac@FreeBSD.org>2013-04-19 21:35:15 +0800
commit045278c15889ed6dfc31ca77bff187725a07eba3 (patch)
tree2d4c974ce4f53acce86d7d4e4fd9091f4816e72e /emulators/dolphin-emu-devel
parent29ffe4a762e7363abb94c1092e9598588a735ada (diff)
downloadfreebsd-ports-gnome-045278c15889ed6dfc31ca77bff187725a07eba3.tar.gz
freebsd-ports-gnome-045278c15889ed6dfc31ca77bff187725a07eba3.tar.zst
freebsd-ports-gnome-045278c15889ed6dfc31ca77bff187725a07eba3.zip
- Update to 20130415 and welcome GLSL !
- Remove BROKEN flag for now-obsolete 7.x branch We should finally be able to get OpenGL rendering work with this update, once Mesa supports all needed extensions (which does not seem to be the case yet) Feature safe: yes
Diffstat (limited to 'emulators/dolphin-emu-devel')
-rw-r--r--emulators/dolphin-emu-devel/Makefile14
-rw-r--r--emulators/dolphin-emu-devel/distinfo4
-rw-r--r--emulators/dolphin-emu-devel/files/patch-CMakeLists.txt308
-rw-r--r--emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-StringUtil.cpp11
-rw-r--r--emulators/dolphin-emu-devel/pkg-plist12
5 files changed, 184 insertions, 165 deletions
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index 9348b31ca869..bd83d5d08d41 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
lzo2:${PORTSDIR}/archivers/lzo2 \
sfml-network:${PORTSDIR}/devel/sfml
-REVDATE= 20130225
+REVDATE= 20130415
USE_ICONV= yes
USE_PKGCONFIG= build
@@ -56,6 +56,10 @@ OPTIONS_DEFAULT= PORTAUDIO FRAMEDUMPS
.include <bsd.port.pre.mk>
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc: uses i386-specific option
+.endif
+
.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -72,14 +76,6 @@ CXXFLAGS+= -g
MAKE_ENV+= VERBOSE=yes
.endif
-# XXX Needs spawn.h header to build
-.if ${OSVERSION} < 800041
-BROKEN= requires FreeBSD 8.0 or newer
-.endif
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc: uses i386-specific option
-.endif
-
.if ${PORT_OPTIONS:MPULSEAUDIO}
LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
.else
diff --git a/emulators/dolphin-emu-devel/distinfo b/emulators/dolphin-emu-devel/distinfo
index e2c725db76a4..1d4a970fc85b 100644
--- a/emulators/dolphin-emu-devel/distinfo
+++ b/emulators/dolphin-emu-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dolphin-emu-3.5.r20130225.tgz) = 1a9ae1d828c8959fb165a2859554ca7fcc3eb8336a11bc5a69274785bec29100
-SIZE (dolphin-emu-3.5.r20130225.tgz) = 26975818
+SHA256 (dolphin-emu-3.5.r20130415.tgz) = 195f5a4793c4e87f81a334da2b301e2a048f7ff1339811d910362ee8c5b8cfb5
+SIZE (dolphin-emu-3.5.r20130415.tgz) = 17819718
diff --git a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
index 73f4660c7764..0f84bfc67fc7 100644
--- a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
@@ -1,166 +1,166 @@
---- CMakeLists.txt.orig 2013-02-25 17:12:52.000000000 +0100
-+++ CMakeLists.txt 2013-02-25 17:22:59.000000000 +0100
-@@ -286,51 +286,81 @@
- message("OpenMP parallelization disabled")
- endif()
+--- CMakeLists.txt.orig 2013-03-20 18:05:37.000000000 +0100
++++ CMakeLists.txt 2013-03-20 18:21:02.000000000 +0100
+@@ -302,51 +302,81 @@
+ message("OpenMP parallelization disabled")
+ endif()
--include(FindALSA OPTIONAL)
--if(ALSA_FOUND)
-- add_definitions(-DHAVE_ALSA=1)
-- message("ALSA found, enabling ALSA sound backend")
-+option(DISABLE_ALSA "Disable ALSA sound backend" OFF)
-+if(NOT DISABLE_ALSA)
-+ include(FindALSA OPTIONAL)
-+ if(ALSA_FOUND)
-+ add_definitions(-DHAVE_ALSA=1)
-+ message("ALSA found, enabling ALSA sound backend")
-+ else()
-+ add_definitions(-DHAVE_ALSA=0)
-+ message("ALSA NOT found, disabling ALSA sound backend")
-+ endif(ALSA_FOUND)
- else()
- add_definitions(-DHAVE_ALSA=0)
-- message("ALSA NOT found, disabling ALSA sound backend")
--endif(ALSA_FOUND)
-+ message("ALSA sound backend disabled")
-+endif()
+- include(FindALSA OPTIONAL)
+- if(ALSA_FOUND)
+- add_definitions(-DHAVE_ALSA=1)
+- message("ALSA found, enabling ALSA sound backend")
++ option(DISABLE_ALSA "Disable ALSA sound backend" OFF)
++ if(NOT DISABLE_ALSA)
++ include(FindALSA OPTIONAL)
++ if(ALSA_FOUND)
++ add_definitions(-DHAVE_ALSA=1)
++ message("ALSA found, enabling ALSA sound backend")
++ else()
++ add_definitions(-DHAVE_ALSA=0)
++ message("ALSA NOT found, disabling ALSA sound backend")
++ endif(ALSA_FOUND)
+ else()
+ add_definitions(-DHAVE_ALSA=0)
+- message("ALSA NOT found, disabling ALSA sound backend")
+- endif(ALSA_FOUND)
++ message("ALSA sound backend disabled")
++ endif()
--check_lib(AO ao QUIET)
--if(AO_FOUND)
-- add_definitions(-DHAVE_AO=1)
-- message("ao found, enabling ao sound backend")
-+option(DISABLE_AO "Disable ao sound backend" OFF)
-+if(NOT DISABLE_AO)
-+ check_lib(AO ao QUIET)
-+ if(AO_FOUND)
-+ add_definitions(-DHAVE_AO=1)
-+ message("ao found, enabling ao sound backend")
-+ else()
-+ add_definitions(-DHAVE_AO=0)
-+ message("ao NOT found, disabling ao sound backend")
-+ endif(AO_FOUND)
- else()
- add_definitions(-DHAVE_AO=0)
-- message("ao NOT found, disabling ao sound backend")
--endif(AO_FOUND)
-+ message("ao sound backend disabled")
-+endif()
+- check_lib(AO ao QUIET)
+- if(AO_FOUND)
+- add_definitions(-DHAVE_AO=1)
+- message("ao found, enabling ao sound backend")
++ option(DISABLE_AO "Disable ao sound backend" OFF)
++ if(NOT DISABLE_AO)
++ check_lib(AO ao QUIET)
++ if(AO_FOUND)
++ add_definitions(-DHAVE_AO=1)
++ message("ao found, enabling ao sound backend")
++ else()
++ add_definitions(-DHAVE_AO=0)
++ message("ao NOT found, disabling ao sound backend")
++ endif(AO_FOUND)
+ else()
+ add_definitions(-DHAVE_AO=0)
+- message("ao NOT found, disabling ao sound backend")
+- endif(AO_FOUND)
++ message("ao sound backend disabled")
++ endif()
--check_lib(BLUEZ bluez QUIET)
--if(BLUEZ_FOUND)
-- add_definitions(-DHAVE_BLUEZ=1)
-- message("bluez found, enabling bluetooth support")
-+option(DISABLE_BLUEZ "Disable bluez (bluetooth) support" OFF)
-+if(NOT DISABLE_BLUEZ)
-+ check_lib(BLUEZ bluez QUIET)
-+ if(BLUEZ_FOUND)
-+ add_definitions(-DHAVE_BLUEZ=1)
-+ message("bluez found, enabling bluetooth support")
-+ else()
-+ add_definitions(-DHAVE_BLUEZ=0)
-+ message("bluez NOT found, disabling bluetooth support")
-+ endif(BLUEZ_FOUND)
- else()
- add_definitions(-DHAVE_BLUEZ=0)
-- message("bluez NOT found, disabling bluetooth support")
--endif(BLUEZ_FOUND)
-+ message("bluez (bluetooth) support disabled")
-+endif()
+- check_lib(BLUEZ bluez QUIET)
+- if(BLUEZ_FOUND)
+- add_definitions(-DHAVE_BLUEZ=1)
+- message("bluez found, enabling bluetooth support")
++ option(DISABLE_BLUEZ "Disable bluez (bluetooth) support" OFF)
++ if(NOT DISABLE_BLUEZ)
++ check_lib(BLUEZ bluez QUIET)
++ if(BLUEZ_FOUND)
++ add_definitions(-DHAVE_BLUEZ=1)
++ message("bluez found, enabling bluetooth support")
++ else()
++ add_definitions(-DHAVE_BLUEZ=0)
++ message("bluez NOT found, disabling bluetooth support")
++ endif(BLUEZ_FOUND)
+ else()
+ add_definitions(-DHAVE_BLUEZ=0)
+- message("bluez NOT found, disabling bluetooth support")
+- endif(BLUEZ_FOUND)
++ message("bluez (bluetooth) support disabled")
++ endif()
--check_lib(PULSEAUDIO libpulse-simple QUIET)
--if(PULSEAUDIO_FOUND)
-- add_definitions(-DHAVE_PULSEAUDIO=1)
-- message("PulseAudio found, enabling PulseAudio sound backend")
-+option(DISABLE_PULSEAUDIO "Disable PulseAudio sound backend" OFF)
-+if(NOT DISABLE_PULSEAUDIO)
-+ check_lib(PULSEAUDIO libpulse-simple QUIET)
-+ if(PULSEAUDIO_FOUND)
-+ add_definitions(-DHAVE_PULSEAUDIO=1)
-+ message("PulseAudio found, enabling PulseAudio sound backend")
-+ else()
-+ add_definitions(-DHAVE_PULSEAUDIO=0)
-+ message("PulseAudio NOT found, disabling PulseAudio sound backend")
-+ endif(PULSEAUDIO_FOUND)
- else()
- add_definitions(-DHAVE_PULSEAUDIO=0)
-- message("PulseAudio NOT found, disabling PulseAudio sound backend")
--endif(PULSEAUDIO_FOUND)
-+ message("PulseAudio sound backend disabled")
-+endif()
+- check_lib(PULSEAUDIO libpulse-simple QUIET)
+- if(PULSEAUDIO_FOUND)
+- add_definitions(-DHAVE_PULSEAUDIO=1)
+- message("PulseAudio found, enabling PulseAudio sound backend")
++ option(DISABLE_PULSEAUDIO "Disable PulseAudio sound backend" OFF)
++ if(NOT DISABLE_PULSEAUDIO)
++ check_lib(PULSEAUDIO libpulse-simple QUIET)
++ if(PULSEAUDIO_FOUND)
++ add_definitions(-DHAVE_PULSEAUDIO=1)
++ message("PulseAudio found, enabling PulseAudio sound backend")
++ else()
++ add_definitions(-DHAVE_PULSEAUDIO=0)
++ message("PulseAudio NOT found, disabling PulseAudio sound backend")
++ endif(PULSEAUDIO_FOUND)
+ else()
+ add_definitions(-DHAVE_PULSEAUDIO=0)
+- message("PulseAudio NOT found, disabling PulseAudio sound backend")
+- endif(PULSEAUDIO_FOUND)
++ message("PulseAudio sound backend disabled")
++ endif()
--include(FindOpenAL OPTIONAL)
--if(OPENAL_FOUND)
-- add_definitions(-DHAVE_OPENAL=1)
-- include_directories(${OPENAL_INCLUDE_DIR})
-- message("OpenAL found, enabling OpenAL sound backend")
-+option(DISABLE_OPENAL "Disable OpenAL sound backend" OFF)
-+if(NOT DISABLE_OPENAL)
-+ include(FindOpenAL OPTIONAL)
-+ if(OPENAL_FOUND)
-+ add_definitions(-DHAVE_OPENAL=1)
-+ include_directories(${OPENAL_INCLUDE_DIR})
-+ message("OpenAL found, enabling OpenAL sound backend")
-+ else()
-+ add_definitions(-DHAVE_OPENAL=0)
-+ message("OpenAL NOT found, disabling OpenAL sound backend")
-+ endif(OPENAL_FOUND)
- else()
- add_definitions(-DHAVE_OPENAL=0)
-- message("OpenAL NOT found, disabling OpenAL sound backend")
--endif(OPENAL_FOUND)
-+ message("OpenAL sound backend disabled")
-+endif()
+- include(FindOpenAL OPTIONAL)
+- if(OPENAL_FOUND)
+- add_definitions(-DHAVE_OPENAL=1)
+- include_directories(${OPENAL_INCLUDE_DIR})
+- message("OpenAL found, enabling OpenAL sound backend")
++ option(DISABLE_OPENAL "Disable OpenAL sound backend" OFF)
++ if(NOT DISABLE_OPENAL)
++ include(FindOpenAL OPTIONAL)
++ if(OPENAL_FOUND)
++ add_definitions(-DHAVE_OPENAL=1)
++ include_directories(${OPENAL_INCLUDE_DIR})
++ message("OpenAL found, enabling OpenAL sound backend")
++ else()
++ add_definitions(-DHAVE_OPENAL=0)
++ message("OpenAL NOT found, disabling OpenAL sound backend")
++ endif(OPENAL_FOUND)
+ else()
+ add_definitions(-DHAVE_OPENAL=0)
+- message("OpenAL NOT found, disabling OpenAL sound backend")
+- endif(OPENAL_FOUND)
++ message("OpenAL sound backend disabled")
++ endif()
# Note: We do not need to explicitly check for X11 as it is done in the cmake
# FindOpenGL module on linux.
-@@ -359,22 +389,33 @@
- check_libav()
- endif()
+@@ -375,22 +405,33 @@
+ check_libav()
+ endif()
--include(CheckCXXSourceRuns)
--set(CMAKE_REQUIRED_LIBRARIES portaudio)
--CHECK_CXX_SOURCE_RUNS(
-- "#include <portaudio.h>
-- int main(int argc, char **argv)
-- { if(Pa_GetVersion() >= 1890) return 0; else return 1; }"
-- PORTAUDIO)
--if(PORTAUDIO)
-- message("PortAudio found, enabling mic support")
-- add_definitions(-DHAVE_PORTAUDIO=1)
-- set(PORTAUDIO_FOUND TRUE)
-+option(DISABLE_PORTAUDIO "Disable PortAudio (mic) support" OFF)
-+if(NOT DISABLE_PORTAUDIO)
-+ include(CheckCXXSourceRuns)
-+ include_directories(BEFORE ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
-+ link_directories(${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
-+ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
-+ set(CMAKE_REQUIRED_FLAGS -L${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
-+ set(CMAKE_REQUIRED_LIBRARIES portaudio)
-+ CHECK_CXX_SOURCE_RUNS(
-+ "#include <portaudio.h>
-+ int main(int argc, char **argv)
-+ { if(Pa_GetVersion() >= 1890) return 0; else return 1; }"
-+ PORTAUDIO)
-+ if(PORTAUDIO)
-+ message("PortAudio found, enabling mic support")
-+ add_definitions(-DHAVE_PORTAUDIO=1)
-+ set(PORTAUDIO_FOUND TRUE)
-+ else()
-+ message("PortAudio not found, disabling mic support")
-+ add_definitions(-DHAVE_PORTAUDIO=0)
-+ set(PORTAUDIO_FOUND FALSE)
-+ endif(PORTAUDIO)
- else()
-- message("PortAudio not found, disabling mic support")
-+ message("PortAudio (mic) support disabled")
- add_definitions(-DHAVE_PORTAUDIO=0)
- set(PORTAUDIO_FOUND FALSE)
--endif(PORTAUDIO)
-+endif()
+- include(CheckCXXSourceRuns)
+- set(CMAKE_REQUIRED_LIBRARIES portaudio)
+- CHECK_CXX_SOURCE_RUNS(
+- "#include <portaudio.h>
+- int main(int argc, char **argv)
+- { if(Pa_GetVersion() >= 1890) return 0; else return 1; }"
+- PORTAUDIO)
+- if(PORTAUDIO)
+- message("PortAudio found, enabling mic support")
+- add_definitions(-DHAVE_PORTAUDIO=1)
+- set(PORTAUDIO_FOUND TRUE)
++ option(DISABLE_PORTAUDIO "Disable PortAudio (mic) support" OFF)
++ if(NOT DISABLE_PORTAUDIO)
++ include(CheckCXXSourceRuns)
++ include_directories(BEFORE ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
++ link_directories(${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
++ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
++ set(CMAKE_REQUIRED_FLAGS -L${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
++ set(CMAKE_REQUIRED_LIBRARIES portaudio)
++ CHECK_CXX_SOURCE_RUNS(
++ "#include <portaudio.h>
++ int main(int argc, char **argv)
++ { if(Pa_GetVersion() >= 1890) return 0; else return 1; }"
++ PORTAUDIO)
++ if(PORTAUDIO)
++ message("PortAudio found, enabling mic support")
++ add_definitions(-DHAVE_PORTAUDIO=1)
++ set(PORTAUDIO_FOUND TRUE)
++ else()
++ message("PortAudio not found, disabling mic support")
++ add_definitions(-DHAVE_PORTAUDIO=0)
++ set(PORTAUDIO_FOUND FALSE)
++ endif(PORTAUDIO)
+ else()
+- message("PortAudio not found, disabling mic support")
++ message("PortAudio (mic) support disabled")
+ add_definitions(-DHAVE_PORTAUDIO=0)
+ set(PORTAUDIO_FOUND FALSE)
+- endif(PORTAUDIO)
++ endif()
- if(OPROFILING)
- check_lib(OPROFILE opagent opagent.h)
-@@ -634,10 +675,13 @@
+ if(OPROFILING)
+ check_lib(OPROFILE opagent opagent.h)
+@@ -668,10 +709,13 @@
install(DIRECTORY Data/User/ DESTINATION ${datadir}/user PATTERN)
install(DIRECTORY Data/Sys/ DESTINATION ${datadir}/sys PATTERN)
endif()
@@ -172,7 +172,7 @@
+if(NOT DISABLE_NLS)
+ include(FindGettext)
+ if(GETTEXT_FOUND AND NOT DISABLE_WX)
-+ file(GLOB LINGUAS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} Languages/po/*.po)
++ file(GLOB LINGUAS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} Languages/po/*.po)
+ GETTEXT_CREATE_TRANSLATIONS(Languages/po/dolphin-emu.pot ALL ${LINGUAS})
+ endif()
endif()
diff --git a/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-StringUtil.cpp b/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-StringUtil.cpp
new file mode 100644
index 000000000000..4616b2c2d7bc
--- /dev/null
+++ b/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-StringUtil.cpp
@@ -0,0 +1,11 @@
+--- Source/Core/Common/Src/StringUtil.cpp.orig 2013-03-21 06:49:23.000000000 +0100
++++ Source/Core/Common/Src/StringUtil.cpp 2013-03-21 06:50:08.000000000 +0100
+@@ -460,7 +460,7 @@
+
+ while (src_bytes != 0)
+ {
+- size_t const iconv_result = iconv(conv_desc, (char**)(&src_buffer), &src_bytes,
++ size_t const iconv_result = iconv(conv_desc, (const char**)(&src_buffer), &src_bytes,
+ &dst_buffer, &dst_bytes);
+
+ if ((size_t)-1 == iconv_result)
diff --git a/emulators/dolphin-emu-devel/pkg-plist b/emulators/dolphin-emu-devel/pkg-plist
index 6bc068ef7f00..20eaae478505 100644
--- a/emulators/dolphin-emu-devel/pkg-plist
+++ b/emulators/dolphin-emu-devel/pkg-plist
@@ -25,6 +25,8 @@ bin/dolphin-emu
%%NLS%%share/locale/zh_TW/LC_MESSAGES/dolphin-emu.mo
%%DATADIR%%/sys/codehandler.bin
%%DATADIR%%/sys/totaldb.dsy
+%%DATADIR%%/sys/GC/dsp_coef.bin
+%%DATADIR%%/sys/GC/dsp_rom.bin
%%DATADIR%%/sys/GC/font_sjis.bin
%%DATADIR%%/sys/GC/font_ansi.bin
%%DATADIR%%/sys/Wii/setting-usa.txt
@@ -32,6 +34,7 @@ bin/dolphin-emu
%%DATADIR%%/sys/Wii/setting-eur.txt
%%DATADIR%%/sys/Wii/setting-kor.txt
%%DATADIR%%/user/Shaders/acidtrip2.txt
+%%DATADIR%%/user/Shaders/asciiart.txt
%%DATADIR%%/user/Shaders/sunset.txt
%%DATADIR%%/user/Shaders/chrismas.txt
%%DATADIR%%/user/Shaders/nightvision2.txt
@@ -89,6 +92,9 @@ bin/dolphin-emu
%%DATADIR%%/user/Themes/Boomy/browse.png
%%DATADIR%%/user/Themes/Boomy/pause.png
%%DATADIR%%/user/Themes/Boomy/nobanner.png
+%%DATADIR%%/user/GameConfig/GWLE6L.ini
+%%DATADIR%%/user/GameConfig/GSZP41.ini
+%%DATADIR%%/user/GameConfig/GFZJ01.ini
%%DATADIR%%/user/GameConfig/GF8P69.ini
%%DATADIR%%/user/GameConfig/GC3P78.ini
%%DATADIR%%/user/GameConfig/R8LE20.ini
@@ -1525,6 +1531,12 @@ bin/dolphin-emu
%%DATADIR%%/user/GameConfig/GH4D69.ini
%%DATADIR%%/user/GameConfig/GZPE70.ini
%%DATADIR%%/user/GameConfig/GH4H69.ini
+%%DATADIR%%/user/GameConfig/GWKE41.ini
+%%DATADIR%%/user/GameConfig/GLSF64.ini
+%%DATADIR%%/user/GameConfig/GHYE6S.ini
+%%DATADIR%%/user/GameConfig/GLSD64.ini
+%%DATADIR%%/user/GameConfig/GLSP64.ini
+%%DATADIR%%/user/GameConfig/GM4J01.ini
%%DATADIR%%/user/Wii/shared2/sys/SYSCONF
%%DATADIR%%/user/Wii/shared2/ec/shopsetu.log
%%DATADIR%%/user/Wii/shared2/succession/shop.log