aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/dosbox
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2004-10-28 13:20:12 +0800
committeroliver <oliver@FreeBSD.org>2004-10-28 13:20:12 +0800
commitefa9dc63ade026cd0e8f6fa159288e1ebf010356 (patch)
treefbe5feb2b4bd02c57035c2edf0a3cf5767219132 /emulators/dosbox
parent7961f5174c73a952eb0330cd44ca943f5c271f44 (diff)
downloadfreebsd-ports-gnome-efa9dc63ade026cd0e8f6fa159288e1ebf010356.tar.gz
freebsd-ports-gnome-efa9dc63ade026cd0e8f6fa159288e1ebf010356.tar.zst
freebsd-ports-gnome-efa9dc63ade026cd0e8f6fa159288e1ebf010356.zip
fix build on FreeBSD 4
PR: ports/73002 Approved By: maintainer
Diffstat (limited to 'emulators/dosbox')
-rw-r--r--emulators/dosbox/Makefile1
-rw-r--r--emulators/dosbox/files/patch-src::dos::cdrom.h13
-rw-r--r--emulators/dosbox/files/patch-src::dos::cdrom_image.cpp20
3 files changed, 34 insertions, 0 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index 72c523284042..345e2cf6a68b 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dosbox
PORTVERSION= 0.62
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/emulators/dosbox/files/patch-src::dos::cdrom.h b/emulators/dosbox/files/patch-src::dos::cdrom.h
new file mode 100644
index 000000000000..a7c8b70b771d
--- /dev/null
+++ b/emulators/dosbox/files/patch-src::dos::cdrom.h
@@ -0,0 +1,13 @@
+--- src/dos/cdrom.h.orig Mon Oct 25 21:57:27 2004
++++ src/dos/cdrom.h Mon Oct 25 21:59:27 2004
+@@ -4,8 +4,9 @@
+
+ #define MAX_ASPI_CDROM 5
+
+-#include <string.h>
++#include <string>
+ #include <iostream>
++#include <fstream>
+ #include <vector>
+ #include "dosbox.h"
+ #include "mem.h"
diff --git a/emulators/dosbox/files/patch-src::dos::cdrom_image.cpp b/emulators/dosbox/files/patch-src::dos::cdrom_image.cpp
new file mode 100644
index 000000000000..d6f13eca4e62
--- /dev/null
+++ b/emulators/dosbox/files/patch-src::dos::cdrom_image.cpp
@@ -0,0 +1,20 @@
+--- src/dos/cdrom_image.cpp.orig Mon Oct 25 22:00:14 2004
++++ src/dos/cdrom_image.cpp Mon Oct 25 22:00:52 2004
+@@ -23,7 +23,7 @@
+ #include <cstdio>
+ #include <fstream>
+ #include <iostream>
+-#include <limits>
++/* #include <limits> */
+ #include <sstream>
+ #include <vector>
+ #include <sys/stat.h>
+@@ -572,7 +572,7 @@
+ if (stat(filename.c_str(), &test) == 0) return true;
+
+ // check if file with path relative to cue file exists
+-#if not defined(WIN32)
++#if !defined(WIN32)
+ string tmpstr(pathname + "/" + filename);
+ if (stat(tmpstr.c_str(), &test) == 0) {
+ filename = tmpstr;