aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/dosbox
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-05-30 15:02:51 +0800
committerclsung <clsung@FreeBSD.org>2006-05-30 15:02:51 +0800
commit8b4b9a9f164d9183dcd870710f9d3210c19b1da4 (patch)
tree74082fd7fdfb1600117a1ed6f6de962c7615213a /emulators/dosbox
parent8f03d105c7557b6e88f75be1768b10a33a780a09 (diff)
downloadfreebsd-ports-gnome-8b4b9a9f164d9183dcd870710f9d3210c19b1da4.tar.gz
freebsd-ports-gnome-8b4b9a9f164d9183dcd870710f9d3210c19b1da4.tar.zst
freebsd-ports-gnome-8b4b9a9f164d9183dcd870710f9d3210c19b1da4.zip
- Fix build on 4.x
PR: 97937 Submitted by: Shaun Amott <shaun_AT_inerd dot com> Approved by: maintainer
Diffstat (limited to 'emulators/dosbox')
-rw-r--r--emulators/dosbox/Makefile2
-rw-r--r--emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp11
2 files changed, 13 insertions, 0 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index 81ba8ee2b279..dea4fce93db6 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -27,6 +27,8 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --enable-core-inline
+USE_GCC= 3.2+
+
post-patch:
@${REINPLACE_CMD} -e 's#\/usr\/share\/doc\/dosbox#${DOCSDIR}#g' \
${WRKSRC}/docs/dosbox.1
diff --git a/emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp b/emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp
new file mode 100644
index 000000000000..9d276f8e9cad
--- /dev/null
+++ b/emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp
@@ -0,0 +1,11 @@
+--- src/cpu/core_dyn_x86.cpp.orig Thu Feb 9 12:32:52 2006
++++ src/cpu/core_dyn_x86.cpp Thu May 25 22:58:53 2006
+@@ -22,6 +22,8 @@
+
+ #define CHECKED_MEMORY_ACCESS
+
++#include <sys/types.h>
++
+ #include <assert.h>
+ #include <stdarg.h>
+ #include <stdio.h>