aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/dynamips-devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-26 16:38:14 +0800
committermiwi <miwi@FreeBSD.org>2009-09-26 16:38:14 +0800
commit9ec0b94cb17c65cc62dafa3fe006810e94068134 (patch)
tree7d401dfbc05464cbde4ae0ae1c9e1b888d2528d2 /emulators/dynamips-devel
parentb26b1f52efb53042b4e216ec3e23a290a3cd95bc (diff)
downloadfreebsd-ports-gnome-9ec0b94cb17c65cc62dafa3fe006810e94068134.tar.gz
freebsd-ports-gnome-9ec0b94cb17c65cc62dafa3fe006810e94068134.tar.zst
freebsd-ports-gnome-9ec0b94cb17c65cc62dafa3fe006810e94068134.zip
- Fix -m flag bug
- Update maintainer mail adress PR: 137297 Submitted by: Pavel I Volkov <pol@opk.ru> (maintainer) Feature safe: yes
Diffstat (limited to 'emulators/dynamips-devel')
-rw-r--r--emulators/dynamips-devel/Makefile4
-rw-r--r--emulators/dynamips-devel/files/patch-net.c10
2 files changed, 12 insertions, 2 deletions
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index d2b2b5ec9d6d..e249a3cf4215 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -7,12 +7,12 @@
PORTNAME= dynamips
DISTVERSION= 0.2.8-RC2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
PKGNAMESUFFIX= -devel
-MAINTAINER= pol@opk.ru
+MAINTAINER= pol@iib.ru
COMMENT= Cisco 1700/2600/3600/3700/7200 Simulator
LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
diff --git a/emulators/dynamips-devel/files/patch-net.c b/emulators/dynamips-devel/files/patch-net.c
new file mode 100644
index 000000000000..6fd2599d92d6
--- /dev/null
+++ b/emulators/dynamips-devel/files/patch-net.c
@@ -0,0 +1,10 @@
+--- net.c.orig 2009-07-20 16:23:20.000000000 +0400
++++ net.c 2009-07-20 16:24:14.000000000 +0400
+@@ -209,6 +209,7 @@
+ addr->eth_addr_byte[3] = v[1] & 0xFF;
+ addr->eth_addr_byte[4] = (v[2] >> 8) & 0xFF;
+ addr->eth_addr_byte[5] = v[2] & 0xFF;
++ return(0);
+ }
+
+ return(-1);