aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/frodo
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-07-06 17:05:17 +0800
committerdinoex <dinoex@FreeBSD.org>2003-07-06 17:05:17 +0800
commit6e3f3ab5d4430727df3b992538b9d2600eed3493 (patch)
treeb9c83b27603f4b38125d5bbf08edd6aed2a69987 /emulators/frodo
parent4395540f6f133f73c64395af203d309c070625b7 (diff)
downloadfreebsd-ports-gnome-6e3f3ab5d4430727df3b992538b9d2600eed3493.tar.gz
freebsd-ports-gnome-6e3f3ab5d4430727df3b992538b9d2600eed3493.tar.zst
freebsd-ports-gnome-6e3f3ab5d4430727df3b992538b9d2600eed3493.zip
- update to use tk84
Diffstat (limited to 'emulators/frodo')
-rw-r--r--emulators/frodo/Makefile5
-rw-r--r--emulators/frodo/files/patch-C64_x.i2
-rw-r--r--emulators/frodo/files/patch-TkGui.tcl2
3 files changed, 5 insertions, 4 deletions
diff --git a/emulators/frodo/Makefile b/emulators/frodo/Makefile
index f169e46d57f2..82044e6b552c 100644
--- a/emulators/frodo/Makefile
+++ b/emulators/frodo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= frodo
PORTVERSION= 4.1a
+PORTREVISION= 1
CATEGORIES= emulators tk83
MASTER_SITES= ftp://metalab.unc.edu/pub/micro/commodore/crossplatform/emulators/Frodo/ \
ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/Frodo/
@@ -15,7 +16,7 @@ DISTNAME= FrodoV4_1a.Src
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Emulates a Commodore 64
-RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
USE_X_PREFIX= yes
ALL_TARGET= Frodo
@@ -41,7 +42,7 @@ do-install:
${INSTALL_DATA} "${WRKDIR}/Frodo/${i} ROM" ${PREFIX}/libexec/frodo
.endfor
${INSTALL_DATA} "${WRKDIR}/Frodo/Frodo Logo" ${PREFIX}/libexec/frodo
- ${CP} "${WRKDIR}/Frodo/TkGui.tcl" ${PREFIX}/libexec/frodo
+ ${INSTALL_SCRIPT} "${WRKDIR}/Frodo/TkGui.tcl" ${PREFIX}/libexec/frodo
${MKDIR} ${PREFIX}/libexec/frodo/64prgs
@${TAR} -C ${WRKDIR}/Frodo/64prgs -cf - . | \
${TAR} -C ${PREFIX}/libexec/frodo/64prgs -xf -
diff --git a/emulators/frodo/files/patch-C64_x.i b/emulators/frodo/files/patch-C64_x.i
index a2b4a23d6673..b0948fc6dd93 100644
--- a/emulators/frodo/files/patch-C64_x.i
+++ b/emulators/frodo/files/patch-C64_x.i
@@ -5,7 +5,7 @@
#else
// try to start up Tk gui.
- gui = new CmdPipe("wish", "TkGui.tcl");
-+ gui = new CmdPipe("wish8.3", "TkGui.tcl");
++ gui = new CmdPipe("wish8.4", "TkGui.tcl");
if (gui) {
if (gui->fail) {
delete gui; gui = 0;
diff --git a/emulators/frodo/files/patch-TkGui.tcl b/emulators/frodo/files/patch-TkGui.tcl
index fcefa38ad682..cf8c2d7d675a 100644
--- a/emulators/frodo/files/patch-TkGui.tcl
+++ b/emulators/frodo/files/patch-TkGui.tcl
@@ -2,7 +2,7 @@
+++ ../TkGui.tcl Mon Apr 26 21:49:18 1999
@@ -1,9 +1,9 @@
-#!/usr/local/bin/X11/wish
-+#!%%LOCALBASE%%/bin/wish8.3 -f
++#!%%LOCALBASE%%/bin/wish8.4 -f
# Frodo Tk GUI by Lutz Vieweg <lkv@mania.robin.de>
# requires Tk >= 4.1