aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/frodo
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-06-23 21:44:03 +0800
committersobomax <sobomax@FreeBSD.org>2000-06-23 21:44:03 +0800
commit75802943a41a8d04904b4f8f73577c1e1f41bd19 (patch)
treecdb15359f6b17edd36ab0ef3a40572e8e1afb2d9 /emulators/frodo
parent8ec81ff63c63edeff820bab082cf56a6e9155929 (diff)
downloadfreebsd-ports-gnome-75802943a41a8d04904b4f8f73577c1e1f41bd19.tar.gz
freebsd-ports-gnome-75802943a41a8d04904b4f8f73577c1e1f41bd19.tar.zst
freebsd-ports-gnome-75802943a41a8d04904b4f8f73577c1e1f41bd19.zip
- Support LOCALBASE properly (in setting path to custom wish script)
PR: 19470 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'emulators/frodo')
-rw-r--r--emulators/frodo/Makefile9
-rw-r--r--emulators/frodo/files/patch-TkGui.tcl2
2 files changed, 7 insertions, 4 deletions
diff --git a/emulators/frodo/Makefile b/emulators/frodo/Makefile
index 411e5b7ab65e..576c93e7d6c3 100644
--- a/emulators/frodo/Makefile
+++ b/emulators/frodo/Makefile
@@ -8,7 +8,7 @@
PORTNAME= frodo
PORTVERSION= 4.1a
CATEGORIES= emulators tk82
-MASTER_SITES= ftp://sunsite.unc.edu/pub/micro/commodore/crossplatform/emulators/unix/
+MASTER_SITES= ftp://metalab.unc.edu/pub/micro/commodore/crossplatform/emulators/unix/
DISTNAME= FrodoV4_1a.Src
MAINTAINER= dirk.meyer@dinoex.sub.org
@@ -21,6 +21,9 @@ WRKSRC= ${WRKDIR}/Frodo/Src
ROM= 1541 Basic Char Kernal
+post-patch:
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKDIR}/Frodo/TkGui.tcl
+
do-configure:
@(cd ${WRKSRC}; ${SH} ./configure)
@@ -36,7 +39,7 @@ do-install:
${INSTALL_DATA} "${WRKDIR}/Frodo/Frodo Logo" ${PREFIX}/libexec/frodo
${CP} "${WRKDIR}/Frodo/TkGui.tcl" ${PREFIX}/libexec/frodo
${MKDIR} ${PREFIX}/libexec/frodo/64prgs
- @cd ${WRKDIR}/Frodo/64prgs; tar cf - . | (cd ${PREFIX}/libexec/frodo/64prgs; tar xf -)
+ @(${TAR} -C ${WRKDIR}/Frodo/64prgs -cf - . | ${TAR} -C ${PREFIX}/libexec/frodo/64prgs -xf -
post-install:
.if !defined(NOPORTDOCS)
@@ -44,7 +47,7 @@ post-install:
.for i in CHANGES
${INSTALL_DATA} ${WRKDIR}/Frodo/${i} ${PREFIX}/share/doc/frodo
.endfor
- @cd ${WRKDIR}/Frodo/Docs; tar cf - . | (cd ${PREFIX}/share/doc/frodo; tar xf -)
+ @(${TAR} -C ${WRKDIR}/Frodo/Docs -cf - . | ${TAR} -C ${PREFIX}/share/doc/frodo -xf -)
.endif
.include <bsd.port.mk>
diff --git a/emulators/frodo/files/patch-TkGui.tcl b/emulators/frodo/files/patch-TkGui.tcl
index 6a94e3408dbc..5aae3b731caf 100644
--- a/emulators/frodo/files/patch-TkGui.tcl
+++ b/emulators/frodo/files/patch-TkGui.tcl
@@ -2,7 +2,7 @@
+++ ../TkGui.tcl Mon Apr 26 21:49:18 1999
@@ -1,9 +1,9 @@
-#!/usr/local/bin/X11/wish
-+#!/usr/local/bin/wish8.2 -f
++#!%%LOCALBASE%%/bin/wish8.2 -f
# Frodo Tk GUI by Lutz Vieweg <lkv@mania.robin.de>
# requires Tk >= 4.1