aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/fuse
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-09-24 00:42:30 +0800
committerrene <rene@FreeBSD.org>2013-09-24 00:42:30 +0800
commit1d4670642d53a71a6498e636858fee48f50f40aa (patch)
tree5721582639406da27f4f0b7d1345bea1efd4c7a4 /emulators/fuse
parent6c5ed293f57ce3e8f964e275ff12675a3d53bc22 (diff)
downloadfreebsd-ports-gnome-1d4670642d53a71a6498e636858fee48f50f40aa.tar.gz
freebsd-ports-gnome-1d4670642d53a71a6498e636858fee48f50f40aa.tar.zst
freebsd-ports-gnome-1d4670642d53a71a6498e636858fee48f50f40aa.zip
Let my ports pass 'make check-sanity' by using modern LIB_DEPENDS
Diffstat (limited to 'emulators/fuse')
-rw-r--r--emulators/fuse/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 33bf066b3d32..f4a51e4f535f 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -11,9 +11,9 @@ COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
LICENSE= GPLv2
-LIB_DEPENDS= spectrum:${PORTSDIR}/emulators/libspectrum \
- png15:${PORTSDIR}/graphics/png \
- gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libspectrum.so:${PORTSDIR}/emulators/libspectrum \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USES= pkgconfig
@@ -35,13 +35,13 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MAO}
CONFIGURE_ARGS+=--with-libao
-LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= libao.so:${PORTSDIR}/audio/libao
.else
CONFIGURE_ARGS+=--without-libao
.endif
.if ${PORT_OPTIONS:MSAMPLERATE}
-LIB_DEPENDS+= samplerate:${PORTSDIR}/audio/libsamplerate
+LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+=--without-libsamplerate
.endif