aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/fuse
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-11 03:33:16 +0800
committermiwi <miwi@FreeBSD.org>2007-04-11 03:33:16 +0800
commit744e8c31a4457df9e8c2c4ddc672b0f013516546 (patch)
tree332fc54b50f95be99c36133a047285bba7c9d3ba /emulators/fuse
parentde46f08ba2851c6c428ae346292c40499eb5b8ec (diff)
downloadfreebsd-ports-gnome-744e8c31a4457df9e8c2c4ddc672b0f013516546.tar.gz
freebsd-ports-gnome-744e8c31a4457df9e8c2c4ddc672b0f013516546.tar.zst
freebsd-ports-gnome-744e8c31a4457df9e8c2c4ddc672b0f013516546.zip
- Fix build with gcc 4.1
PR: 111030 Submitted by: Alexey Antipovsky<kemm@in-line.ru> (maintainer)
Diffstat (limited to 'emulators/fuse')
-rw-r--r--emulators/fuse/Makefile2
-rw-r--r--emulators/fuse/files/patch-sound.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 51d76ca63a02..cb29bde4018c 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fuse
PORTVERSION= 0.7.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fuse-emulator
diff --git a/emulators/fuse/files/patch-sound.c b/emulators/fuse/files/patch-sound.c
new file mode 100644
index 000000000000..9f5a596a1d1a
--- /dev/null
+++ b/emulators/fuse/files/patch-sound.c
@@ -0,0 +1,13 @@
+--- sound.c.orig Thu Mar 29 16:09:24 2007
++++ sound.c Thu Mar 29 16:09:50 2007
+@@ -58,8 +58,8 @@
+ int sound_stereo_ay_abc=0; /* (AY stereo) true for ABC stereo, else ACB */
+ int sound_stereo_ay_narrow=0; /* (AY stereo) true for narrow AY st. sep. */
+
+-static int sound_stereo_ay=0; /* local copy of settings_current.stereo_ay */
+-static int sound_stereo_beeper=0; /* and settings_current.stereo_beeper */
++int sound_stereo_ay=0; /* local copy of settings_current.stereo_ay */
++int sound_stereo_beeper=0; /* and settings_current.stereo_beeper */
+
+
+ /* assume all three tone channels together match the beeper volume (ish).