aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/gxemul
diff options
context:
space:
mode:
authorimp <imp@FreeBSD.org>2014-02-26 04:32:40 +0800
committerimp <imp@FreeBSD.org>2014-02-26 04:32:40 +0800
commitdc2255dbca05f67e201eee73a22856ebba19d52c (patch)
treeb12e6d12d5b094ef546229da25332b080263c972 /emulators/gxemul
parent20a23cbd312c1d6d2488fa91b3ec3b12813519d1 (diff)
downloadfreebsd-ports-gnome-dc2255dbca05f67e201eee73a22856ebba19d52c.tar.gz
freebsd-ports-gnome-dc2255dbca05f67e201eee73a22856ebba19d52c.tar.zst
freebsd-ports-gnome-dc2255dbca05f67e201eee73a22856ebba19d52c.zip
Force gcc, since gxemul isn't clang ready yet.
Fix for building with gcc 4.6 due to slight differences in namespace pollution.
Diffstat (limited to 'emulators/gxemul')
-rw-r--r--emulators/gxemul/Makefile2
-rw-r--r--emulators/gxemul/files/patch-ab11
2 files changed, 13 insertions, 0 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 751f65daf186..09883bdfe906 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -22,6 +22,8 @@ MAN1= gxemul.1
PORTDOCS= *
PLIST_FILES= bin/gxemul
+USE_GCC= yes
+
# svgalib installs vga.h, which conflicts with gxemul when building with
# a virtual VGA adaptor.
CONFLICTS= svgalib-[0-9]*
diff --git a/emulators/gxemul/files/patch-ab b/emulators/gxemul/files/patch-ab
new file mode 100644
index 000000000000..aa155710ce96
--- /dev/null
+++ b/emulators/gxemul/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/include/refcount_ptr.h 2010-02-14 02:33:54.000000000 -0700
++++ src/include/refcount_ptr.h 2014-02-24 03:48:14.000000000 -0700
+@@ -28,6 +28,8 @@
+ * SUCH DAMAGE.
+ */
+
++#include <stddef.h>
++
+ /**
+ * \brief Base class for reference countable objects.
+ *