aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/gxemul
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-01 05:46:24 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-01 05:46:24 +0800
commitaa94c5e62d193db37b22646502801346e84ba294 (patch)
treed41e6288f30544fe0b1745abdd33d04565eceeab /emulators/gxemul
parent97bdce7188fc794c8e6a94a55f456fe82ce7e1b2 (diff)
downloadfreebsd-ports-gnome-aa94c5e62d193db37b22646502801346e84ba294.tar.gz
freebsd-ports-gnome-aa94c5e62d193db37b22646502801346e84ba294.tar.zst
freebsd-ports-gnome-aa94c5e62d193db37b22646502801346e84ba294.zip
- Switch to options helpers
- Regenerate patches with `make makepatch`
Diffstat (limited to 'emulators/gxemul')
-rw-r--r--emulators/gxemul/Makefile10
-rw-r--r--emulators/gxemul/files/patch-src_devices_dev__wdc.cc (renamed from emulators/gxemul/files/patch-src_devices_dev_wdc.cc)8
-rw-r--r--emulators/gxemul/files/patch-src_include_refcount__ptr.h11
-rw-r--r--emulators/gxemul/files/patch-src_include_refcount_ptr.h11
4 files changed, 21 insertions, 19 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 7f9d4f446d36..336d343553c1 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -40,10 +40,12 @@ post-patch:
/CXXFLAGS=/s|-f[a-zA-Z-]+||g' ${WRKSRC}/configure
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} gxemul \
- ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/man && ${INSTALL_MAN} gxemul.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1)
+ ${INSTALL_PROGRAM} ${WRKSRC}/gxemul \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/gxemul.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . \
${STAGEDIR}${DOCSDIR})
diff --git a/emulators/gxemul/files/patch-src_devices_dev_wdc.cc b/emulators/gxemul/files/patch-src_devices_dev__wdc.cc
index 752e7f318aae..fc921947292f 100644
--- a/emulators/gxemul/files/patch-src_devices_dev_wdc.cc
+++ b/emulators/gxemul/files/patch-src_devices_dev__wdc.cc
@@ -1,6 +1,6 @@
---- src/devices/dev_wdc.cc.orig 2013-06-27 18:10:50.000000000 -0700
-+++ src/devices/dev_wdc.cc 2013-06-27 18:11:13.000000000 -0700
-@@ -274,12 +274,12 @@
+--- src/devices/dev_wdc.cc.orig 2014-08-17 08:45:12 UTC
++++ src/devices/dev_wdc.cc
+@@ -274,12 +274,12 @@ void wdc__read(struct cpu *cpu, struct w
+ (int64_t)d->head * d->sectors_per_track[d->drive] +
(int64_t)d->heads[d->drive] * d->sectors_per_track[d->drive] * cyl);
@@ -15,7 +15,7 @@
#endif
while (count > 0) {
-@@ -320,12 +320,12 @@
+@@ -320,12 +320,12 @@ void wdc__write(struct cpu *cpu, struct
uint64_t offset = 512 * (d->sector - 1
+ (int64_t)d->head * d->sectors_per_track[d->drive] +
(int64_t)d->heads[d->drive] * d->sectors_per_track[d->drive] * cyl);
diff --git a/emulators/gxemul/files/patch-src_include_refcount__ptr.h b/emulators/gxemul/files/patch-src_include_refcount__ptr.h
new file mode 100644
index 000000000000..991a95cc9430
--- /dev/null
+++ b/emulators/gxemul/files/patch-src_include_refcount__ptr.h
@@ -0,0 +1,11 @@
+--- src/include/refcount_ptr.h.orig 2014-08-17 08:45:13 UTC
++++ src/include/refcount_ptr.h
+@@ -33,6 +33,8 @@ template <class T>
+ class refcount_ptr;
+
+
++#include <stddef.h>
++
+ /**
+ * \brief Base class for reference countable objects.
+ *
diff --git a/emulators/gxemul/files/patch-src_include_refcount_ptr.h b/emulators/gxemul/files/patch-src_include_refcount_ptr.h
deleted file mode 100644
index aa155710ce96..000000000000
--- a/emulators/gxemul/files/patch-src_include_refcount_ptr.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/include/refcount_ptr.h 2010-02-14 02:33:54.000000000 -0700
-+++ src/include/refcount_ptr.h 2014-02-24 03:48:14.000000000 -0700
-@@ -28,6 +28,8 @@
- * SUCH DAMAGE.
- */
-
-+#include <stddef.h>
-+
- /**
- * \brief Base class for reference countable objects.
- *