aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/higan
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-08-27 17:09:19 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-08-27 17:09:19 +0800
commitcef8d328ffd31462e3a5b2f000beb2b016c7d644 (patch)
tree006b493774d984d5b58b0719d4c5c2c3f887501a /emulators/higan
parenteb8927cf96a11cd467d1493e47d44e1f4f1d6f5d (diff)
downloadfreebsd-ports-gnome-cef8d328ffd31462e3a5b2f000beb2b016c7d644.tar.gz
freebsd-ports-gnome-cef8d328ffd31462e3a5b2f000beb2b016c7d644.tar.zst
freebsd-ports-gnome-cef8d328ffd31462e3a5b2f000beb2b016c7d644.zip
- Pet portlint, switch to options helpers
PR: 202532 Submitted by: cyberbotx@cyberbotx.com (maintainer)
Diffstat (limited to 'emulators/higan')
-rw-r--r--emulators/higan/Makefile12
-rw-r--r--emulators/higan/files/patch-nall-platform.hpp6
-rw-r--r--emulators/higan/files/patch-ruby__video__glx.cpp6
-rw-r--r--emulators/higan/files/patch-shaders22
-rw-r--r--emulators/higan/files/patch-target-ethos-Makefile6
-rw-r--r--emulators/higan/files/patch-target-ethos_general_presentation.cpp11
-rw-r--r--emulators/higan/files/patch-target-ethos_utility_utility.cpp11
7 files changed, 36 insertions, 38 deletions
diff --git a/emulators/higan/Makefile b/emulators/higan/Makefile
index 662745c94095..b95cd35dd7b3 100644
--- a/emulators/higan/Makefile
+++ b/emulators/higan/Makefile
@@ -16,7 +16,6 @@ USES= compiler:c++11-lib gmake pkgconfig tar:xz
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
-#MAKE_ENV+= c="${CC} -std=gnu99" cpp="${CXX} -std=gnu++0x"
MAKE_ENV+= compiler="${CXX}" cflags="-x c -std=c99 ${CFLAGS}" \
cppflags="-x c++ -std=c++11 ${CXXFLAGS}"
@@ -118,19 +117,18 @@ post-patch:
${WRKSRC}/target-ethos/Makefile
${REINPLACE_CMD} -e 's|/usr/share/|${PREFIX}/share/|' \
${WRKSRC}/nall/string/platform.hpp
-.if ${PORT_OPTIONS:MDEBUG}
+
+post-patch-DEBUG-on:
${REINPLACE_CMD} -e 's|-O3|-g|g' \
${WRKSRC}/ananke/Makefile \
${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's|:= -s|:= #|g' \
${WRKSRC}/Makefile
-.endif
-# ${RM} ${WRKSRC}/shaders/Sepia.Direct3D.shader
-do-build:
-.if ${PORT_OPTIONS:MQT4}
+pre-build-QT4-on:
(cd ${WRKSRC}/phoenix/qt && ${MOC} -i -o platform.moc platform.moc.hpp)
-.endif
+
+do-build:
.for d in . ananke
(cd ${WRKSRC}/${d} && ${MAKE_CMD} ${MAKE_ENV})
.endfor
diff --git a/emulators/higan/files/patch-nall-platform.hpp b/emulators/higan/files/patch-nall-platform.hpp
index c16fa0e80fa3..89c08865fbd3 100644
--- a/emulators/higan/files/patch-nall-platform.hpp
+++ b/emulators/higan/files/patch-nall-platform.hpp
@@ -1,6 +1,6 @@
---- ./nall/platform.hpp.orig 2014-03-16 21:33:25.000000000 -0400
-+++ ./nall/platform.hpp 2014-03-16 21:45:07.000000000 -0400
-@@ -41,7 +41,7 @@
+--- nall/platform.hpp.orig 2014-01-20 06:37:12 UTC
++++ nall/platform.hpp
+@@ -41,7 +41,7 @@ namespace Math {
#undef interface
#define dllexport __declspec(dllexport)
#else
diff --git a/emulators/higan/files/patch-ruby__video__glx.cpp b/emulators/higan/files/patch-ruby__video__glx.cpp
index a45d0151a80f..2030d21ec8cc 100644
--- a/emulators/higan/files/patch-ruby__video__glx.cpp
+++ b/emulators/higan/files/patch-ruby__video__glx.cpp
@@ -1,6 +1,6 @@
---- ./ruby/video/glx.cpp.orig 2014-01-20 01:37:14.000000000 -0500
-+++ ./ruby/video/glx.cpp 2014-06-02 23:32:39.000000000 -0400
-@@ -128,6 +128,28 @@
+--- ruby/video/glx.cpp.orig 2014-01-20 06:37:14 UTC
++++ ruby/video/glx.cpp
+@@ -128,6 +128,28 @@ struct pVideoGLX : OpenGL {
//require GLX 1.2+ API
if(glx.version_major < 1 || (glx.version_major == 1 && glx.version_minor < 2)) return false;
diff --git a/emulators/higan/files/patch-shaders b/emulators/higan/files/patch-shaders
deleted file mode 100644
index e14b2cd4aad2..000000000000
--- a/emulators/higan/files/patch-shaders
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./target-ethos/general/presentation.cpp.orig 2013-12-06 15:19:40.000000000 -0500
-+++ ./target-ethos/general/presentation.cpp 2014-03-16 22:40:31.000000000 -0400
-@@ -235,7 +235,7 @@
- void Presentation::loadShaders() {
- //only the OpenGL driver has video shader support
- if(config->video.driver == "OpenGL") {
-- string pathname = program->path("Video Shaders/");
-+ string pathname = program->path("shaders/");
- lstring shaders = directory::folders(pathname, "*.shader");
- for(auto& name : shaders) {
- auto shader = new RadioItem;
---- ./target-ethos/utility/utility.cpp.orig 2013-12-21 02:00:03.000000000 -0500
-+++ ./target-ethos/utility/utility.cpp 2014-03-16 22:41:03.000000000 -0400
-@@ -203,7 +203,7 @@
- video.set(Video::Filter, Video::FilterLinear);
- } else if(config->video.shader == "Display Emulation") {
- if(program->active) {
-- string pathname = program->path("Video Shaders/");
-+ string pathname = program->path("shaders/");
- pathname.append("Display Emulation/");
- pathname.append(presentation->systemName, ".shader/");
- if(directory::exists(pathname)) {
diff --git a/emulators/higan/files/patch-target-ethos-Makefile b/emulators/higan/files/patch-target-ethos-Makefile
index ae089f537874..de0f4369168e 100644
--- a/emulators/higan/files/patch-target-ethos-Makefile
+++ b/emulators/higan/files/patch-target-ethos-Makefile
@@ -1,6 +1,6 @@
---- ./target-ethos/Makefile.orig 2014-01-13 00:26:29.000000000 -0500
-+++ ./target-ethos/Makefile 2014-03-16 21:57:02.000000000 -0400
-@@ -27,9 +27,9 @@
+--- target-ethos/Makefile.orig 2014-01-13 05:26:29 UTC
++++ target-ethos/Makefile
+@@ -27,9 +27,9 @@ else ifeq ($(platform),linux)
ruby += audio.alsa audio.openal audio.oss audio.pulseaudio audio.pulseaudiosimple audio.ao
ruby += input.udev input.sdl input.x
else ifeq ($(platform),bsd)
diff --git a/emulators/higan/files/patch-target-ethos_general_presentation.cpp b/emulators/higan/files/patch-target-ethos_general_presentation.cpp
new file mode 100644
index 000000000000..bd4a6d47f510
--- /dev/null
+++ b/emulators/higan/files/patch-target-ethos_general_presentation.cpp
@@ -0,0 +1,11 @@
+--- target-ethos/general/presentation.cpp.orig 2013-12-06 20:19:40 UTC
++++ target-ethos/general/presentation.cpp
+@@ -235,7 +235,7 @@ void Presentation::bootstrap() {
+ void Presentation::loadShaders() {
+ //only the OpenGL driver has video shader support
+ if(config->video.driver == "OpenGL") {
+- string pathname = program->path("Video Shaders/");
++ string pathname = program->path("shaders/");
+ lstring shaders = directory::folders(pathname, "*.shader");
+ for(auto& name : shaders) {
+ auto shader = new RadioItem;
diff --git a/emulators/higan/files/patch-target-ethos_utility_utility.cpp b/emulators/higan/files/patch-target-ethos_utility_utility.cpp
new file mode 100644
index 000000000000..6e3b23643054
--- /dev/null
+++ b/emulators/higan/files/patch-target-ethos_utility_utility.cpp
@@ -0,0 +1,11 @@
+--- target-ethos/utility/utility.cpp.orig 2013-12-21 07:00:03 UTC
++++ target-ethos/utility/utility.cpp
+@@ -203,7 +203,7 @@ void Utility::updateShader() {
+ video.set(Video::Filter, Video::FilterLinear);
+ } else if(config->video.shader == "Display Emulation") {
+ if(program->active) {
+- string pathname = program->path("Video Shaders/");
++ string pathname = program->path("shaders/");
+ pathname.append("Display Emulation/");
+ pathname.append(presentation->systemName, ".shader/");
+ if(directory::exists(pathname)) {