aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/hugo
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2007-11-03 01:55:22 +0800
committeraraujo <araujo@FreeBSD.org>2007-11-03 01:55:22 +0800
commit98058b07376afc9f6b140d9e579b9f1db9ef8376 (patch)
tree622a01159022ba878fac25bef4d5c4183a4d0045 /emulators/hugo
parent19122282e12db34260ac4b4e4f41f0b0eeea49cf (diff)
downloadfreebsd-ports-gnome-98058b07376afc9f6b140d9e579b9f1db9ef8376.tar.gz
freebsd-ports-gnome-98058b07376afc9f6b140d9e579b9f1db9ef8376.tar.zst
freebsd-ports-gnome-98058b07376afc9f6b140d9e579b9f1db9ef8376.zip
- Mark unbroken.
- Fix build on non-i386. - Fix build with gcc-4.2. PR: ports/117054 Submitted by: Li-Lun Wang <llwang@infor.org> (maintainer) Approved by: portmgr (erwin), itetcu (mentor, implicit)
Diffstat (limited to 'emulators/hugo')
-rw-r--r--emulators/hugo/Makefile12
-rw-r--r--emulators/hugo/files/patch-configure15
-rw-r--r--emulators/hugo/files/patch-pce.c11
3 files changed, 24 insertions, 14 deletions
diff --git a/emulators/hugo/Makefile b/emulators/hugo/Makefile
index 2e2c3554cca6..b493308e9605 100644
--- a/emulators/hugo/Makefile
+++ b/emulators/hugo/Makefile
@@ -56,14 +56,4 @@ MAKE_ENV+= PORTDOCS=true
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.if ${ARCH} != "i386"
-BROKEN= fails to install
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/hugo/files/patch-configure b/emulators/hugo/files/patch-configure
index e091c8d8495d..d2c6dd550136 100644
--- a/emulators/hugo/files/patch-configure
+++ b/emulators/hugo/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Tue Apr 5 14:28:53 2005
-+++ configure Fri May 19 02:02:42 2006
+--- configure.orig 2005-04-05 14:28:53.000000000 -0500
++++ configure 2007-10-09 21:55:43.000000000 -0500
@@ -3256,7 +3256,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -27,7 +27,16 @@
then
-@@ -8675,7 +8675,36 @@
+@@ -8657,7 +8659,7 @@
+
+ fi
+ ;;
+- i386-FreeBSD)
++ *-FreeBSD)
+ echo "FreeBSD build enabled"
+
+ HUGO_TARGET_MACHINE="FREEBSD"
+@@ -8675,6 +8677,35 @@
SDL_FREEBSD_FALSE=
fi
diff --git a/emulators/hugo/files/patch-pce.c b/emulators/hugo/files/patch-pce.c
new file mode 100644
index 000000000000..56aedae4cfb4
--- /dev/null
+++ b/emulators/hugo/files/patch-pce.c
@@ -0,0 +1,11 @@
+--- pce.c.orig 2005-03-28 08:17:45.000000000 -0600
++++ pce.c 2007-10-09 21:32:50.000000000 -0500
+@@ -358,7 +358,7 @@
+ int UPeriod = 0;
+ // Number of frame to skip
+
+-static int BaseClock;
++int BaseClock;
+
+ UChar video_driver = 0;
+ /* 0 => Normal driver, normal display