aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/i386-wine-devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-09-01 21:03:25 +0800
committerbapt <bapt@FreeBSD.org>2014-09-01 21:03:25 +0800
commit90c29cca255cfd1665d8132e185fa401329ad673 (patch)
treeb8124e1b26d3492a2efdf76a075756366da04991 /emulators/i386-wine-devel
parentd0966178b740c628954c7eb37143a02d12fefe0e (diff)
downloadfreebsd-ports-gnome-90c29cca255cfd1665d8132e185fa401329ad673.tar.gz
freebsd-ports-gnome-90c29cca255cfd1665d8132e185fa401329ad673.tar.zst
freebsd-ports-gnome-90c29cca255cfd1665d8132e185fa401329ad673.zip
Remove support for pkg_install
Merge back bsd.pkgng.mk into bsd.port.mk Add a note about @stopdaemon not being supported anymore With hat: portmgr Differential Revision: https://reviews.freebsd.org/D693
Diffstat (limited to 'emulators/i386-wine-devel')
-rw-r--r--emulators/i386-wine-devel/Makefile.i38616
1 files changed, 5 insertions, 11 deletions
diff --git a/emulators/i386-wine-devel/Makefile.i386 b/emulators/i386-wine-devel/Makefile.i386
index 6d5be147f031..e6a29c6fc1ff 100644
--- a/emulators/i386-wine-devel/Makefile.i386
+++ b/emulators/i386-wine-devel/Makefile.i386
@@ -70,11 +70,7 @@ post-install-script:
done
echo '@dirrm lib32/.libGL/dri' >> ${TMPPLIST}
echo '@dirrm lib32/.libGL' >> ${TMPPLIST}
- if [ -n "${WITH_PKGNG}" ]; then \
- echo '@dirrmtry lib32' >> ${TMPPLIST}; \
- else \
- echo '@unexec rmdir %D/lib32 2>/dev/null || true' >> ${TMPPLIST}; \
- fi
+ echo '@dirrmtry lib32' >> ${TMPPLIST}; \
echo '@dirrm bin32' >> ${TMPPLIST}
# Install nvidia patching script
${INSTALL_SCRIPT} ${SLAVEDIR}/files/nvidia.sh ${STAGEDIR}${DATADIR}/patch-nvidia.sh
@@ -82,11 +78,9 @@ post-install-script:
@${CAT} ${PKGMESSAGE}
post-package-script:
- if [ -n "${WITH_PKGNG}" -a -z "${PACKAGE_BUILDING}" ]; then \
- ${XZ_CMD} -dc ${PKGFILE} | \
- ${SED} -e 's/\(freebsd:.*:x86\):32/\1:64/' -e 's/\(freebsd:.*:x86\):32/\1:64/' | \
- ${XZ_CMD} > ${WRKDIR}/${PKGNAME}${PKG_SUFX}; \
- ${MV} ${WRKDIR}/${PKGNAME}${PKG_SUFX} ${PKGFILE}; \
- fi
+ ${XZ_CMD} -dc ${PKGFILE} | \
+ ${SED} -e 's/\(freebsd:.*:x86\):32/\1:64/' -e 's/\(freebsd:.*:x86\):32/\1:64/' | \
+ ${XZ_CMD} > ${WRKDIR}/${PKGNAME}${PKG_SUFX}; \
+ ${MV} ${WRKDIR}/${PKGNAME}${PKG_SUFX} ${PKGFILE}; \
.include "${MASTERDIR}/Makefile"